VirtualBox

Ticket #6249 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

guest hangs if pressing the left CTRL key several seconds, it recovers after releasing the key

Reported by: mhanor Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Host: XP SP3 32 bit, E6400 Guests: * 1st - XP SP3 32 bit, guest additions installed, 2D+3D acceleration enabled, then disabled; VT-X enabled, then disabled; NX enabled, then disabled; network bridged on, then off; usb off; audio null, then off; even with all of them off * 2nd - Windows 7 Ultimate 64 bit, no guest additions, 2D+3D acceleration off; VT-X and NX enabled; usb off; audio null; network briged on; even during its install (see log)

The host key is set to right CTRL. When pressing left CTRL, the guest freezes. If mouse integration is disabled, the guest's cursor freezes, if not, you are able to move it, but can't interract with the freezed guest. To better observe this, use the guest cursor to trigger a hovering effect inside the guest, or open a text editor and observe the blinking text cursor. The guest recovers only when releasing the left CTRL key.

Attachments

VBox.log Download (35.6 KB) - added by mhanor 4 years ago.
3.1.4 log during win7 64 bit install, not that helpful

Change History

Changed 4 years ago by mhanor

3.1.4 log during win7 64 bit install, not that helpful

comment:1 Changed 4 years ago by mhanor

sometimes it freezes after 2 seconds, sometimes after 10-15 seconds I can reproduce it most of the times, sometimes I have to try a little harder try moving the mouse cursor, while trying to reproduce it

comment:2 Changed 4 years ago by mhanor

I can reproduce it on a 2nd host machine: Athlon64 3500+ single core, XP SP3 32 bit, AMD-V and NX enabled, no audio, no usb, no 2D and no 3D acceleration, no guest additions, one network adapter (bridged), guest Windows 7 Ultimate 64 bit (even during install)

comment:3 Changed 4 years ago by mhanor

keyboard&mouse input must be captured by the guest I discovered it when I was trying to individually select multiple objects in the guest, using the CTRL functionality of Windows Explorer

comment:4 Changed 4 years ago by mhanor

it doesn't have 100% reproducibility while you have captured the keyboard and mouse input, hold left CTRL while moving the guest mouse cursor; if you pressed it longer than 10-15 sec without success, release the left CTRL key, then hold it again and play with the cursor; after a few failed attempts, use the host key to loose the guest keyboard&mouse input capture, then recapture it and retry

comment:5 Changed 4 years ago by mhanor

test test2

test3

ps: I hate how it looses the "new line" when adding a reply

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Sounds like a duplicate of #5375, correct?

Regarding your last comment: Did you every consider to read the Wiki formatting rules?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use