VirtualBox

Ticket #5253 (closed defect: duplicate)

Opened 5 years ago

Last modified 22 months ago

Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION; VMMRZCallRing3)

Reported by: rf Owned by:
Priority: blocker Component: VMM
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

I'm using VirtualBox on 3 different machines (IBM 440 BX) and get a similar problem on all of them. The virtual machine is a web server answering HTTP queries, when it died. Nothing special (like big load) is known.

Host is running Fedora 9: 2.6.25.9-76.fc9.i686.PAE Guest is Fedora 5.

Attachments

fc5-www.reinform.de-2009-10-19-13-45-04.log Download (180.5 KB) - added by rf 5 years ago.
VBox.log
mantis.loef.reinform.de-2009-10-25-04-52-29.log Download (228.4 KB) - added by rf 4 years ago.
Another Log after Update to 3.0.8 on similar guest on identical host
VBox.log.1 Download (306.5 KB) - added by sandervl73 4 years ago.
Another occurance
sol11x-guru-VBox.log.gz Download (97.5 KB) - added by th 3 years ago.
VBox.log.gz Download (85.6 KB) - added by tilmann.bubeck 22 months ago.
Crash with VirtualBox-4.1.18

Change History

Changed 5 years ago by rf

VBox.log

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Update to 3.0.8 please. This should be fixed by now.

Changed 4 years ago by rf

Another Log after Update to 3.0.8 on similar guest on identical host

comment:2 Changed 4 years ago by rf

  • Status changed from closed to reopened
  • Resolution fixed deleted

I updated to 3.0.8 as you requested. But still I got the same -2701 guru meditation than before. The problem occurs on the same host but in a different guest. Before the update to 3.0.8 I saw this problem on a number of hosts of the same hardware architecture. I'm not yet sure, how often they will come in 3.0.8.

Any ideas or suggestions?

comment:3 Changed 4 years ago by sandervl73

I will add some more diagnostics and send you a private build to test if you wish.

comment:4 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 3.0.2 to VirtualBox 3.0.8

comment:5 Changed 4 years ago by rf

Yes, I would welcome this very much and give the feedback back.

(Gruesse nach Endersbach..., wo ich aufgewachsen bin :-))

Changed 4 years ago by sandervl73

Another occurance

comment:6 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 3.0.8 to VirtualBox 3.1.2

Attached a similar report with 3.1.2.

comment:7 Changed 4 years ago by sandervl73

Duplicates #4497, #4858, #4809, #5081

comment:8 Changed 4 years ago by sandervl73

  • Priority changed from major to blocker

comment:9 Changed 4 years ago by frank

  • Summary changed from Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION) on linux host/guest to Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION; VMMRZCallRing3)

comment:10 Changed 4 years ago by frank

  • Component changed from other to VMM

comment:11 Changed 4 years ago by frank

Guys, we are still searching an easy way to reproduce this Guru meditation.

comment:12 Changed 3 years ago by th

this happens to me as well in 4.0.4 on Solaris 11 Express

Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION)

4.0-sol-rel/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2476) int pgmPoolMonitorInsert(PGMPOOL*, PGMPOOLPAGE*)

i'll attach the full log, please let me know if i can help by providing more data.

th
--

Changed 3 years ago by th

comment:13 Changed 3 years ago by frank

th, any change with VBox 4.0.6?

comment:14 Changed 3 years ago by th

sorry - i reduced the amount of guest-RAM to 8192MB and the problems went away.

as this VM is now in quasi-production it is hard to change it back to more RAM to reproduce the problem. perhaps i will have that chance in some maintenance window within the next weeks.

th
--

comment:15 Changed 3 years ago by th

frank, i finally had a chance to update to 4.0.6

i set the memory amount 16384MB and started the VM. it was running fine first, but this morning with users on it i got the Guru Meditation -2701 (VERR_VMM_RING0_ASSERTION) again.

Location : /export/home/vbox/tinderbox/4.0-sol-rel/src/VBox/VMM/VMMAll/PGMAllPool.cpp(2476) int pgmPoolMonitorInsert(PGMPOOL*, PGMPOOLPAGE*)

th
--

comment:16 Changed 22 months ago by tilmann.bubeck

I was the original reporter (rf, changed through SSO).

The same problem still persists iff the guest is running with 16 GB RAM. If I change memory to 8 GB everything is working fine.

Host: Linux vmserver10.loef.reinform.de 2.6.32.23-170.fc12.x86_64 #1 SMP Mon Sep 27 17:23:59 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Guest: Linux skillbase-prod64.loef.reinform.de 2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

VirtualBox-4.1.18 (64 bit)

... and the problem is 100% reproducible. The guest crashes after 2-4 hours.

Last edited 22 months ago by tilmann.bubeck (previous) (diff)

Changed 22 months ago by tilmann.bubeck

Crash with VirtualBox-4.1.18

comment:17 Changed 22 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #10745. Please read the advise there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use