VirtualBox

Ticket #4940 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Crash installing Win2008 (cRefs == PGMPOOL_TD_CREFS_PHYSEXT guru) -> fixed in SVN/3.1.6

Reported by: _Pierre_ Owned by:
Component: VMM Version: VirtualBox 3.0.4
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

VM crashed during installation of Windows 2008

Attachments

VBox.log Download (156.2 KB) - added by _Pierre_ 10 years ago.
Windows 7-2010-03-10-18-42-34.log Download (42.9 KB) - added by sammy2ooo 10 years ago.

Change History

Changed 10 years ago by _Pierre_

comment:1 Changed 10 years ago by sandervl73

  • Summary changed from Crash installing Win2008 to Crash installing Win2008 (cRefs == PGMPOOL_TD_CREFS_PHYSEXT guru)

comment:2 Changed 10 years ago by frank

  • Component changed from installer to VMM

comment:3 Changed 10 years ago by frank

Bugs #6109, #4722 and #6340 have been marked as duplicate of this one.

comment:4 Changed 10 years ago by sandervl73

Let me know if you want to try out a build with a possible fix.

comment:5 Changed 10 years ago by sammy2ooo

i would like to test a possible fix. could you please attach it? btw: i am the OP of bug id 6109

comment:6 Changed 10 years ago by sandervl73

I can only provide you with a .run Linux installer, which might not be what you want. Windows builds are much easier. :)

comment:7 Changed 10 years ago by sammy2ooo

i am on Fedora x68_64 linux so a .run binary would be fine. could you please also have a look at  http://www.virtualbox.org/ticket/6109

Changed 10 years ago by sammy2ooo

comment:9 Changed 10 years ago by sammy2ooo

thanks for this test build. unfortunately my windows 7 crashes again.

this is what the log in my home dir shows.

Log created: 2010-03-10T17:42:34.867111000Z
Executable: /opt/VirtualBox/VirtualBox
Arg[0]: /opt/VirtualBox/VirtualBox
Arg[1]: --comment
Arg[2]: Windows 7
Arg[3]: --startvm
Arg[4]: ad2f532e-6c1f-4382-9964-d1d02c48409f
cRefs=0 pPhysPage=Z--:RAM:00011b089000:0000000:-0000 pPage=00007fbc115886d0:{.idx=342}

please also have a look at the attached log file

comment:10 Changed 10 years ago by sandervl73

sammy2ooo: can you always reproduce this guru meditation? If so, is it possible to get access to your VDI?

comment:11 Changed 10 years ago by sammy2ooo

What do you mean by VDI? No indeed, I can not reproduce this crash at every boot.

(OT: how is the meaning "guru meditation" tight to a crash???)

comment:12 Changed 10 years ago by sammy2ooo

However, booting Windows 7 in "Safe Mode" always seems to work...

comment:13 Changed 10 years ago by sammy2ooo

00:00:15.664 Audio: set_record_source ars=0 als=0 (not implemented)
00:00:15.665 Audio: set_record_source ars=0 als=0 (not implemented)
00:00:17.216 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007faf68000000 w=800 h=600 bpp=32 cbLine=0xC80
00:00:17.280 VMMDev::SetVideoModeHint: got a video mode hint (1152x864x0) at 0
00:00:20.405
00:00:20.405 !!Assertion Failed!!
00:00:20.405 Expression: cRefs == PGMPOOL_TD_CREFS_PHYSEXT
00:00:20.405 Location  : /home/vbox/tinderbox/3.1-lnx64-rel/src/VBox/VMM/VMMAll/PGMAllPool.cpp(3926) void pgmPoolTrackPhysExtDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, PGMPAGE*)
00:00:20.405 cRefs=0 pPhysPage=Z--:RAM:00014d0dd000:0000000:-0000 pPage=00007fafa15e3490:{.idx=410}

comment:14 Changed 10 years ago by sammy2ooo

I started the virtual machine from CLI using "VBoxManage startvm "Windows 7" -type vrdp" and then connected via MS Remote Desktop Client

comment:15 Changed 10 years ago by frank

With VDI he meant the virtual disk image of your VM. For the term guru meditation see  here.

comment:16 Changed 10 years ago by sammy2ooo

sandervl73: i could give you access to a copy of my vdi file, as it is a somewhat freshly windows 7 install. do you have any ftp account for me where i could upload the file?

comment:17 Changed 10 years ago by sammy2ooo

the vdi is about 5.9G long (bziped)

comment:18 Changed 10 years ago by sandervl73

So you always start this VM with the option -vrdp and connect with the MS RDP client when you see this guru meditation? I haven't tried that here yet. Also please give me an indication as to how often you can reproduce this problem? (every time, 1 out of 2, 2 out of 5 times?)

comment:19 Changed 10 years ago by sammy2ooo

no i do not start the vm all the time with the vrdp option, sometimes i use the virtualbox gui with the exact same result. this crash seems to occur randomly while booting. i would say about 1 out of 5 boot attemps are successful

comment:20 Changed 10 years ago by sandervl73

Ok, please upload the file to  ftp://ftp.virtualbox.org/incoming (write only; others can't see your file). Thanks!

comment:21 Changed 10 years ago by sammy2ooo

thanks for your space. upload is in process and may take up to a few hours...

comment:22 Changed 10 years ago by sammy2ooo

I have finished the upload, i hope we dont have any CRC's... please also have a look at the sha1sum file and let me know if everything went fine

comment:23 Changed 10 years ago by sandervl73

Thanks. Downloading. If I can't reproduce it, I'll post a link to a new build here as I've fixed something possibly related yesterday.

comment:24 Changed 10 years ago by sammy2ooo

hm i have recognized when trying to adding this vdi to a VirtualBox Installation which runs on Windows XP Host (Version 3.1.4) I receive this error message. Maybe my vdi is (or got while sending over network) simply corrupted?

Fehlercode: VBOX_E_IPRT_ERROR (0x80BB0005) Komponente: Medium Interface: IMedium {aa8167ba-df72-4738-b740-9b84377ba9f1} Callee: IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}

comment:25 Changed 10 years ago by sandervl73

Not sure, but tar doesn't like the extracted tar file here (bzip2 didn't complain though). A new test build can be downloaded here:  http://www.virtualbox.org/download/testcase/VirtualBox-2010-03-17-14-24-02-lin64-3.1-3.1.5-r58927.run

Could you give that one a try?

comment:26 Changed 10 years ago by sammy2ooo

Thanks for that build. Unfortunately the same problem occurs...

00:00:31.155 Guest Log: VBoxService.exe: 3.1.5 r58575 started. Verbose level = 0
00:00:35.685 
00:00:35.685 !!Assertion Failed!!
00:00:35.685 Expression: cRefs == PGMPOOL_TD_CREFS_PHYSEXT
00:00:35.685 Location  : /home/vbox/tinderbox/3.1-lnx64-rel/src/VBox/VMM/VMMAll/PGMAllPool.cpp(3935) void pgmPoolTrackPhysExtDerefGCPhys(PGMPOOL*, PGMPOOLPAGE*, PGMPAGE*)
00:00:35.685 cRefs=0 pPhysPage=Z--:RAM:00010956e000:0000000:-0000 pPage=00007f3dbc2f9460:{.idx=117}

comment:27 Changed 10 years ago by sandervl73

We managed to extract the tar file. My tar binary is perhaps a bit outdated. Will give your vdi a try.

comment:28 Changed 10 years ago by sandervl73

Your VDI is fine, but unfortunately I'm not able to reproduce your problem here.

comment:29 Changed 10 years ago by sandervl73

Funny, tried again and I got it. :)

comment:30 Changed 10 years ago by sammy2ooo

Yes, this is really odd. nd I guess pretty hard to hunt down or find out what is causing it.... I hate randomly occuring erros X-)

Any ideas or insights?

comment:31 Changed 10 years ago by sandervl73

Already found and fixed. I'll post a link to a test build tomorrow if no regressions show up overnight. Thanks for your help.

comment:33 Changed 10 years ago by sammy2ooo

YES!!! This really seems to have fixed it, tested it several times....What was causing this issue? Will this fix be included within the next stable release?

comment:34 Changed 10 years ago by sammy2ooo

one more question: is this the opensource version? usb is not working anymore and greyedout

comment:35 Changed 10 years ago by sandervl73

It's not the opensource version, so usb should work. 3.1.6 will be released soon and will include the fix.

comment:36 Changed 10 years ago by sandervl73

  • Summary changed from Crash installing Win2008 (cRefs == PGMPOOL_TD_CREFS_PHYSEXT guru) to Crash installing Win2008 (cRefs == PGMPOOL_TD_CREFS_PHYSEXT guru) -> fixed in SVN/3.1.6

comment:37 Changed 9 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use