VirtualBox

Ticket #3562 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

CentOS faild to install => Fixed in SVN

Reported by: calete Owned by:
Priority: critical Component: installer
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi,

I have installed the latests virtual box 2.1.4; I have tried to install centos (5.1 and 5.2) but it freezes on the boot process; I can install debian successfully.

Attachments

Centos-2009-03-16-20-01-57.log Download (28.6 KB) - added by calete 5 years ago.
VirtualBox log

Change History

Changed 5 years ago by calete

comment:1 Changed 5 years ago by frank

Please could you retry with IO-APIC (VM settings) enabled?

comment:2 Changed 5 years ago by sspreitzer

Bug confirmed with version 2.1.4

After being loaded into memory, Linux kernel blanks screen and shows following two lines:

Kernel alive
Kernel direct mapping tables up to 100000000 @ 8000-d000


Host System is Fedora 10 x86_64, AMD Phenom 3x 2,3Ghz 8GB RAM
Guest System configuration: Redhat64, 2 GB RAM, APCI, IO-APIC, VAMD, Nested Paging

Booting guest from ISO file: CentOS-5.2-x86_64-netinstall.iso


Qemu+kvm is able to boot the kernel on this ISO file.

comment:3 Changed 5 years ago by sspreitzer

Updated my copy of vbox to version 2.2.0.

Bug confirmed with version 2.2.0.

comment:4 Changed 5 years ago by frank

Sorry, still no clue. Please could you do some more tests:

  • Any change with VirtualBox 2.2.2?
  • What happens if you enable the VT-x/AMD-V button for that VM (note that starting with 2.2.0 that setting is enabled for new VMs by default)?

comment:5 Changed 5 years ago by ccaim

We have got the same problem and it still persists with VirtualBox 2.2.4. Host system is CentOS 5.3 final (Kernel: 2.6.18-128.1.10.el5, x86_64). Guest system is the same.

Hardware: Fujitsu PRIMERGY RX330 2x AMD Opteron 2344 HE 16 GB DDR2-RAM ECC 3x 500 GB SAS, 7.200upm, Hardware RAID 5

Fiddling with all possible settings either in VirtualBox for the virtual machine or at the guest kernel level (enabling or disabling various things) showed no effect whatsoever.

The machine hangs and latest message is the one posted by sspreitzer above.

comment:6 Changed 5 years ago by utdream

Confirmed for 2.2.4. The interesting thing is that I can install Ubuntu 8.04 LTS 64-bit and get this error, but the VM contines to boot even though this error is displayed. The VM appears to be fine even though it had this error at boot.

comment:7 Changed 5 years ago by frank

  • Summary changed from CentOS faild to install to CentOS faild to install => Fixed in SVN

This is most probably a duplicate of #3927. It appears that this is an issue with AMD processors. Therefore I will tag this one as fixed in SVN.

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use