VirtualBox

Ticket #3563 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

vboxmouse driver changes locale -> should be fixed in SVN

Reported by: fatih Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

vboxmouse module calls setlocale and changes X server's locale to user's locale instead of C. Then server makes comparisons in user's locale and that causes serious problems especially in Turkish locale. In Turkish, tolower("I") is not "i". So server converts "PCI" string to "pcı" (not "pci").

In order to reproduce the problem, add the following line to xorg.conf:

BusId "PCI:0:2:0"

Then set LC_ALL to tr_TR.UTF-8 and start xserver. That will fail; because it won't find the matching "Device" section. When vboxmouse module is disabled, server starts correctly.

Change History

comment:1 Changed 5 years ago by michael

Might I ask which guest this was, and specifically which version of X.Org server?

comment:2 Changed 5 years ago by fatih

The guest is Pardus Linux 2008.2. It uses xorg-server 1.4.2.

comment:3 Changed 5 years ago by michael

  • Summary changed from vboxmouse driver changes locale to vboxmouse driver changes locale -> should be fixed in SVN

I have not been able to reproduce this problem (I don't have a guest handy with X.Org server 1.4, and I had no success with X.Org 7.1 and with Server 1.5). However, I have removed the call to setlocale in vboxmouse, so hopefully this should be fixed in SVN now (should be in the public tree as of tomorrow).

comment:4 Changed 5 years ago by fatih

I have tested with VirtualBox 2.1.4 + the svn patch r18055 and it seems fixed. Thanks.

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use