VirtualBox

Ticket #3927 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V) -> fixed in SVN

Reported by: draeath Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: draeath@… Guest type: Linux
Host type: Linux

Description

Host system: Ubuntu 9.04 x86_64 (NX/VT/PAE etc supported)
Guest: Centos 5.3 x86_64 netinstall media (cdrom iso)

The guest will not boot properly. isolinux runs and presents menus correctly, but the kernel hangs with the following lines displayed (with vbox utilizing 100% of a host CPU)
Kernel alive
kernel direct mapping tables up to 100000000 @ 8000-d000

The isolinux menu boots the kernel with only the initrd specified, no other parameters are passed (such as quiet)

I have attached a .tgz archive containing the machine's XML and a VBox.log

Quick summary of guest (and VM) settings:
OS Type: Linux 2.6 (64 bit)
Base Memory: 512 MB (of 4 GB)
Video Memory: 16 MB (of 512 MB)
Boot Order: CD/DVD-ROM, Hard Disk
ACPI: Enabled
IO APIC: Enabled
VT-X/AMD-V: Enabled (required for 64-bit guest. Supported by hardware)
Nested Paging: Enabled
PAE/NX: Enabled
3D Acceleration: Enabled

Hard Disks: One empty 10 GB image

CD-DVD: ISO (CentOS5-5.3-x86_64-netinstall.iso)
md5sum (binary mode): 7dec88e4147d6d90785ca57501af807e
obtain from:  http://mirrors.usc.edu/pub/linux/distributions/centos/5.3/isos/x86_64/

Audio: ALSA (ICH AC97 mode)

Network: Intel PRO/1000MT Desktop (bridged mode)

USB fully enabled, no filters defined

Attachments

centos-5.3-amd64.tgz Download (9.7 KB) - added by draeath 5 years ago.
machine xml and log file
centos-5.3-amd64.xml Download (3.4 KB) - added by draeath 5 years ago.
machine XML
VBox.log Download (44.5 KB) - added by draeath 5 years ago.
execution log
VBox.2.log Download (43.4 KB) - added by nylan75 5 years ago.
VBox.slackware64.log Download (33.2 KB) - added by Cherife 5 years ago.
64-bit slackware guest on 32-bit slackware host
Cent53_amd64_phenom3.tar.gz Download (17.3 KB) - added by cwadge 5 years ago.
CentOS 5.3/AMD64 | VirtualBox 2.2.4 | AMD Phenom 2 (955) | Linux 2.6.29.4 x86

Change History

Changed 5 years ago by draeath

machine xml and log file

comment:1 Changed 5 years ago by sandervl73

The archive appears corrupted. Please attach the VBox.log as a textfile so I don't have to download and unpack it first.

comment:2 Changed 5 years ago by nylan75

Same Problem with the CentOS-5.3-x86_64-bin-DVD.iso

Same config as above except: 3d acceleration disabled

Changed 5 years ago by draeath

machine XML

Changed 5 years ago by draeath

execution log

comment:3 Changed 5 years ago by draeath

Sorry, individual files uploaded. Somehow, I managed to recursively gzip the tar archive several times.

Changed 5 years ago by nylan75

comment:4 Changed 5 years ago by frank

draeath, does it make any difference if you disable nested paging for that VM?

comment:5 Changed 5 years ago by draeath

No changes to the observed behaviour

Changed 5 years ago by Cherife

64-bit slackware guest on 32-bit slackware host

comment:6 Changed 5 years ago by Cherife

Running Virtualbox 2.2.2 on slackware linux (32bit) and tried to install slackware64 (64bit) as guest. The Intel VT-x is enabled. I've read about the 64-bit guest section in the UserManual.pdf. I've also tried to install RHEL5.2 (64bit) guest. Almost the same issue, the host become non-responsive (hang), some times the host auto-reboot, after the guest installation loaded initrd.img.

The log file has been attached.

Thanks!

comment:7 Changed 5 years ago by sandervl73

Cherife: your problem is different. Please open another defect.

Draeath: this looks like a duplicate.

comment:8 Changed 5 years ago by sandervl73

  • Summary changed from vbox 2.2.2 - centos 5.3 x86_64 guest will not boot to vbox 2.2.2 - centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V)

Similar to #3923, but not quite the same.

comment:9 Changed 5 years ago by sandervl73

  • Summary changed from vbox 2.2.2 - centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V) to Centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V)

Changed 5 years ago by cwadge

CentOS 5.3/AMD64 | VirtualBox 2.2.4 | AMD Phenom 2 (955) | Linux 2.6.29.4 x86

comment:10 in reply to: ↑ description Changed 5 years ago by draeath

I've changed my host system to Debian stable. Recreating the machines with vbox 2.2.4 r47978 the same behavior occurs, however an i386 CentOS guest does boot correctly.

This seems to be for a x86_64 CentOS guest only.

comment:11 Changed 5 years ago by nkinchev

CentOS 5.3/4.7 AMD64 | VirtualBox 2.2.4 | AMD Phenom 9850

Host - Ubuntu 9.04 and Windows 7 same behavior

Guest - CentOS 5.3 and 4.7 / AMD64 same behavior

It looks any CentOS 64bit kernel doesn't boot.

comment:12 Changed 5 years ago by sandervl73

nylan75: you have disabled the IO-APIC somehow. 64 bits guests will not work without it.

comment:13 Changed 5 years ago by sandervl73

  • Summary changed from Centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V) to Centos 5.3 x86_64 guest will not boot (Phenom II; AMD-V) -> fixed in SVN

Reproduced and fixed in SVN. Will be included in the next version.

comment:14 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use