VirtualBox

Ticket #19533 (new defect)

Opened 2 years ago

Last modified 2 years ago

wacom clicks not registered in virtualbox manager window

Reported by: Jackg Owned by:
Component: other Version: VirtualBox 6.1.6
Keywords: Cc:
Guest type: Linux Host type: Linux

Description

Tested with virtualbox 6.1.6 on Ubuntu 20.04 and separately, by a different person, with virtualbox 6.0.14 on Ubuntu 19.10.

Both of us are unable to click within the virtualbox manager window, like create a new VM or import or export or access preferences, using wacom tablet (in my case Wacom Intuos Pen Tablet).

For me up to a few days ago, when I was still running virtualbox 5.2.40 on Ubuntu 19.04 (and before on Ubuntu 18.04), this was not a problem. Upgrading to Ubuntu 20.04 means that python2 is no longer supported (which makes total sense) but now it looks like virtualbox manager has become unusable because it does not seem to register the mouse clicks.

To clarify, when I hover over items in the virtualbox manager window the buttons seem to respond to the hovering, but when I click nothing happens. Clicking in any other program so far has not resulted into issues like this. Also interestingly I discovered today that when I import (using a regular mouse temporarily plugged in) several VMs that I am able to change the order of the VMs in the virtualbox manager window (sort/group them) but again not able to click them.

This may be similar or related to: https://www.virtualbox.org/ticket/11939 If so, this may be a regression bug.

And I also posted it here without reply so far:  https://forums.virtualbox.org/viewtopic.php?f=7&t=97881

Change History

comment:1 Changed 2 years ago by Jackg

OK this seems to be a QT issue and virtualbox running an older version of QT. See also  https://bugreports.qt.io/browse/QTBUG-77826

Once virtualbox updates to QT 5.14.1 this should be solved. A temporary workaround has been posted at  https://forums.virtualbox.org/viewtopic.php?f=7&t=97881

comment:2 Changed 2 years ago by Jackg

FYI Also virtualbox is highlighted here as being affected by other users by this bug:  https://github.com/linuxwacom/xf86-input-wacom/issues/93

comment:3 Changed 2 years ago by mmikk

Check if switching from wayland to X11 help. There are multiple bugs filed for that issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use