VirtualBox

Ticket #19532 (closed defect: worksforme)

Opened 2 years ago

Last modified 2 years ago

Request https file download error from virtualbox 6.1.6 vm

Reported by: honking Owned by:
Component: network Version: VirtualBox 6.1.6
Keywords: https, checksum Cc:
Guest type: Linux Host type: Windows

Description

When I download https file from virtualbox 6.1.6 vm, the file always return wrong checksum. The file size is correct, but the checksum is wrong.

If the download url starts with " http://" , the downloaded size and checksum are both correct.

For example, when use the url with " https://", I always got right file size but wrong checksum.

 https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz

If I replace the url start with " http://", I can get the right file size and right checksum.

 http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz

I tested these cases in serval vms (including ubuntu 18.04, ubuntu 19.10, boot2docker ), I can not get right checksum in https download.

Change History

comment:1 follow-up: ↓ 2 Changed 2 years ago by fbatschu

  • Status changed from new to awaitsfeedback

1) which checksum and from where did you got the checksum for what? 2) how did you arrived at the conclusion to file a bug with Virtualbox? 3) have you tried this on bare metal ? I cannot because I don't know which checksum you talk about.

Last edited 2 years ago by fbatschu (previous) (diff)

comment:2 in reply to: ↑ 1 Changed 2 years ago by honking

Replying to fbatschu:

1) which checksum and from where did you got the checksum for what?

I get the checksum by using linux command md5sum and sha1sum.

$md5sum meteor-bootstrap-os.linux.x86_64.tar.gz
$sha1sum meteor-bootstrap-os.linux.x86_64.tar.gz

2) how did you arrived at the conclusion to file a bug with Virtualbox?

When I test it in the vms installed in Virtualbox, I can not get right checksum. If I use the same vms in vmware, I can get right result

3) have you tried this on bare metal ? I cannot because I don't know which checksum you talk about.

I have tried in serval ways , they all can get right checksum. The ways I have tried:

  1. my own windows host
  2. wsl2 on windows host
  3. the same vms in vmware
  4. my own linux server(centos)

Here is the test result from my linux server (md5sum/sha1sum/filesize is the same between http and https download)

[root@vps3 ~]# curl -o 1.tar.gz https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  40.1M      0  0:00:05  0:00:05 --:--:-- 48.1M

[root@vps3 ~]# curl -o 2.tar.gz http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  46.0M      0  0:00:05  0:00:05 --:--:-- 52.1M

[root@vps3 ~]# ls -l 1.tar.gz 2.tar.gz
-rw-r--r-- 1 root root 245001119 Apr 27 09:17 1.tar.gz
-rw-r--r-- 1 root root 245001119 Apr 27 09:21 2.tar.gz
[root@vps3 ~]# md5sum 1.tar.gz 2.tar.gz
18e3421c88172df9171db707baaea7b6  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz
[root@vps3 ~]# sha1sum 1.tar.gz 2.tar.gz 
37809c09ba72cdd045c50c8cab84ac8e48d132f0  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz



Here is the test result from wsl2 on windows host (md5sum/sha1sum/filesize is the same between http and https download)

➜  ~ curl -o 1.tar.gz https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  7241k      0  0:00:33  0:00:33 --:--:-- 7220k
➜  ~ curl -o 2.tar.gz  http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4124k      0  0:00:58  0:00:58 --:--:-- 4351k
➜  ~ ls -l 1.tar.gz 2.tar.gz
-rw-r--r-- 1 honking honking 245001119 Apr 27 09:36 1.tar.gz
-rw-r--r-- 1 honking honking 245001119 Apr 27 09:38 2.tar.gz
➜  ~ md5sum 1.tar.gz 2.tar.gz
18e3421c88172df9171db707baaea7b6  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz
➜  ~ sha1sum 1.tar.gz 2.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz

Here is the test result from vms in virtualbox6.1.6(md5sum/sha1sum is different between http and https download, but the filesize is the same).I have tried other vms in vbox, but they all can not get the same md5sum/sha1sum between http and https download

docker@default:/tmp$ curl -o 1.tar.gz  https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  3602k      0  0:01:06  0:01:06 --:--:-- 4834k
docker@default:/tmp$ curl -o 1.tar.gz  http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4978k      0  0:00:48  0:00:48 --:--:-- 5086k
docker@default:/tmp$ ls -l 1.tar.gz 2.tar.gz
-rw-r--r--    1 docker   staff    245001119 Apr 27 01:28 1.tar.gz
-rw-r--r--    1 docker   staff    245001119 Apr 27 01:28 2.tar.gz
docker@default:/tmp$ md5sum 1.tar.gz 2.tar.gz
9fd7523ef19bc97d13225baeaa3ef4cf  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz
docker@default:/tmp$ sha1sum 1.tar.gz 2.tar.gz
6fddf39e7c40e7350e062acdac3ce829768b457a  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz

In particular,I get different md5sum/sha1sum in the same https download url

Last edited 2 years ago by honking (previous) (diff)

comment:3 follow-up: ↓ 4 Changed 2 years ago by fbatschu

I dont know what that server should be delivering but it certainly has nothing todo with Virtualbox.

Here's is one test from a bare metal Ubuntu 18.04.4 system failing:

fbatschu@minibox:~/tmp$  curl -o 1.tar.gz https://static-meteor.netdna-ssl.com
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   243    0   243    0     0    105      0 --:--:--  0:00:02 --:--:--   105
fbatschu@minibox:~/tmp$  curl -o 2.tar.gz http://static-meteor.netdna-ssl.com
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   243    0   243    0     0    517      0 --:--:-- --:--:-- --:--:--   515

fbatschu@minibox:~/tmp$ ls -l 1.tar.gz 2.tar.gz
-rw-r--r-- 1 fbatschu staff 243 Apr 27 08:40 1.tar.gz
-rw-r--r-- 1 fbatschu staff 243 Apr 27 08:41 2.tar.gz

fbatschu@minibox:~/tmp$ md5sum 1.tar.gz 2.tar.gz
215bf292a38179609196979492e9a055  1.tar.gz
cac5a8fa8b97898ac94aabce6cc4e19b  2.tar.gz

fbatschu@minibox:~/tmp$ sha1sum 1.tar.gz 2.tar.gz
868aa8f5a0ef4aedf2661d3f4f0be2a1f05b0f29  1.tar.gz
e787aab48c4a64c5b3b39ce858ceafb77981e452  2.tar.gz

and here is the test failing on a bare metal Ubuntu 19.10 system:

fbatschu@oradesk:~/tmp$  curl -o 1.tar.gz https://static-meteor.netdna-ssl.com
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   243    0   243    0     0    430      0 --:--:-- --:--:-- --:--:--   430
fbatschu@oradesk:~/tmp$ curl -o 2.tar.gz http://static-meteor.netdna-ssl.com
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   243    0   243    0     0    456      0 --:--:-- --:--:-- --:--:--   455

fbatschu@oradesk:~/tmp$ ls -l 1.tar.gz 2.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 243 Apr 27 08:42 1.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 243 Apr 27 08:42 2.tar.gz

fbatschu@oradesk:~/tmp$ md5sum 1.tar.gz 2.tar.gz
c5910952bc95040418827b32979b744a  1.tar.gz
b064d62c82e2499bf766831d00967d42  2.tar.gz

fbatschu@oradesk:~/tmp$ sha1sum 1.tar.gz 2.tar.gz
128b9dc221c39bd7d5f9e2a68919143d81a79569  1.tar.gz
6760c4d22085777317915e7bfd1b3054629180ef  2.tar.gz

comment:4 in reply to: ↑ 3 Changed 2 years ago by honking

You should not test like your way. Because the content of url " http://static-meteor.netdna-ssl.com" is always changing , you will not get the same checksum from the download file!

You should test the whole url " http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz" and " https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz"

The url I provided is a file link from server. In general cases, the md5sum from the this download file should be "18e3421c88172df9171db707baaea7b6" whever you test how many times. I can always get this right md5sum from other system , but can not get the right md5sum from vms in vbox6.1.* .

comment:5 Changed 2 years ago by fbatschu

  • Status changed from awaitsfeedback to closed
  • Resolution set to worksforme

I don't know where your specific problem lives, but I certainly cannot reproduce it in 2 different guest VM with 2 different Linux ditros:

Linux linux-nezc 4.12.14-122.17-default #1 SMP Wed Feb 26 10:31:05 UTC 2020 (6090a75) x86_64 x86_64 x86_64 GNU/Linux
PRETTY_NAME="SUSE Linux Enterprise Server 12 SP5"

fbatschu@linux-nezc:~> curl -o 1.tar.gz https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  1262k      0  0:03:09  0:03:09 --:--:-- 1321k
fbatschu@linux-nezc:~> curl -o 2.tar.gz http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4678k      0  0:00:51  0:00:51 --:--:-- 4834k

fbatschu@linux-nezc:~> ls -l 1.tar.gz 2.tar.gz
-rw-r--r-- 1 fbatschu users 245001119 Apr 27 10:55 1.tar.gz
-rw-r--r-- 1 fbatschu users 245001119 Apr 27 11:06 2.tar.gz

fbatschu@linux-nezc:~> md5sum 1.tar.gz 2.tar.gz
18e3421c88172df9171db707baaea7b6  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz

fbatschu@linux-nezc:~> sha1sum 1.tar.gz 2.tar.gz 
37809c09ba72cdd045c50c8cab84ac8e48d132f0  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz
Linux fbatschu-VirtualBox 5.4.0-26-generic #30-Ubuntu SMP Mon Apr 20 16:58:30 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
PRETTY_NAME="Ubuntu 20.04 LTS"

fbatschu@fbatschu-VirtualBox:~$  curl -o 1.tar.gz https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4655k      0  0:00:51  0:00:51 --:--:-- 4696k
fbatschu@fbatschu-VirtualBox:~$  curl -o 2.tar.gz http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4686k      0  0:00:51  0:00:51 --:--:-- 4703k

fbatschu@fbatschu-VirtualBox:~$ ls -l 1.tar.gz 2.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 245001119 Apr 27 11:14 1.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 245001119 Apr 27 11:15 2.tar.gz

fbatschu@fbatschu-VirtualBox:~$ md5sum 1.tar.gz 2.tar.gz
18e3421c88172df9171db707baaea7b6  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz

fbatschu@fbatschu-VirtualBox:~$ sha1sum 1.tar.gz 2.tar.gz 
37809c09ba72cdd045c50c8cab84ac8e48d132f0  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz

### check whether or not using the tmp file system makes a difference:

fbatschu@fbatschu-VirtualBox:~$ cd /tmp
fbatschu@fbatschu-VirtualBox:/tmp$ curl -o 1.tar.gz https://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4364k      0  0:00:54  0:00:54 --:--:-- 4850k
fbatschu@fbatschu-VirtualBox:/tmp$ curl -o 2.tar.gz http://static-meteor.netdna-ssl.com/packages-bootstrap/1.8.3/meteor-bootstrap-os.linux.x86_64.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  233M  100  233M    0     0  4830k      0  0:00:49  0:00:49 --:--:-- 4788k

fbatschu@fbatschu-VirtualBox:/tmp$ ls -l 1.tar.gz 2.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 245001119 Apr 27 11:36 1.tar.gz
-rw-rw-r-- 1 fbatschu fbatschu 245001119 Apr 27 11:39 2.tar.gz

fbatschu@fbatschu-VirtualBox:/tmp$  md5sum 1.tar.gz 2.tar.gz
18e3421c88172df9171db707baaea7b6  1.tar.gz
18e3421c88172df9171db707baaea7b6  2.tar.gz

fbatschu@fbatschu-VirtualBox:/tmp$ sha1sum 1.tar.gz 2.tar.gz 
37809c09ba72cdd045c50c8cab84ac8e48d132f0  1.tar.gz
37809c09ba72cdd045c50c8cab84ac8e48d132f0  2.tar.gz

NB: typically the forum is the place to go discuss and to investigate such nebulous problems rather then filing a bug straigth away without any indication of that being a product bug specific to Virtualbox. Maybe you have any Network settings changed from the defaults in your guest ? Any specific network adapter settings or configurations you are using outside the real of Virtualbox?

comment:6 Changed 2 years ago by Simon_c

I have ran across this exact problem. My research has narrowed it down to having WSL2 enabled. Disabling it, by disabling the "Virtual Machine Platform" in "windows features" and restarting will fix the problem.

This ticket also seems related https://www.virtualbox.org/ticket/19695

comment:7 Changed 2 years ago by djhaskin987

comment:8 Changed 2 years ago by aeichner

We will track this further in #19695, please continue there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use