VirtualBox

Ticket #1946 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

Ubuntu 8.04 host, Windows XP guest, AMD x86_64 SMP host, CPU = 100%

Reported by: rober1s Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

CPU utilization is 100 percent in this configuration. Have found no tweaking combination of USB 2.0 / clipboard settings that present a work-around.

Ubuntu 8.04 host, Windows XP SP2 guest.

Attachments

VBox.log Download (42.2 KB) - added by gbell12 5 years ago.

Change History

comment:1 Changed 6 years ago by rober1s

Sorry, make that an "AMD" processor, not an "AMC".

--Doug

comment:2 Changed 6 years ago by sandervl73

  • Component changed from host support to other
  • Summary changed from Ubuntu 8.04 host, Windows XP guest, AMC x86_64 SMP host, CPU = 100% to Ubuntu 8.04 host, Windows XP guest, AMD x86_64 SMP host, CPU = 100%

Attach the sessions's VBox.log please.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. The problem might have been fixed anyway, try out the latest release 2.2.0.

Changed 5 years ago by gbell12

comment:4 Changed 5 years ago by gbell12

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'd like to reopen this ticket. Its a dupe of  http://www.virtualbox.org/ticket/1233

I've attached my Vbox.log file. The only thing different from the original poster is that I'm on FC10.

As you can see from the attached log, I'm running 2.2.0, with XP as a guest. One CPU is pegged at 100% no matter what the guest is doing. For this testcase, I didn't even login, just booted XP, left it sitting there at the login screen for 20 minutes, then shutdown.

I was running with taskset -c 1. I've disabled the clipboard, increased video memory size to > 32MB, turned off USB, etc. etc. and it always runs at 100% CPU.

Archlinux as guest does not.

comment:5 Changed 5 years ago by sandervl73

Don't use the IO-APIC for 32 bits Windows guests. That will kill performance. Turning it off will make Windows blue screen, so you either have to reinstall Windows or change the HAL. (see  http://www.virtualbox.org/wiki/Migrate_Windows)

comment:6 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

Duplicate of #638.

comment:7 Changed 5 years ago by gbell12

Not a good solution as IO-APIC seems to be required for Windows XP install disk to boot. Also detailed in this bug, that appears to be yet another duplicate (638, 1233, 1407, 1946)

 http://www.virtualbox.org/ticket/638

Changing the HAL as suggested doesn't seem to be an option without a Recovery floppy created.

comment:8 Changed 5 years ago by sandervl73

Well, there is currently unfortunately no other option. IO-APIC is only required if you installed Windows with it enabled. Which probably implies that you migrated a VMWare image as we don't enable it by default for 32 bits guests.

comment:9 Changed 5 years ago by gbell12

Not a VMWare image, but it is an nLite generated image from a running system...

comment:10 Changed 5 years ago by sandervl73

Same applies for images from physical systems. See defect #638 for a video link.

comment:12 follow-ups: ↓ 13 ↓ 15 Changed 5 years ago by gbell12

Everybody googling this issue:

Its extremely easy to fix. From the video,

Start->Control Panel->System->Hardware->Device Manager

Expand "Computer" Right-Click on "ACPI Multiprocessor PC" or "Advanced Configuration and Power Interface (ACPI)"

Select "Update Driver"

Select "No, not this time" and Next

Select "Install from a list or specific location" and Next

Select "Don't Search, I will cho-cho-choose the driver to install" and Next

Select "Standard PC" and next

Follow instructions to reboot, etc.

That's *it*. 5 minutes of interruption and your fans will be quiet again, and your power consumption will drop, providing the world with fewer black baloons for your outputted wonders from your VirutalBox? PC.

comment:13 in reply to: ↑ 12 ; follow-up: ↓ 14 Changed 5 years ago by gbell12

Everybody googling this issue:

Its extremely easy to fix. From the video,

Start->Control Panel->System->Hardware->Device Manager

Expand "Computer" Right-Click on "ACPI Multiprocessor PC" or "Advanced Configuration and Power Interface (ACPI)"

Select "Update Driver"

Select "No, not this time" and Next

Select "Install from a list or specific location" and Next

Select "Don't Search, I will cho-cho-choose the driver to install" and Next

Select "Standard PC" and next

Follow instructions to reboot, etc.

That's *it*. 5 minutes of interruption and your fans will be quiet again, and your power consumption will drop, providing the world with fewer black baloons for your outputted wonders from your VirtualBox PC.

comment:14 in reply to: ↑ 13 Changed 5 years ago by vondralbra

Replying to gbell12:

Everybody googling this issue:

Its extremely easy to fix. From the video,

I can confirm this workaround on an Ubuntu 9.0.4 Host and a Debian Lenny Host both having Windows XP Guests which showed up with high cpu loads on the host while the guests were idling along.

The Virtualbox version used here is vbox 3.0.2

comment:15 in reply to: ↑ 12 Changed 5 years ago by nemo34

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Replying to gbell12:

Everybody googling this issue:

Its extremely easy to fix. From the video,

Start->Control Panel->System->Hardware->Device Manager

Expand "Computer" Right-Click on "ACPI Multiprocessor PC" or "Advanced Configuration and Power Interface (ACPI)"

Select "Update Driver"

Select "No, not this time" and Next

Select "Install from a list or specific location" and Next

Select "Don't Search, I will cho-cho-choose the driver to install" and Next

Select "Standard PC" and next

Follow instructions to reboot, etc.

That's *it*. 5 minutes of interruption and your fans will be quiet again, and your power consumption will drop, providing the world with fewer black baloons for your outputted wonders from your VirutalBox? PC.

Warning, this fix did nto work for me. System would not restart. Had to switch to safe-mode windows to select back "multiple microprocessor with ACPI". So proceed with caution if trying this.

BTW, I still have 100% CPU load with XP-SP3 running on VB3.0.2 on Ubuntu 9.04 and no idea on how to fix that. Processes sucking CPU are services.exe, vm_sti.exe, explorer.exe, antivirus (rtvscan.exe) and wmiadap.exe

Any idea?

comment:16 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Nemo34: do not reopen tickets without providing any information (VBox.log). The original problem has been solved.

comment:17 Changed 5 years ago by simoncpu

Hi,

I am still experiencing this problem with version 2.2.4 r47978. My uname -a for my host is:

Linux soulfury 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 01:19:55 UTC 2009 x86_64 GNU/Linux

My guest is FreeBSD 7.1.

Sorry, I have no logs atm.

[ simon.cpu ]

comment:18 Changed 5 years ago by michael

simoncpu: you might want to check whether the problem persists with version 3.0.4. If so, you could also try the test builds linked to on  http://www.virtualbox.org/ticket/3755#comment:29 (see the information and the warnings there as well of course).

comment:19 Changed 5 years ago by michael

  • Status changed from closed to reopened
  • Resolution fixed deleted

[Pasted from ticket 894]

Good day!

I'm currently using version 2.2.4 r47978. The uname for my host is:

Linux soulfury 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 01:19:55 UTC 2009 x86_64 GNU/Linux

The uname for my guest is:

FreeBSD inara.simoncpu.com 7.1-RELEASE-p4 FreeBSD 7.1-RELEASE-p4 #0: Thu May 7 12:19:03 PHT 2009 admin@inara:/usr/obj/usr/src/sys/SOLIDWALL i386

top gives the following output even though both host and guest OSes are idle:

7053 simoncpu 20 0 575m 261m 27m R 32.2 13.1 6024:17 VirtualBox

VirtualBox is consuming ~30-35% CPU. I'm reopening this because this problem still exist.

Thanks!

[ simon.cpu ]

comment:20 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

Just another case of IO-APIC overhead. Do not reopen duplicates.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use