VirtualBox

Ticket #638 (closed defect: duplicate)

Opened 7 years ago

Last modified 5 years ago

IO APIC eat 100% (32 bits guests) -> duplicate of 4392

Reported by: axet Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Fedora 7 host, Macbook Pro. If i enable option IO APIC VirtualBox eat all CPU, independ my windows guest work or in idle state.

Attachments

Windaube-2009-08-11-11-22-16.log Download (33.8 KB) - added by nemo34 5 years ago.
vblog
Windaube-2009-08-11-11-22-16.2.log Download (33.8 KB) - added by nemo34 5 years ago.
vblog

Change History

comment:1 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.x please and reopen if necessary.

comment:2 Changed 6 years ago by dmccombs

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have this problem on an Ubuntu 8.04 64-bit host with Windows XP as the guest - with io apic enabled, the host has 100% cpu used, while the guest is using next to nothing (0-5%). This is happening with 1.6.0. Disabling IO APIC makes the cpu usage disappear, though it's a Windows install I share with my real hardware so I'd like to leave it enabled in Windows.

comment:3 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.5.0 to VirtualBox 1.6.0

comment:4 follow-up: ↓ 5 Changed 6 years ago by clipcarl

I have this same problem with a FreeBSD 6.2 guest on an OpenSuse 10.3 host.

comment:5 in reply to: ↑ 4 Changed 6 years ago by clipcarl

Replying to clipcarl:

I have this same problem with a FreeBSD 6.2 guest on an OpenSuse 10.3 host.

I should state that I have confirmed the problem on VirtualBox 1.6 and 1.6.2.

comment:6 Changed 5 years ago by fabiangebert

Can confirm this on amd64 ubuntu 8.10 host with xp64 win guest. (hardware: lenovo T61)

comment:7 Changed 5 years ago by fabiangebert

(running Vbox 2.0.4)

comment:8 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.6.0 to VirtualBox 2.0.4
  • Summary changed from IO APIC eat 100% to IO APIC eat 100% (32 bits guests)

Fabiangebert: This defect only applies to 32 bits guests. I doubt your problem is related to the IO-APIC.

comment:9 Changed 5 years ago by g4borg

I can confirm this behaviour with native installed Windows XPSP2 run through VirtualBox. It eats up 95-101% of CPU at all times.

  • installed windows xp first in virtual box on native drive - without apic - ran well - no cpu problems. but could not boot for itself (xp needs apic for core2duo afaik).
  • installed windows xp natively and ran it through virtualbox (same setup, but now have to enable apic, since native xp always needs apic on core2), and/or installed windows xp in the virtual box with apic/acpi, same result, eats up cpu.

host: ubuntu 8.10 32bit guest: win xp sp2 32bit config: intel core2duo t8100 2.2 ghz

disabling stuff does not resolve issues. my workaround at the moment is setting the cpu to powersafe mode, so at least it only eats up a 800mhz core instead of 2.1ghz.

comment:10 Changed 5 years ago by axet

confirm bug persist

host: fedora 10 guest windows xp sp3 (native installed)

comment:11 Changed 5 years ago by g4borg

bug persists in 2.1.0

comment:12 Changed 5 years ago by g4borg

however  CPULimit can be used to limit the process' cpu as a temporary solution. No problems in the target client detected.

tried with 75% and 50% limitation.

comment:13 Changed 5 years ago by g4borg

bug persists in 2.1.4

comment:14 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.0.4 to VirtualBox 2.2.0

comment:15 Changed 5 years ago by sandervl73

Useful video that shows step by step how e.g. to change the HAL:  http://www.vernalex.com/guides/sysprep/video.shtml

(from defect #1299)

comment:16 Changed 5 years ago by tomchiverton

This is still present in v3.0. Could the install of the VirtualBox tools to a WindowsXP guest not change this for users ?

Changed 5 years ago by nemo34

vblog

Changed 5 years ago by nemo34

vblog

comment:17 Changed 5 years ago by perkas

The problem persist in 3.0.6 version, using Ubuntu 9.0.4 as guest and windows XP as host (Intel cuad core with VT enabled).
I have to disable IO APIC.

comment:18 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

See #4392 for a more complete description and status update.

comment:19 Changed 5 years ago by sandervl73

  • Summary changed from IO APIC eat 100% (32 bits guests) to IO APIC eat 100% (32 bits guests) -> duplicate of 4392
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use