VirtualBox

Ticket #1941 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

Repeated BSODs with vBox 1.6.4, XP SP3, SATA => Fixed in 1.6.6

Reported by: aloishammer Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 1.6.4 Keywords: sata windows
Cc: Guest type: Windows
Host type: Linux

Description

I've tried several methods to get SATA support working under vBox with Linux (2.6.26.2) as host and Windows XP SP3 as guest. I've slipstreamed SP3 and the latest Intel ahci driver (8.5), and merely having the virtal SATA controller enabled causes a BSOD during installation, or after installation (using IDE to perform the installation instead). After installation, having the virtual controller enabled causes a BSOD immediately after the GUI starts.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

  • Summary changed from Repeated BSODs with vBox 1.6.4, XP SP3, SATA to Repeated BSODs with vBox 1.6.4, XP SP3, SATA => Fixed in 1.6.6

Known issue, fixed in 1.6.6.

comment:2 in reply to: ↑ 1 Changed 6 years ago by aloishammer

Replying to frank:

Known issue, fixed in 1.6.6.

You probably get this too often, but-- ETA?

comment:3 Changed 6 years ago by frank

hopefully this week.

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:5 Changed 6 years ago by chookieeee

  • Status changed from closed to reopened
  • Resolution fixed deleted

still crashes on my pc. im running kubuntu 8.04, windows guest, slipstreamed XP sp3 w/ Intel Sata driver. first part of install works, then reboot to the gui install bombs after approx 30 secs. ACPI, VT-x, and PAE/NX enabled.

comment:6 Changed 6 years ago by chookieeee

btw - im running 1.6.6

comment:7 Changed 6 years ago by frank

chookieeee, please could you attach a VBox.log file from such a VM session?

comment:8 Changed 6 years ago by chookieeee

workaround  here:

basically, dont slipstream the windows install with the intel sata 8.5.. check the box to use sata, but have the harddisk on IDE primary. after xp install on IDE, then download the intel sata 8.2 drivers, install it, then switch the VM off, and change HD to SATA.

frankie ill replicate the problem and send u the .log file tonight.

comment:9 Changed 6 years ago by dave321

I used exactly same method to have the harddisk attached to SATA, i.e. install WinXP using IDE primary, install Intel drivers (8.2 or 8.5, no difference). Shutdown and re-attach the disk to SATA-0 controller. That works just fine.

However, a very reproducible way to get a BSOD (Stop machine F4) in SATA config, is simply running the add-hardware-wizard or right-click in device-manager and 'scan for hardware changes'.

This BSOD happens on 1.6.4 / 1.6.6 / 2.0.0 ,linux 2.6.26 host, winXP-SP3 as guest. Switching back the disk to IDE primary, error is no longer there and add-hardware just works (eg. adding serial port).

comment:10 Changed 5 years ago by ddn

Confirmed in VirtualBox last version 2.0.4 too.

Windows XP SP2 with slipstreamed 8.2 or 8.5 version intel SATA AHCI result in a STOP 0x000000F4 error on "installing devices" setup phase...

comment:11 Changed 5 years ago by frank

Sounds like a duplicate of #2024.

comment:12 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please check 2.0.6. Reopen if necessary.

comment:13 Changed 5 years ago by mooninite

  • Status changed from closed to reopened
  • Resolution fixed deleted

This bug is not fixed. I'm running 2.0.6 on 32-bit Linux host. 32-bit XP Pro SP3 install with SATA driver and SATA controller enabled results in BSOD.

comment:14 Changed 5 years ago by aloishammer

Guys, this has never been fixed or even made less painful. I've tested XPSP2, XPSP3 with Intel AHCI drivers from 8.0 to 8.6 (latest). Hosts from XPSP2, XPSP3 to Vista (SP1 and no) and both CentOS 5 and FC9 x86 and x86-64 each: BSOD, always, no exceptions. You've got some kind of core bug going here.

comment:15 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

Let's continue the discussing in @2282 then. There's more info there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use