VirtualBox

Ticket #1942 (closed defect: worksforme)

Opened 6 years ago

Last modified 5 years ago

NT4 Wont work

Reported by: jbennet Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.4 Keywords: NT NT4 4 Windows New Technology
Cc: Guest type: Windows
Host type: Windows

Description

Some versions of Nt4 wont work. It hasnt worked since at least 1.6 Ive changed all the settings possible, nothing works.

I am running Xp Home Sp3 on a Pentium 4

NT4 server wont install. NT4 Terminal Server edition crashes with the same error too. On server when boting using the floppies (cd is not bootable) the first floppy works fine, but when it begins reading the seond floppy i get:

"A breakpoint has been reached (Ox80000003) occured in location 0x10ec2318"

NT4 workstation on the other hand, works fine when booting from cd (its cd is bootable, with server you have to use the floppies)

Change History

comment:1 Changed 6 years ago by frank

Is your computer capable of VT-x or AMD-V? Did you already try to activate this mode and does it make any difference? If you think you enabled VT-x or AMD-V and it did not work either please attach the VBox.log file of this session.

comment:2 Changed 6 years ago by jbennet

its off because my cpu doesnt have it

comment:3 Changed 6 years ago by jbennet

update: NT4 Terminal server edition doesnt work either, same issue

comment:4 Changed 5 years ago by sandervl73

Please include your VBox.log here. Could be a duplicate of #1885.

comment:5 Changed 5 years ago by Donuts

Could this problem be related to the "Limit CPUID Maxval" option in many BIOSes? (IA32_MISC_ENABLE MSR bit 22). Apparently NT 4 doesn't work on (some?) P4 CPUs due to a bug in its CPU detection code. You could try enabling the option in your BIOS.

If that is the cause of the problem, it would be good if VirtualBox had more settings for adjusting the guest/emulated CPU.

comment:6 Changed 5 years ago by jbennet

actually that could very well be the problem

The machine running VB is a Pentium 4 HT and i tried installing NT4 server on it 'bare metal' and got a similar error.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Actually VirtualBox already limits the CPUID.

comment:8 Changed 5 years ago by ni81036

Please set your guest type to NT4.0, it's required for CPUID leaf limit in recent VBox'es.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use