VirtualBox

Ticket #2024 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

chkdsk freeze

Reported by: chmichael Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Hello, Run -> chkdsk /f c: Reboot After check disk completes it will not reboot the system.

Using Virtual Disk on Sata Port 0. I think it's a bug.

Thanks

Attachments

chkdsk_VBox.log Download (59.5 KB) - added by arsit 6 years ago.
vbox.log file of starting up needing a chkdsk, then a forced reboot
chkdsk_XP64RecoveryConsole.log Download (63.1 KB) - added by bqtran 6 years ago.
VM State during reset of Windows XP 64 bit Recovery Console
VBox_20081024_v2.0.4.log Download (63.6 KB) - added by wraithdu 5 years ago.
VBox log after chkdsk freeze / forced shutdown

Change History

comment:1 Changed 6 years ago by chmichael

fixed in 2.02

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 follow-up: ↓ 4 Changed 6 years ago by arsit

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's not fixed.

I'm running v2.02 on Debian Etch 64 host. SATA 0 as primary drive. I have the same problem.

Thanks, Dan

Changed 6 years ago by arsit

vbox.log file of starting up needing a chkdsk, then a forced reboot

comment:4 in reply to: ↑ 3 Changed 6 years ago by arsit

Also, it chkdsk every other boot (literally) - it does chkdsk, I force reset, then it boots into windows. The next boot is *always* a chkdsk.

Replying to arsit:

It's not fixed.

I'm running v2.02 on Debian Etch 64 host. SATA 0 as primary drive. I have the same problem.

Thanks, Dan

comment:5 Changed 6 years ago by bqtran

I am also experiencing the same problem.

Currently running XP64 guest on XP64 host. chkdsk freezes in both using the recovery console and reboot process (as described by others above).

Thanks, Bao

Changed 6 years ago by bqtran

VM State during reset of Windows XP 64 bit Recovery Console

comment:6 Changed 6 years ago by wraithdu

I've recently had the same problem - Vista host, WinXP guest, HDD on SATA0 as primary, no other disks.

Occasionally I'll schedule a disk check via chkdsk /f c:

Everytime I do this, on restart chkdsk runs, but does not restart the system. I have to reset the VM. At this point I have a corrupted bootex.log file in the root drive. I have to restart the VM with XP media and boot into the recovery console, run chkdsk /p, and then I can delete the file.

If I do not do this, then every reboot chkdsk will run (and freeze) saying the disk needs to be checked for consistency. I have ntfs filesystem errors in my Event log.

The process is consistently repeatable.

comment:7 Changed 6 years ago by wraithdu

Sorry, I'm running VBox v2.0.2 as well.

comment:8 Changed 6 years ago by sandervl73

Try again with 2.0.4 please. Some SATA issues were fixed there, but not necessarily for this defect.

comment:9 Changed 5 years ago by wraithdu

I tried again with 2.0.4, and I get the same freeze after chkdsk finishes. I'm attaching my log this time, which ends immediately after the freeze when I manually turned off the VM (no reboot yet). I have the same corrupted 'bootex.log' file in the root of the drive as before.

Changed 5 years ago by wraithdu

VBox log after chkdsk freeze / forced shutdown

comment:10 Changed 5 years ago by chriswyatt

Same problem here. As it happens on every other boot it makes me wonder if there's also something that happens during shutdown i.e. as the disk is unmounting that's causing bootex.log to corrupt. Annoying bug this is, would love to see a fix.

comment:11 Changed 5 years ago by frank

  • Version changed from VirtualBox 1.6.4 to VirtualBox 2.0.4

comment:12 Changed 5 years ago by frank

There is a known problem in our SATA device implementation (actually not in the SATA device itself but in the virtual disk backend). Currently, the backend cannot handle disk transfers which are not sector aligned (offset and size). A fix is planned for the next release.

comment:13 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please check 2.0.6, this release should fix your problems.

comment:14 Changed 5 years ago by wraithdu

Version 2.0.6 works. Looks like the problem is resolved. Thanks for the hard work!!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use