VirtualBox

Ticket #1920 (new defect)

Opened 6 years ago

Last modified 5 years ago

Windows Mobile (RNDIS) USB device NOT WORKING BY DEFAULT

Reported by: teratorn Owned by:
Priority: major Component: USB
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I have an issue with connecting my Windows Mobile device to the Guest OS (Windows XP SP2). Host is Ubuntu Linux 8.04. The device is an HTC Mogul (PPC-6800). The device appears as "HTC Generic RNDIS".

The actual "symptoms" inside the Guest vary... sometimes the device shows up in Hardware Manager (as "Windows-mobile network adapter"). Other times it doesn't show up at all, and other times it shows up with a red icon next to it indicating a problem status.

In no cases will ActiveSync ever recognize that you have a mobile device plugged in.

All other USB devices that I've tried work fine inside the Guest.

MY WORKAROUND:

To make it work I have to make one setting change on the PDA itself. Go to Settings -> Connections -> USB to PC. UNCHECK the box that says "Enable advanced network functionality". My device sometimes hangs trying to apply this setting.. if so use the soft reset hardware button, then try again.

This setting totally changes how the device behaves on the USB bus.. it now appears as "HTC Generic Serial" and with different USB IDs, etc, and it uses different protocols to communicate with the Host Adapter (it's a lot of black magic I don't know too much about).

This issues really does need to be resolved somehow, as I actually want to be able to use the "advanced network functionality" that my PDA has to offer.

I'm happy to assist in debugging and development, including remote access to systems where you can access my device if that would be of any assistance.

I've attached the output of two commands to this ticket. "VBoxManage list usbhost" and "lsusb".

Attachments

VBoxManage_list_usbhost.txt Download (2.2 KB) - added by teratorn 6 years ago.
command output: VBoxManage list usbhost
lsusb.txt Download (701 bytes) - added by teratorn 6 years ago.
command output: lsusb

Change History

Changed 6 years ago by teratorn

command output: VBoxManage list usbhost

Changed 6 years ago by teratorn

command output: lsusb

comment:1 Changed 6 years ago by kcarnold

I can confirm problems with the "Generic RNDIS" driver trying to connect to a SmartPhone. (Also Linux host.) I haven't tried the workaround, though. Hopefully a developer has access to such a device (I suspect anything that can ActiveSync won't work); if not, I can provide debugging information on request.

comment:2 Changed 6 years ago by DieterFauth

See ticket 1974, it could be related since one of my devices is a SmartPhone as well. "Generic RNDIS".

comment:3 Changed 5 years ago by DieterFauth

Problem still exists in 2.04.

comment:4 Changed 5 years ago by rabid9797

I am having the same problem. Unfortunately, the workaround will not work for me as I have BlackJack II which does not have the ability to turn off the advanced networking feature.

I can confirm that both ubuntu and my windows guest recognize the device, but the guest will not initialize it. The device appears in the device manager but has an error code saying "The device cannot start (code 10)"

I have tried the other workaround in ticket:2222 (blacklisting the RNDIS module), but this still does not work.

I can also confirm that this bug still exists in 2.0.6

comment:5 Changed 5 years ago by jansekal

my htc touch pro does not work on windows xp guest on Kubuntu 8.04 host. if I connect the device as RNDIS for the first time under host windows, i get the message, that new hardware was recognized, but there were some problems and the device wont work properly (under native windows all forks seamlessly) then it is necessary to restart the htc touch pro, reboot into native windows, connect it to active sync and after that the htc touch pro works again (after connecting it to the guest windows xp the device does not work neither as mass storage device nor as a device connectable via activesync) so i deleted virtualbox.. please email me after this bug is solved if you provide me with detailed information, how to provide you with detailed information concerning this bug, you may get some further info thanks

comment:6 Changed 5 years ago by teratorn

This seems to be a very popular issue... HTC devices are mainstream, high-volume handsets, and lots of people have them already with larger, extended markets on the way.

Unfortunately, Microsoft ActiveSync is the only 100% reliable way to sync these devices for all users. A lot of people will want to use it, and if they're using Linux this would mean using VirtualBox in a large number of cases. This is what I do, and I imagine it's a pretty typical scenario.

Any chance of seeing this issue (and other similar ones) resolved in the future?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use