VirtualBox

Ticket #1921 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Clipboard paste into WinXP guest crashes VB

Reported by: dimitris Owned by:
Priority: major Component: clipboard
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Host is Debian Sid, guest is WinXP Pro SP3. VB is from the Debian OSE package.

After copying some text from the host, the moment I tried to paste it into the guest VB crashed/aborted. Attaching log.

Attachments

VBox.log.1 Download (31.6 KB) - added by dimitris 6 years ago.

Change History

Changed 6 years ago by dimitris

comment:1 Changed 6 years ago by frank

Any chance to reproduce this? Or does it occur every time you paste something from the host into the guest?

comment:2 Changed 6 years ago by dimitris

It only happened that one time, and I've been copy/pasting often before and since then. If it happens again I'll upload the log here.

comment:3 Changed 6 years ago by frank

Please could you provide the minidump, see  http://www.virtualbox.org/wiki/User_FAQ?

comment:4 Changed 6 years ago by dimitris

I don't seem to have a minidump directory. The Control Panel settings say it should be under %SystemRoot%\Minidump and %SystemRoot% is C:\WINDOWS on the guest, but that directory was missing. I've created it, in case that prevented the minidump from being created.

Just to be clear, it wasn't just an application that crashed. The whole VM aborted "instantly" when I tried to paste.

comment:5 Changed 6 years ago by frank

Oh right, my fault. So please make sure you enable core dumps on your Linux host system and attach the core dump next time this bug occurs ( http://www.virtualbox.org/wiki/Core_dump), perhaps you could try a little bit to reproduce?

comment:6 Changed 6 years ago by dimitris

Hmm, a core dump will be problematic. I use the VM in order to work, under NDA, on code I don't own, on a Windows-only development environment. A VB core dump would include an image of the guest's memory, wouldn't it? Is there a way to remove that from the core dump, and if there is, would that still be useful for debugging?

I can try to reproduce when not running anything related to that work, but given how uncommon the bug is, it may take a while.

Is there any VB code I could modify to get extra debugging/logging around the copy/paste function?

comment:7 Changed 6 years ago by frank

Oh, in that case you could just install the virtualbox-ose-dbg package and open the core dump yourself. Next time such a core dump occurs just save the core dump and I will instruct you how to proceed. No, the guest memory content cannot be removed. When you've got a core dump make sure the virtualbox-ose-dbg package is installed. Then

gdb -c core /usr/lib/virtualbox/VirtualBox

I assume that you start VirtualBox using the GUI. You now are at the gdb prompt. Do

bt

to show a backtrace and attach the output here (please notify me with an additional comment as attaching logs doesn't general an E-mail.

comment:8 Changed 6 years ago by frank

  • Component changed from guest additions to clipboard

comment:9 Changed 6 years ago by frank

dimitris, any response?

comment:10 Changed 6 years ago by dimitris

I haven't been able to reproduce it since. Feel free to downgrade, but please leave it open since trac won't let me reopen it.

comment:11 Changed 6 years ago by DmitryG

I always had this bug while pasting, but recently I had this bug reproduced twice after booting Windows XP Pro XP3 and doing nothing (host: OpenSUSE 11.0). Guest OS just aborted. Anyway error was "vboxClipboardReadDataFromClient: XtGetSelectionValue failed to complete with 2000 milliseconds". Now I turned off clipboard interchange.

Now reading FAQ how to create dump etc., want to reproduce this bug cause its only annoying thing in VB as for me.

Sorry for my Eglish.

comment:12 Changed 6 years ago by DmitryG

Finally I got an error, again with no actions, before it clipboard worked well.

But dump file has size of 350Mb (256Mb), in bzip2 - 100Mb... So what shall I do?

comment:13 Changed 6 years ago by frank

Please paste the core dump to some file sharing service (e.g.  http://rapidshare.com/), perhaps splitted into several parts. Send the URL to frank _dot_ mehnert _at_ sun _dot_ com.

comment:14 Changed 6 years ago by frank

When you do this please don't forget to mention this ticket ID in the E-mail.

comment:15 Changed 6 years ago by DmitryG

Already sent e-mail with rapidshare.com links with dumps on August, 27, including 1921 ticket ID.

comment:16 Changed 6 years ago by frank

Dmitry, just saw this bug report again. I'm not sure if I already got your core dump. If possible, please could you send me that report again? It would be great if you could try to reproduce this problem with VirtualBox version 1.6.6. Thank you!

comment:17 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

There were several clipboard-related fixes in VirtualBox 2.0.2 and VirtualBox 2.0.4. Please upgrade to the latest version and check again. Reopen this bug if necessary.

comment:18 Changed 5 years ago by ToddAndMargo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Guys! Dudes!

Not fixed in 2.2.0. Copying from guest XP-Pro-sp3 to Linux causes guest to "abort". This happens about twice a day when I am in my office doing paperwork.

Please let me know what diagnostic logs you need me to send you next time this happens. This bug is very, very annoying and destructive: I'd love to help get it fixed! (Oh my gosh! Did I just volunteer for something!)

Many Thanks, -T

Host: CentOS 5.3; XFce 4.4.2 Guest: XP-Pro-SP3

comment:19 follow-up: ↓ 20 Changed 5 years ago by michael

comment:20 in reply to: ↑ 19 Changed 5 years ago by ToddAndMargo

Replying to michael:

Please see  http://www.virtualbox.org/ticket/3723.

This is probably a duplicate of that one. I concur

comment:21 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem persists with VirtualBox 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use