VirtualBox

Ticket #12245 (closed defect: fixed)

Opened 6 months ago

Last modified 3 weeks ago

Regression: 4.2.18 -> 4.3.0: WindowsXP/KVM - BSOD - 0x0000008E

Reported by: alxchk Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

After updating from 4.2.18 to 4.3.0 Guest WindowsXP SP3 /w all (?) current updates crashed with BSOD with error line:

0x0000008E (0xC0000005, 0xB19350BA, 0xBA4CFF48, 0x00000000)

However, Guest OS can be booted with KVM disabled, or in Safe mode. Note, that minidump wasn't create and system wasn't reboot after BSOD (Minidumps saving and auto rebooting options are setted up)

Tried next steps without success:

  • Fully remove/update guest additions
  • Migrate to Different chipset
  • Migrate from NOAPIC to APIC
  • Migrate from IDE to SATA/AHCI
  • Disable Network/USB/NX/PAE/Nesting

In all cases booted successfully in safe mode, but not in normal mode. In all cases downgrading to 4.2.18 makes the problem go away.

Attachments

bluescreen.png Download (10.0 KB) - added by alxchk 6 months ago.
BSOD screenshot
VBox.log Download (95.2 KB) - added by alxchk 6 months ago.
VBox_BSOD_4.3.2_and_4.3.0.png Download (117.9 KB) - added by Schninckel 6 months ago.
VBox_BSOD.log Download (91.9 KB) - added by Schninckel 6 months ago.
Logfile of XP-Machine BSOD-ing after Upgrade to 4.3.2
VBox_Safe_Mode.log Download (89.4 KB) - added by Schninckel 6 months ago.
Logfile of same XP-Machine booting fine in Safe Mode
VBox.2.log Download (98.7 KB) - added by alxchk 5 months ago.
Vbox 4.3.2
VBox_imported_physical_Machine.log Download (95.8 KB) - added by Schninckel 5 months ago.
VBox.log - imported from a physical intel machine

Change History

Changed 6 months ago by alxchk

BSOD screenshot

Changed 6 months ago by alxchk

comment:1 follow-up: ↓ 2 Changed 6 months ago by ramshankar

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #12227

comment:2 in reply to: ↑ 1 Changed 6 months ago by alxchk

Replying to ramshankar:

Duplicate of #12227

 https://www.dropbox.com/s/ygv1hnfxehmvi5m/115328scr.png

If #12227 fixed, then this bug is not duplicate of the that one, because it still here, on 4.3.2

comment:3 Changed 6 months ago by alxchk

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Changed 6 months ago by Schninckel

comment:4 in reply to: ↑ description Changed 6 months ago by Schninckel

Same Problem for me: Windows XP Machine works in Safe Mode, BSOD on boot with any other configuration. BSOD appears in 4.3.0 and 4.3.2 and disappears when downgrading to 4.2.18. Tried some things to resolve it (changed SATA to IDE, disabled Networking and USB, booted with and without Graphics Driver, etc.) but for now I seem to be stuck on 4.2.18. I doubt that this bug is a duplicate of #12227, it shows completely different behavior. This one seems similar: #12293. @ramshankar: Right now I'm short in time, but if you are interested, I'm trying to produce some logs as soon as possible.

Replying to alxchk:

After updating from 4.2.18 to 4.3.0 Guest WindowsXP SP3 /w all (?) current updates crashed with BSOD with error line:

0x0000008E (0xC0000005, 0xB19350BA, 0xBA4CFF48, 0x00000000)

However, Guest OS can be booted with KVM disabled, or in Safe mode. Note, that minidump wasn't create and system wasn't reboot after BSOD (Minidumps saving and auto rebooting options are setted up)

Tried next steps without success:

  • Fully remove/update guest additions
  • Migrate to Different chipset
  • Migrate from NOAPIC to APIC
  • Migrate from IDE to SATA/AHCI
  • Disable Network/USB/NX/PAE/Nesting

In all cases booted successfully in safe mode, but not in normal mode. In all cases downgrading to 4.2.18 makes the problem go away.

Last edited 6 months ago by Schninckel (previous) (diff)

comment:5 follow-up: ↓ 6 Changed 6 months ago by frank

Schninckel, please attach a VBox.log file for a VM session running on VBox 4.3.2. Thank you!

Changed 6 months ago by Schninckel

Logfile of XP-Machine BSOD-ing after Upgrade to 4.3.2

Changed 6 months ago by Schninckel

Logfile of same XP-Machine booting fine in Safe Mode

comment:6 in reply to: ↑ 5 Changed 6 months ago by Schninckel

Replying to frank:

Schninckel, please attach a VBox.log file for a VM session running on VBox 4.3.2. Thank you!

Sorry, it took some time before I had the chance to upgrade to 4.3.2 again - this is my workstation for productive use.

comment:7 Changed 6 months ago by frank

Thanks! Now I'm really sure what the problem is: The access to MSR 0x2C. This one is not documented on AMD and will actually raise a GP (general protection fault) on physical hardware but for some reason your Windows guest seems to expect that this MSR can be read without raising a GP. VBox 4.2.x just returned 0 and didn't raise a GP while VBox 4.3.x raises a GP on AMD.

comment:8 follow-up: ↓ 9 Changed 6 months ago by frank

Did you create this guest initially on an Intel box by any chance?

comment:9 in reply to: ↑ 8 Changed 6 months ago by Schninckel

Replying to frank:

Did you create this guest initially on an Intel box by any chance?

Initially I created this machine on an AMD-based PC, but then copied it over to a Laptop my employer gave me, which was pure Intel Hardware. Some months ago I moved the Virtual XP Machine back to the originating AMD PC. So it was not really created on Intel Hardware, but lived there for a while.

comment:10 Changed 6 months ago by Schninckel

Edit: Just tried to boot the XP Machine with AMD-V disabled in VB 4.3.2. and it works just fine. (I always thought, I couldn't revert back to non-accelerated mode, once it's been enabled.) Turning AMD-V back on triggers the BSOD again.

comment:11 Changed 5 months ago by alxchk

Just FYU: I never used VirtualBox on AMD

Last edited 5 months ago by alxchk (previous) (diff)

comment:12 Changed 5 months ago by frank

alxchk, please attach a VBox.log file for a VBox 4.3.2 VM session where you see this BSOD.

Changed 5 months ago by alxchk

Vbox 4.3.2

comment:13 Changed 5 months ago by Schninckel

I'm attaching a logfile of a friends PC. His virtual XP Machine has been imported from a physical Intel-Machine. It was running fine on an AMD host until 4.3.2, since then it's BSODing. Reverting back to 4.2.18 or turning of AMD-V makes the problem go away.

Changed 5 months ago by Schninckel

VBox.log - imported from a physical intel machine

comment:14 Changed 5 months ago by frank

alxchk, your problem is handled in #12240.

comment:15 Changed 5 months ago by Schninckel

@frank: Just wanted to ask, if this bug is still under investigation and if I can provide you with any additional data, to solve this problem. And: #12420 might be a duplicate of this bug.

comment:16 Changed 4 months ago by frank

This bug is still under investigation. Your VM is kind of a special case (a VM running on an AMD box is accessing an MSR of an Intel box. It would BSOD on bare metal so we are currently discussing how we define the VBox behavior. I know that you expect that VBox should tolerate that MSR access as VBox 4.2.x did so...

comment:17 follow-up: ↓ 18 Changed 4 months ago by frank

VBox 4.3.6 should fix your VMs, please confirm.

comment:18 in reply to: ↑ 17 Changed 4 months ago by Schninckel

Replying to frank:

VBox 4.3.6 should fix your VMs, please confirm.

VBox 4.3.6 fixes the Problem on both my affected machines.

Steps to reproduce 1:

  1. Copy a working Win-XP-Machine from an AMD-PC to an Intel-PC
  2. Start XP-Machine on Intel-PC (Vbox-Version makes no Difference here)
  3. Copy XP-Machine from Intel-PC back to AMD-PC
  4. Start XP-Machine on AMD-PC with Virtualbox 4.3.0/4.3.2/4.3.4 -> BSOD
  5. Start XP-Machine with Virtualbox 4.3.6 -> works as expected, no BSOD

Steps to reproduce 2:

  1. Migrate a physical XP-Installation from an Intel-System to a Virtual-Machine
  2. Start XP-Machine on AMD-PC with Virtualbox 4.3.0/4.3.2/4.3.4 -> BSOD
  3. Start XP-Machine with Virtualbox 4.3.6 -> works as expected, no BSOD

comment:19 Changed 3 weeks ago by ramshankar

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use