VirtualBox

Ticket #12293 (closed defect: duplicate)

Opened 20 months ago

Last modified 19 months ago

Windows XP DON'T WORK in Version 4.3.2

Reported by: yann458 Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.3.2 Keywords: virtualbox,xp,bsold
Cc: Guest type: other
Host type: other

Description

Windows XP , don't work with VirtualBox 4.3.2 ; I'have a bsod

Impossible join a DMP.

Attachments

test windows XP.png Download (11.6 KB) - added by yann458 20 months ago.
VBox.log Download (87.8 KB) - added by yann458 20 months ago.
test windows XP.vbox Download (11.9 KB) - added by yann458 20 months ago.

Change History

Changed 20 months ago by yann458

Changed 20 months ago by yann458

Changed 20 months ago by yann458

comment:1 Changed 20 months ago by yann458

The safemode run is work good.

I try update kernel linux

comment:2 Changed 20 months ago by yann458

I have removed VirtualBox 4.3.2 and reinstalled the version 4.2.18. I upgrade kernel linux , problem no resolved .

Sorry , but on VirtualBox 4.2.18 my guest windows XP work good (No BSOD) .

Last edited 20 months ago by yann458 (previous) (diff)

comment:3 Changed 20 months ago by frank

  • Priority changed from blocker to major

comment:4 Changed 20 months ago by frank

It's most likely because the guest is trying to read from MSR 0x2C. This MSR is not implemented on AMD processors. Did you install this WinXP guest on an Intel CPU by any chance?

comment:5 Changed 20 months ago by yann458

My Windows XP on guest machine DON'T work with VirtualBox 4.3.2

My Windows XP on guest machine work with VirtualBox 4.2.18
I tested only AMD Processor.
Otherwise,

About If it's MSR 2c ,
WHAT line of source code VMM do I recopy from the 4.2.18 version into 4.3.2 Virtualbox version for my Windows XP guest will run on VirtualBox 4.3.2 (installed into host AMD processor) ??
Thank,

Last edited 20 months ago by yann458 (previous) (diff)

comment:6 Changed 19 months ago by _ReD_

Temporarily, you may want to disable amd-v for that machine. In my case XP guests that crash with AMD-V enabled under 4.3.x (and worked on 4.2), will function on 4.3 as well with hardware assisted virtualization disabled.

Last edited 19 months ago by _ReD_ (previous) (diff)

comment:7 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of #12420.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use