VirtualBox

Ticket #12227 (closed defect: fixed)

Opened 6 months ago

Last modified 6 months ago

Red Bar Win XP => Fixed in SVN

Reported by: ArtZ Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: other
Host type: other

Description

upgraded to 4.3.0, all XP vm's were stable. Now after running at some point they get red bar up top, have to reset them fairly often. This might be similar to another xp bug submitted too for 4.3 by other users.

Art PS. Nice improvements overall, kudo's to dev team!

Attachments

VBox.log Download (206.8 KB) - added by ArtZ 6 months ago.
VBox.log.1 Download (111.2 KB) - added by ArtZ 6 months ago.
VBox.log.2 Download (105.2 KB) - added by ArtZ 6 months ago.
VBox.log.3 Download (94.0 KB) - added by ArtZ 6 months ago.
Capture.JPG Download (71.8 KB) - added by ArtZ 6 months ago.
VBox.2.log Download (90.0 KB) - added by ArtZ 6 months ago.
Capturex.JPG Download (13.6 KB) - added by ArtZ 6 months ago.
VBoxabc.log Download (86.8 KB) - added by ArtZ 6 months ago.
cap2.JPG Download (22.5 KB) - added by ArtZ 6 months ago.
VBox.3.log Download (68.6 KB) - added by ArtZ 6 months ago.
minidumps.zip Download (30.4 KB) - added by B.Sam 6 months ago.
BartPE-1.JPG Download (73.0 KB) - added by B.Sam 6 months ago.
BartPE-2.JPG Download (77.5 KB) - added by B.Sam 6 months ago.
Mini102413-01.dmp Download (88.0 KB) - added by B.Sam 6 months ago.
ATTEMPTED_WRITE_TO_READONLY_MEMORY

Change History

comment:1 Changed 6 months ago by ramshankar

Could you please provide VBox.log for the VM where you see the read-bar. Are Windows guest additions installed for the VM? If so which version of the additions are installed?

Changed 6 months ago by ArtZ

Changed 6 months ago by ArtZ

Changed 6 months ago by ArtZ

Changed 6 months ago by ArtZ

comment:2 Changed 6 months ago by ArtZ

Attached logs... not sure if one of these is the red line, but the last one vbox.log is another failure in xp where the machine died and got the vb error box.

guest additions is also 4.3

art

comment:3 Changed 6 months ago by ramshankar

Could you check if booting the VM in safe-mode and removing the 4.3 Guest Additions and rebooting makes the VM healthy again?

comment:4 Changed 6 months ago by ArtZ

tried rebooting in safe mode... got capture.jpg multiple times.

reset a few times more and rebooted finally in normal mode.

will remove guest additions and let you know.

Last edited 6 months ago by ArtZ (previous) (diff)

Changed 6 months ago by ArtZ

comment:5 Changed 6 months ago by klaus

FYI, the red bar is a Windows BSOD which for some super strange reason is displayed in the wrong video mode.

Changed 6 months ago by ArtZ

comment:6 Changed 6 months ago by ArtZ

just had a different vm --- exact same config, xp, 4.3 etc. red bar or bsod too... see attached log.

comment:7 Changed 6 months ago by ArtZ

turned off guest additions on first vm, running fine for several hours now.... also had turned off enable usb.

reenabling guest additions and will let it run over night. cant say what I was doing the first time the it red lined.

the second vm here also red lined.. turned off usb option and it was able to come up okay.. turned it back on and it red lined. see capturex.jpg attachment.

guest additions are enabled on this second vm.

Last edited 6 months ago by ArtZ (previous) (diff)

Changed 6 months ago by ArtZ

comment:8 Changed 6 months ago by ArtZ

spoke to soon -- 2nd vm with guest additions still enabled, but usb turned off, able to restart and come up, but redlined while in mozilla.

log attached vboxabc.log

Changed 6 months ago by ArtZ

Changed 6 months ago by ArtZ

Changed 6 months ago by ArtZ

comment:9 Changed 6 months ago by ArtZ

error while sitting idle in xp vm.. see cap2.jpg and vbox.log just added.

Last edited 6 months ago by ArtZ (previous) (diff)

comment:10 Changed 6 months ago by B.Sam

I can also confirm this behavior. it also appears that klaus is right in saying this is actually a BSOD. a quick look at the minidumps, shows the error is PAGE_FAULT_IN_NONPAGED_AREA (i also see bsods with the same message sometimes when i load BartPE in a vm). I'm just guessing here based on my observations, but it seems to me that after getting one of those, if i do not revert the snapshot, i hardly get another one(if any) though that might not actually be the case. If its any help, i also see guest additions service crashes from time to time, not sure if its related to this bug however. I will attach 2 minidumps that the guest OS provided on bsod, and 2 picture of BartPE BSOD.

Last edited 6 months ago by B.Sam (previous) (diff)

Changed 6 months ago by B.Sam

Changed 6 months ago by B.Sam

Changed 6 months ago by B.Sam

comment:11 Changed 6 months ago by VirtualBurns

As a test I made a fresh install of XP with "Enable IO APIC" unhecked, and have experienced no crashing.

Anyone else having success without IO APIC? (It's not an easy change to make to pre-existing VMs...)

comment:12 Changed 6 months ago by B.Sam

It also appears that i'm unable to reproduce a crash in BartPE if i turn off APIC. VirtualBurns beat me to it in reporting that :)

Edit: about to add a minidump of guest BSOD when as a test, i changed the number of CPUs from 2 to 1 while APIC was still enabled and booted the VM. it crashed before the welcome screen.

Last edited 6 months ago by B.Sam (previous) (diff)

Changed 6 months ago by B.Sam

ATTEMPTED_WRITE_TO_READONLY_MEMORY

comment:13 Changed 6 months ago by ramshankar

Fixed the bug in SVN. The fix will be available in the next maintenance release. The bug is VT-x specific, and is caused due to an incorrect TPR-threshold mask.

Thank you for the report!

comment:14 Changed 6 months ago by frank

  • Summary changed from Red Bar Win XP to Red Bar Win XP => Fixed in SVN

comment:15 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 4.3.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use