VirtualBox

Ticket #11758 (reopened defect)

Opened 3 years ago

Last modified 7 months ago

"Take Screenshot" just makes black PNG ==> Fixed in SVN

Reported by: Aren Cambre Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.12 Keywords:
Cc: aren@… Guest type: Linux
Host type: Windows

Description

If I hit Take Screenshot, all I get is a black PNG. I've attached the PNG. I've also attached a user-generated screenshot, created from hitting PrtScn while VirtualBox does not have the focus (and later cropped with GIMP).

System state:

  • guest is Ubuntu 13.04, fresh install
  • Guest Additions installed, has been rebooted
  • host is Windows 8 x64

If you look at the manually-taken screenshot, you'll notice a problem with z-order on the windows: even though Chromium is below gedit, Chromoium's chrome web store content is displaying above gedit. I'm filing a separate issue with Ubuntu over this, but that should not affect VirtualBox's ability to take a screenshot, as it really should just be slicing off a copy of the final rendered output.

Attachments

VBox.log Download (87.7 KB) - added by Aren Cambre 3 years ago.
VBox.log.1 Download (111.2 KB) - added by Aren Cambre 3 years ago.
Ubuntu 13.png Download (4.7 KB) - added by Aren Cambre 3 years ago.
user-generated screenshot (resized).png Download (430.8 KB) - added by Aren Cambre 3 years ago.
VBox.2.log Download (101.1 KB) - added by snoopy1978 2 years ago.
VBox.log of taking black screenshot

Change History

Changed 3 years ago by Aren Cambre

Changed 3 years ago by Aren Cambre

Changed 3 years ago by Aren Cambre

Changed 3 years ago by Aren Cambre

comment:1 Changed 3 years ago by fpn

Same here on:

  • Guest: Ubuntu 12.10
  • Guest Additions installed 4.2.12_84980
  • Host: OS X 10.8.3
  • VirtualBox: 4.2.12_84980

Specifically I can't take screenshots inside the VM e.g. run gimp on Ubuntu and capture screen.

comment:2 Changed 3 years ago by frank

  • Component changed from other to 3D support

Most likely 3D-related. If you would disable 3D, creating a screenshot would work.

comment:3 Changed 3 years ago by Aren Cambre

Strangely, I can no longer reproduce. Regardless of whether I have 3D turned on, I can now get screenshots.

comment:4 Changed 2 years ago by Vort

Same problem for Linux Mint 15 (or 16) Cinnamon 64-bit: screenshots are black

  • VirtualBox: 4.3.2
  • Host: Windows 7
  • Guest: Linux Mint 15 Cinnamon 64-bit
  • 3D acceleration is enabled

comment:5 Changed 2 years ago by fpn

Yep, problem also persists for me:

  • Guest: Ubuntu 12.10
  • Guest Additions installed 4.3.0_89960
  • Host: OS X 10.8.5
  • VirtualBox: 4.3.0_89960

comment:6 Changed 2 years ago by misha

This issue should be now fixed.
Please give a try to the following test build that has the fix included, and let me know whether it works for you:

Last edited 2 years ago by frank (previous) (diff)

comment:7 Changed 2 years ago by misha

  • Summary changed from "Take Screenshot" just makes black PNG to "Take Screenshot" just makes black PNG ==> Fixed in SVN

comment:8 Changed 2 years ago by RoteAdler

4.3.7-92195 solves the following issues for me:

  • #11758 "Take Screenshot" just makes black PNG (this issue)
  • #7953 Just desktop background in preview
  • #other Video capturing still image

In fact, my issue was: when using 3D the preview freezes and "take screenshot" or "video capture" uses the preview image; maybe not the same physical image, but time coincident.

Now, this didn't solve #12306. That seems related, because the image was once again "the same". Anyway, there are other problems that make the mini toolbar a poor solution, see #12344.

comment:9 Changed 2 years ago by frank

Could you test  VBox 4.3.8 RC1?

comment:10 Changed 2 years ago by RoteAdler

  • 4.3.8_RC1-92386 tested with windows7 host
  • windows7, windows8.1, ubuntu13.10, and other guest
  • 3d disabled and enabled where applicable:

screenshot, preview and video capture working as expected, thank you :)

comment:11 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

comment:12 Changed 2 years ago by snoopy1978

  • Status changed from closed to reopened
  • Resolution fixed deleted

In this constellation exactly this problem occurs (again):

  • Host: Windows 7 x64
  • VirtualBox 4.3.10
  • Guest: Ubuntu 14.04, GuestAdditions installed

comment:13 Changed 2 years ago by Aren Cambre

It's working for me. My only difference is the host is Windows 8.1 x64.

comment:14 Changed 2 years ago by frank

snoopy1978, please attach a VBox.log file of such a VM session.

Changed 2 years ago by snoopy1978

VBox.log of taking black screenshot

comment:15 Changed 2 years ago by snoopy1978

sorry for the delay, just noticed the answers today.

I attached a VBox.log from this session:

1) Start VM with Ubuntu Guest
2) Login to Ubuntu Guest
3) Take a screenshot which was black

comment:16 Changed 2 years ago by snoopy1978

Just made a short screen capture in VirtualBox, you can see it here:

 https://www.dropbox.com/l/BDTacT2kFDkxwlJMblMrWq?

comment:17 Changed 2 years ago by jonathan naguin

This problem occurs with:

  • Windows 7 x64
  • VirtualBox 4.3.12r93733
  • Guest: Ubuntu 12.04 LTS

If I disable the 3D Acceleration (correctly enabled in Ubuntu) it works as expected.

Last edited 2 years ago by jonathan naguin (previous) (diff)

comment:18 Changed 2 years ago by asayler

I'm also seeing this on:

  • Host: Ubuntu 14.04 x64
  • VirtualBox: 4.3.10_Ubuntu r93010
  • Guest: Ubuntu 14.04 x64 (Guest extensions installed from Ubuntu repos)

Screenshots are black when 3D Acceleration is enabled, but fine when it is disabled.

Last edited 2 years ago by asayler (previous) (diff)

comment:19 Changed 18 months ago by Aren Cambre

Still a problem with 3D acceleration enabled on:

  • Host: Windows 8.1 x64
  • VirtualBox: 4.3.18 r96516
  • Guest: Ubuntu 14.14 x64 (Guest Additions installed via VirtualBox, not Ubuntu)

comment:20 Changed 9 months ago by snowch

This problem happens with 3D acceleration on:

  • Host: Mac OS X Yosemite 10.10.4
  • Guest: Ubuntu 15.04 x64
  • Virtualbox guest additions: installed via Virtualbox
  • Virtualbox version: 5.0.0r101573

Screenshots work fine with 3D acceleration disabled.

comment:21 Changed 7 months ago by alexsch

The issue also affects java.awt.Robot.createScreenCapture(rectangle) method in JDK.

For more details see issue JDK-8138759 Robot.createScreenCapture() does not work on VirtualBox with installed GuestAdditions

 https://bugs.openjdk.java.net/browse/JDK-8138759

The Robot.createScreenCapture(rectangle) uses "GdkPixbuf *gdk_pixbuf_get_from_drawable ()" method in GTK and and it just returns a screenshot with background or with some dark rectangles on VirtualBox with GuestAdditions installed and the 3D Acceleration option enabled.

Last edited 7 months ago by alexsch (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use