VirtualBox

Ticket #11759 (closed defect: duplicate)

Opened 9 years ago

Last modified 8 years ago

Error renaming connection Installer error VirtualBox-4.2.12-84980-Win.exe

Reported by: JerryW Owned by:
Component: installer Version: VirtualBox 4.2.12
Keywords: connection, rename, error, installer Cc:
Guest type: Windows Host type: Windows

Description

Message Box pop up 9/10th of the way through install of VirtualBox-4.2.12-84980-Win.exe. This occurs during both upgrading and install Upgrade after pre existing Virtual box installs of VirtualBox-4.2.10-84105-Win.exe and VirtualBox-4.2.6-82870-Win.exe And install after control panel "uninstall" And install after uninstall followed by manual delete of "Local Area connection 4 Virtual box host only" see image attached. I am thinking of hitting the registry to look for candidate "connections" I am assuming this is a Network connection. Possibly caused by McAfee enterprise and some sort of network controls. (I'll report back if the same now occurs with re-install of VirtualBox-4.2.10-84105-Win.exe) The result of this is that during launch of Virtualbox VM (Windows XP) an error is generated (I'll post back this error on restart of my machine - as I have now replicated the installer error, but need a restart to get the Virtual box error. Windows 7 host, full admin rights (and have tried right click - Run as administrator)

Attachments

VirtualBox-4.2.12-84980-Win.exe Windows 7 installer error 3 images.png Download (155.7 KB) - added by JerryW 9 years ago.
Screenshot of error, installer state and network connections
VirtualBox-4.2.12-84980-Win.exe post restart error.png Download (31.5 KB) - added by JerryW 9 years ago.
Failed to open a session for the virtual machine XP VM. Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE). Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

Change History

Changed 9 years ago by JerryW

Screenshot of error, installer state and network connections

comment:1 Changed 9 years ago by JerryW

OK, the start Virtualbox error changed to unable to load kernel, so I did a repair install - which fixed it, all up and running! Not sure what is the cause! Replicate something like: Windows 7 32 bit on Lenovo T400 with Virtualbox 4.2.10 (which has been upgraded from 4.2.6) Simply upgrade to 4.2.12. Fix ? Uninstall repair install, uninstall, delete Virtualbox network connection, re install as administrator, uninstall, reinstall as administrator repair install as normal admin right user. Rebooting each time. I guess this must be a user rights and in use virtualbox network connection that Windows 7 will not release issue.

Changed 9 years ago by JerryW

Failed to open a session for the virtual machine XP VM. Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE). Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

comment:2 Changed 9 years ago by JerryW

Post reboot I am now getting Failed to open a session for the virtual machine XP VM.

Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

Which was what I was trying to recreate above.

comment:3 Changed 9 years ago by JerryW

Resolved it! You need to delete the extraneous network connections from your registry.

I followed the Techguy info from this link:  http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-can-i-remove-old-network-connections/679baf9b-0303-4b2c-af51-92981477a43a

But make sure the connections you delete are safe to delete. I checked using a Wifi connection, followed by a Ethernet connection, checking he adapters and naming of the connections, then deleted all the remaining ones. Typically named something like: "Local Area Connection* 12" - had around 120 - 130 of these which I think perhaps made the installer run out of network numbers.

comment:4 Changed 9 years ago by JerryW

duh... ignore the "Resolved it" - it doesn't survive a reboot :(

Installer worked 100%, and did not request a reboot. But to make sure I have now just rebooted - the result being: Failed to open a session for the virtual machine XP VM.

Failed to load VMMR0.r0 (VERR_LDR_MISMATCH_NATIVE).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

Odd really as it worked 100% before reboot, I have not run any other software, simply exited the VM, then restarted Windows 7.

The might be a different issue - but it was introduced by the installer for this version.

Any help would be much appreciated....

The key refers to a registry entry for "ProxStubClsid" for iConsole, but the registry key doesn't give any real clues as to what it does (apart from proxy of some sort)

Last edited 9 years ago by JerryW (previous) (diff)

comment:5 Changed 9 years ago by JerryW

OK thanks to this forum, running it as admin works, so this seems to be an access or restricted file problem??

 https://forums.virtualbox.org/viewtopic.php?f=6&t=34542#p177439

Re: Windows 7 VERR_LDR_MISMATCH_NATIVE by blackisle » 3. Mar 2011, 15:18

Driver Verifier was not enabled on my system. I can say that Right Clicking the Virtual Box icon and "Run As Administrator" has solved the issue on my install.

Hope this helps!

comment:6 Changed 8 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10872. Please read the most recent comments there (in particular from 'bird') and continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use