VirtualBox

Ticket #12306 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Mini toolbar leaves black area in full-screen mode

Reported by: matthijs Owned by:
Component: other Version: VirtualBox 4.3.2
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

The mini toolbar leaves a black area when it retracts to the screen border. This is a regression with respect to VB 4.2.18

The guest is Ubuntu 13.10, the host is Windows7.

Attachments

VBox.log Download (70.5 KB) - added by matthijs 6 years ago.
VB popup artifact.png Download (2.0 KB) - added by le.jawa 6 years ago.

Change History

Changed 6 years ago by matthijs

comment:1 Changed 6 years ago by RoteAdler

In src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp, VBox 4.3 has a new method to draw the mini toolbar, that fails with some hardware when 3D is enabled. The new method is not activated when Q_WS_X11 (linux) is defined, and the mini toolbar is ok. Old style squared, but ok.

If nothing more can be done, and that would be solving #7953, I suggest the mini toolbar draw method to be a user option instead of a preprocessor macro.

comment:2 in reply to: ↑ description Changed 6 years ago by le.jawa

Replying to matthijs:

The mini toolbar leaves a black area when it retracts to the screen border. This is a regression with respect to VB 4.2.18

The guest is Ubuntu 13.10, the host is Windows7.

I'm seeing the same problem with a similar configuration - Windows 7 host, VB 4.3.4, Ubuntu 13.04 guest (all 64-bit), Radeon HD 7570M video chip. The black artifact covers up any contents of the VM: background, applications, etc; rendering the bottom portion of the screen nearly unusable.

Changed 6 years ago by le.jawa

comment:3 Changed 5 years ago by ${NICK}

Confirmed for Windows 8.1 host, Fedora 20 Guest, Nvidia GTX480 graphics card.

comment:4 Changed 5 years ago by matthijs

I now have more information:

  • VBox 4.3.10 on Windows 7
  • Client Ubuntu 14.04, 32bit, 3D acceleration on, screen 1600x900x32
    • With gnome-session-flashback and all dependencies installed
    • This gives the following 3 desktop environments to chose from at login time (click the Ubuntu logo):
      • GNOME Flashback (Compiz)
      • GNOME Flashback (Metacity)
      • Ubuntu (default)

With "GNOME Flashback (Metacity)" the mini toolbar behaves correct.
With "GNOME Flashback (Compiz)" the mini toolbar shows the problem.

Last edited 5 years ago by matthijs (previous) (diff)

comment:5 Changed 5 years ago by damienc

Confirmed for

  • Host : Windows 8.1. Virtualbox 4.3.12r93733 with extpack
  • Guest : Debian Wheezy with 3D acceleration and guest-additions installed

(all 64 bits)

Here is what appears on the bottom of the screen: http://i.imgur.com/LxFTjOG.png

Particularry annoying, when I spend all my work time on my VM.

comment:6 Changed 5 years ago by cremor

This doesn't just happen on Linux guests, but also on Windows. I have the same problem with a Windows 8.1 x64 guest on a Windows 7 SP1 x64 host as soon as I enable 3D acceleration.

comment:7 Changed 5 years ago by jj05

A workaround to the issue is to disable the mini-toolbar on the VM

VM Settings > General > Advanced tab

Mini ToolBar: [ ] Show in Fullscreen/Seamless

comment:8 Changed 5 years ago by RoteAdler

This is solved in v4.3.16, tested with Win7 host and Win7, Win8, Ubuntu clients.

Thank you :)

comment:9 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thank you for the confirmation!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use