VirtualBox

Ticket #9946 (new defect)

Opened 2 years ago

Last modified 3 months ago

Guest does not work when 3D is activated

Reported by: mcgimpsey Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by misha) (diff)

Host is Windows Vista Home Premium 64 bit, service pack2 Attempting to run Ubuntu 11.10 (Linux) guest with 3D. Works when 3D is not activated, but either fails or hangs when 3D is activated through the VirtualBox interface.

Have attached zip file that contains Word document and VirtualBox logs.

In Word document have added screen shots concerning the Intel 3D software on the host computer. It is my understanding that VirtualBox tunnels 3D functions to the guest from the host machine.

The Linux kernal is 3.0.0.12-generic

Attachments

VBox.log Download (64.4 KB) - added by mcgimpsey 2 years ago.
VBoxSVC.log Download (1.7 KB) - added by mcgimpsey 2 years ago.
Virtual Box Log
VLinUb1110.vbox Download (10.1 KB) - added by mcgimpsey 2 years ago.
Virtual Box Guest Machine
StoppedWorking.pdf Download (86.6 KB) - added by mcgimpsey 2 years ago.
Screen Shot
ScreenShots1.pdf Download (178.2 KB) - added by mcgimpsey 2 years ago.
Screen Shots pertinent to ticket
ScreenShots2.pdf Download (285.2 KB) - added by mcgimpsey 2 years ago.
Screen Shots pertinent to ticket
VBoxSVC.2.log Download (1.4 KB) - added by mcgimpsey 2 years ago.
VBox.2.log Download (89.4 KB) - added by mcgimpsey 2 years ago.
VBoxSVC.3.log Download (2.3 KB) - added by mcgimpsey 2 years ago.
VBox.3.log Download (92.6 KB) - added by mcgimpsey 2 years ago.
guest VB log file
3DIssue.zip Download (120.5 KB) - added by mcgimpsey 2 years ago.
Information and screen shot of Ubuntu screen - zipped
VBox.4.log Download (60.0 KB) - added by mcgimpsey 2 years ago.
VBox log
VBoxSVC.4.log Download (3.6 KB) - added by mcgimpsey 2 years ago.
VBox SVC
VLinUb9.04.log.txt Download (1.8 KB) - added by mcgimpsey 2 years ago.
Guest log
VLinUb1110.2.vbox Download (9.9 KB) - added by mcgimpsey 2 years ago.
VBox guest profile
WER817F.tmp.version.txt Download (480 bytes) - added by mcgimpsey 2 years ago.
Window Vista Dump file1
WER910A.tmp.appcompat.txt Download (37.6 KB) - added by mcgimpsey 2 years ago.
Window Vista Dump file2

Change History

Changed 2 years ago by mcgimpsey

Changed 2 years ago by mcgimpsey

Virtual Box Log

Changed 2 years ago by mcgimpsey

Virtual Box Guest Machine

Changed 2 years ago by mcgimpsey

Screen Shot

Changed 2 years ago by mcgimpsey

Screen Shots pertinent to ticket

Changed 2 years ago by mcgimpsey

Screen Shots pertinent to ticket

comment:1 Changed 2 years ago by misha

Your guest has two screens according to the log. Could you try to start the guest with one screen and see if the problem goes away?

comment:2 Changed 2 years ago by misha

Also, please attach the dump for the crash you are seeing. See https://www.virtualbox.org/ticket/9267#comment:36 for detail on enabling the crash dump generation.
In case the dump is too big to be attached here, drop me a mail at mikhail dot sennikovsky at oracle dot com and I will post you a link to our public ftp server where you could upload it.

comment:3 follow-up: ↓ 4 Changed 2 years ago by mcgimpsey

Not concerned about the dump.

Am concerned about the 3D issue. Message in the log (I showed in 9945 which is a duplicate and is closed...), is: "OpenGL Warning: FBO status(0x8cdd) isn't complete"

This seems to be the problem for the 3D not working. When starting the guest, it simply freezes after this message is given... or it crashes... (normally it simply freezes and discontinues brining up the guest).

comment:4 in reply to: ↑ 3 Changed 2 years ago by misha

Replying to mcgimpsey:

Not concerned about the dump. Am concerned about the 3D issue.

As long as the "3D issue" causes the host VM process to crash like you said, we DO concerned about the dump, since w/o it it's hard to guess what caused the crash, so please consider attaching it here.
Please also try running a guest with one screen like I mentioned in Comment 2 to see if the issue goes away. This is actually needed to determine whether the issue is caused by a multiscreen handling-specific code.

Changed 2 years ago by mcgimpsey

Changed 2 years ago by mcgimpsey

comment:5 Changed 2 years ago by mcgimpsey

Attached two files: vboxSVC.2.log and vbox.2.log

Started guest with one monitor and 3D activated as requested.

Guest came up with desktop background color, but no desktop icons whatever. Just plain screen(other than desktop background color) and sat there frozen, doing nothing.

Did not experience a VirtualBox application failure on the Windows host, so, no application dump to provide.

Noticed that I did not see the message "OpenGL Warning: FBO status(ox8cdd)isn't complete" in the vbox.2.log this time.

Noticed two error lines in vboxSVC.2.log file... not sure if they are pointing to the reason of the guest doing nothing.

This does not happen when 3D is not activated.

Also.... I think the VirtualBox application failure occurs when 2 monitors and 3D is active.

Thanks for the help...Want to do some Android development and need 3D on the Linux guest.

Changed 2 years ago by mcgimpsey

Changed 2 years ago by mcgimpsey

guest VB log file

comment:6 Changed 2 years ago by mcgimpsey

Attached VBoxSVC.3.log and VBox.3.log files

Decided to try with 2 monitors and 3D active, again. I sent a change request update on 11/28/11 then sent this on 11/29/11 before obtaining a response for the 11/28/11 change request.

The 11/28 request was to activate with one monitor and 3D, which was done. The 11/29 was my attempt to activate with two monitors and 3D to see if I would get a dump.

I expected an application VirtualBox dump on the Vista host, but none occurred this time.

However... did notice the message "OpenGL Warning: FBO status(ox8cdd) isn't complete" this time in the VBox.3.log guest file.

Again... the VBoxSVC.3.log shows some type of errors at the end of the log. Don't know if that points to the guest not coming up.

The guest did come up, but only with black screens for both monitors with no icons or a desktop. Just sat there. At least with the one monitor, the desktop background color scheme displayed. But with two monitors, not even the background color scheme is displayed.

Is the FBO message expecting some type of status to be returned from the host's 3D application (Intel)???

I see posts on the internet that Ubuntu 11.04 and 11.10 DO work with the OpenGL 3D in VirtualBox. Did not learn, from the posts, what host was running VirtualBox.

comment:7 Changed 2 years ago by mcgimpsey

Hello...

Any further update concerning this defect???

comment:8 Changed 2 years ago by mcgimpsey

Have updated to VirtualBox 4.1.8.

Made attempt to bring up Ubuntu system with 3D and it STILL DOES NOT WORK.

Have not seen any more activity on this ticket.

Notice that with the Windows Guest machine that it is recommended to bring up in safe mode before upgrading the Guest Additions when using 3D. Apparently the reason is to allow certain system files to be updated with the Guest Additions that would not be accessible if windows was in normal operating mode.

To my knowledge there is no comparable "Safe Mode" in Linux. Therefore, are there any system files, that are involved with 3D, that should be deleted before running the Guest Additions to activate 3D?

Thanks...

Changed 2 years ago by mcgimpsey

Information and screen shot of Ubuntu screen - zipped

Changed 2 years ago by mcgimpsey

VBox log

Changed 2 years ago by mcgimpsey

VBox SVC

Changed 2 years ago by mcgimpsey

Guest log

Changed 2 years ago by mcgimpsey

VBox guest profile

Changed 2 years ago by mcgimpsey

Window Vista Dump file1

Changed 2 years ago by mcgimpsey

Window Vista Dump file2

comment:9 Changed 2 years ago by mcgimpsey

1/29/12 - Attached 3DIssue.zip file containing a Word Document file which shows the terminal window resulting from a 3D support test command of sudo /usr/lib/nux/unity_support_test - p

Attached Virutal Box log files of VBox.4.log, VBoxSVC.4.log,VLinUb9.04.log.txt, VLinUb1110.2.vbox

Attached Window dump files of WER817F.tmp.version.txt and WER910A.tmp.appcompat.txt. Was not able to send a third file, which may have been a mini-dump of some sort owing to your attachment restriction of 256KB. I have the file available if I can send through some other means.

Changed Unity Desktop to Gnome3 desktop. Looks the same to me, BUT.....

Am now able to bring up the guest Ubuntu11.10 machine when 3D is checked in the VirtualBox Manager. Some success....

However... ran 3D unity test (when 3D checked in VB Manager), and VirtualBox application failed in windows. Assume that the test performs some attempt at 3D activation and that is when the VB failed in Windows. Just an assumption.

When 3D is NOT selected in VB Manager, and run the test, then, see the attached document above(3DIssue.doc) to see the output in the terminal window.

From everything I can see, it appears that 11.04 and earlier worked with 3D just fine. Something is NOT right in 11.10, or... some setting must be done in Compiz or something to get working. There is a problem in 11.10 for 3D. Just google "3D on Ubuntu11.10" to see all the responses about failures...

Would like to, at least, know the status of what is being done. Will there be a newer version of Ubuntu forthcoming that corrects this issue or what????

Thanks...

comment:10 Changed 2 years ago by mcgimpsey

1/29/12 - 21:41 cst OK... something new Noticed that I had Chromium graphics driver on the Ubuntu 11.10 guest. Tried installing Nividia - believe I was successful Shut down the guest

Turned on 3D in VB Manager Started up Ubuntu 11.10 guest

Brought up the terminal window Entered the command for testing for 3D support of: sudo /usr/lib/nux/unity_support_test - p

This time something different happened. The VB application did not fail, instead received an output of:

Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0". Xlib: extension "GLX" missing on display ":0".

The remainder of the display that show what components are available did not appear.

So... appears that installing Nvidia is getting a little closer to having 3D support, if I can get past this "Xlib" message...

Would also like to know, what is the meaning of the first 3 lines that are returned from the 3D test that show something like:

OpenGL vendor string: Mesa Project OpenGL renderer string: Software Rasterizer OpenGL version string: 2.1 Mesa 7.11

++++++++++++++

Do these lines have something to do with the graphics driver being used? Wondering if that is a hint to the problem.

comment:11 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions?

comment:12 Changed 6 months ago by FreeEagle

Hi!

I can confirm this issue. I installed yesterday the last Version of Oracle Virtualbox 4.3 on my Windows 7 Prof. 64bit Up2Date. And i still have the same Problem. My Hardware are:

Dell Latitude E6520 With Nvidia Graphic Card NVS 4200M Connecting a Second Monitor to this Laptop using the Dell Replicator.

As a Guest i installed both Ubuntu 13.10 the last version with all Updates and Debian 7 also Up2Date.

Whenever i activate 3D in VirtualBox i get a Black Screen after loging in to the Operating System. When i deactivate the 3D. I can log in and both Monitors work well. The VirtualBOx Addition are installed and they have the same Version of the VirtualBox.

Best Regards, FreeEagle

comment:13 Changed 5 months ago by michael

Is this with two guest screens? This is currently known not to work. One monitor should work, and mirror mode should show an image on one screen with 3D enabled.

comment:14 Changed 3 months ago by markwkjr

I am experiencing this problem with TWO (2) guest screens on VB 4.3.6

I have Windows 7 host using Ubuntu 12.04 guest.

I was using VirtualBox (VB) 4.2.16 (where this was working) but decided to upgrade to 4.3.6 this weekend. I spent quite a lot of time troubleshooting, upgrading kernels (tried original 3.2 and upgraded to 3.8), uninstalling and installing Guest Additions (GA) several times, and what not, to no avail. I even built a brand new Ubuntu 12.04.03 Guest, same issue. When I have 2 screens and 3D Acceleration enabled I either get a black screen or only the background loads and I cannot use the Guest. Note, I can disable the 3D Acceleration, or at the logon screen change to Unity 2D and it will work. It worked with 1 guest screen, but not 2.

I downgraded to 4.2.20, I figured I'd try that instead of the 4.2.16 I was on to get a little newer software. I wanted to go to 4.2.22 but I couldn't find the extension pack for that version.

4.2.20 is working properly though in both my original guest and the clean install I built up. 2 guest screens running on my dual monitors. Guess I'll stay with 4.2 for now until this is resolved in 4.3.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use