VirtualBox

Ticket #994 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Assertion failed: PDMDevice.cpp(1920) => Fixed in SVN

Reported by: nikman Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I coped a big file (~700M) from vbox-share to local disk inside virtual machine and I got "aborted status". I reproduced the problem 3 times. Now I can't reproduce it. VBox-share on my host is USB-disk 100G with fat32.

Log created: 2007-12-20T16:09:27.148921000Z Executable: /usr/lib/virtualbox/VirtualBox

Arg[0]: /usr/lib/virtualbox/VirtualBox Arg[1]: -comment Arg[2]: WinXP_x32 Arg[3]: -startvm Arg[4]: 6db9f90d-441f-481e-fda5-8a97279cb139

!!Assertion Failed!! Expression: RT_SUCCESS(rc) Location : /usr/src/packages/BUILD/VirtualBox-1.5.2_OSE/src/VBox/VMM/PDMDevice.cpp(1920) void pdmR3DevHlp_ISASetIrqNoWait(PDMDEVINS*, int, int) VERR_VM_REQUEST_STATE (-1902) - Invalid VM request state. The state of the request packet was not the expected and accepted one(s). Either the interface user screwed up, or we've got corruption/broken logic.

Change History

comment:1 Changed 6 years ago by nikman

My OS is OpenSuSE 10.3 x86 (last update).

$ uname -a Linux linux-nikman 2.6.22.13-0.3-default #1 SMP 2007/11/19 15:02:58 UTC i686 i686 i386 GNU/Linux

$ cat /proc/cpuinfo processor : 0 vendor_id : GenuineIntel cpu family : 6 model : 15 model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz stepping : 6 cpu MHz : 1596.000 cache size : 4096 KB physical id : 0 siblings : 2 core id : 0 cpu cores : 2 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 10 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm bogomips : 4807.12 clflush size : 64

processor : 1 vendor_id : GenuineIntel cpu family : 6 model : 15 model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz stepping : 6 cpu MHz : 1596.000 cache size : 4096 KB physical id : 0 siblings : 2 core id : 1 cpu cores : 2 fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : yes fpu_exception : yes cpuid level : 10 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm bogomips : 4803.84 clflush size : 64

comment:2 Changed 6 years ago by frank

Duplicate of #567.

comment:3 Changed 6 years ago by frank

  • Summary changed from Assertion failed: PDMDevice.cpp(1920) to Assertion failed: PDMDevice.cpp(1920) => Fixed in SVN

We believe that we fixed this bug in SVN. The fix will be included in the next version (either 1.5.6 or 1.6).

comment:4 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use