VirtualBox

Ticket #995 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

XP guest fails to boot

Reported by: nashattan Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: windows xp mup.sys agp440.sys boot fail failure
Cc: Guest type: other
Host type: other

Description

Using qemu and vmplayer, I created a vmdk file (and corresponding vmx) that had a complete windows installation on it. Now I am trying to switch over to virtualbox, but the machine I created using said vmdk file fails to boot. While booting in safe mode, it hung up on agp440.sys. I found this page:  http://www.virtualbox.org/wiki/Migrate_Windows and went in to the system files and renamed it agp440.sys.backup. Now it hangs on Mup.sys during boot. Just to experiment, I also renamed mup.sys to mup.sys.backup, but then it hung on NDIS.sys. Not sure what is causing this as it ran fine in VMPlayer and Vmware Server.

Change History

comment:1 Changed 6 years ago by russdot

I can confirm the same problem. I am using a partition install of windows XP fine in VMWare, and amd trying to get it working in VirtualBox. I disabled the agp440 service using the recovery console, and now the VM is hanging on Mup.sys, however I have not yet tried renaming Mup.sys to see the effect.

comment:2 Changed 6 years ago by omgparticle@…

I had a vmware fusion image file. I did the agp440 rename thing.

It was hanging on Mup so I

Increased the memory available, Underneath the general tab I checked that XP is the type of OS, and on the advanced tab I checked the Enable IO APIC. (I believe that is what made it start to work.)

comment:3 Changed 6 years ago by rossy65

I had the mup.sys hang as well. I did a disable mup in the recovery console, and it hung elsewhare pbadrv.sys. Don't really think its mup.sys... just a catch all place for things to hang in windows.

I tried increasing memory and also setting enable IO APIC... this didn't help, although I can't rule out having the incorrect hal (hardware abstraction layer).

Just wanted to report the mup.sys issue... perhaps we can do some Windows XP sniffing of a *.vdi to determine what the correct virtual machine parameters need to be to run it. Thats future stuff.

My image was from a Dell D620 laptop. Also required for this was a fix to boot.ini as there are two partitions on the original disk (DellUtilities[1] and Windows[2]).

If I get to the bottom of my mup.sys issue I will post it. Again setting IO APIC didn't fix the issue.

comment:4 Changed 6 years ago by frank

Additional hints: When you boot .vmdk images created by VMware you should select the PIIX4 in the VirtualBox settings (available since 1.5.6). Make sure that the APIC and IOAPIC settings of the VirtualBox settings match the VMware settings.

comment:5 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use