VirtualBox

Ticket #9865 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Qt WARNING: Object::connect: No such signal QNetworkReplyImpl::sslErrors(QList<QSslError>)

Reported by: Skinkie Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

Going for Preferences in the main gui results in:

Qt WARNING: Object::connect: No such signal QNetworkReplyImpl::sslErrors(QList<QSslError>)

and a Segmentation Fault.

(gdb) bt
#0  0x00007f308fe54b16 in QString::section(QRegExp const&, int, int, QFlags<QString::SectionFlag>) const () from /opt/VirtualBox/libQtCoreVBox.so.4
#1  0x00007f30916902d8 in UIExtensionPackageItem::UIExtensionPackageItem(QTreeWidget*, UISettingsCacheGlobalExtensionItem const&) ()
   from /opt/VirtualBox/VirtualBox.so
#2  0x00007f309168e7ef in UIGlobalSettingsExtension::getFromCache() ()
   from /opt/VirtualBox/VirtualBox.so
#3  0x00007f3091672fa0 in UISettingsSerializer::qt_metacall(QMetaObject::Call, int, void**) () from /opt/VirtualBox/VirtualBox.so
#4  0x00007f308ff0112b in QObject::event(QEvent*) ()
   from /opt/VirtualBox/libQtCoreVBox.so.4
#5  0x00007f308f4a1740 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /opt/VirtualBox/libQtGuiVBox.so.4
#6  0x00007f308f4a192e in QApplication::notify(QObject*, QEvent*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#7  0x00007f308fef0207 in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /opt/VirtualBox/libQtCoreVBox.so.4
#8  0x00007f308fef3cfc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /opt/VirtualBox/libQtCoreVBox.so.4
#9  0x00007f308ff18103 in ?? () from /opt/VirtualBox/libQtCoreVBox.so.4
#10 0x00007f308b7df7b2 in g_main_context_dispatch ()
   from /usr/lib64/libglib-2.0.so.0
#11 0x00007f308b7dff90 in g_main_context_iterate.clone.6 ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib64/libglib-2.0.so.0
#12 0x00007f308b7e0171 in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
#13 0x00007f308ff18900 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#14 0x00007f308f529c99 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtGuiVBox.so.4
#15 0x00007f308feef863 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#16 0x00007f308feefa12 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#17 0x00007f3091666cc8 in QIMainDialog::exec() ()
   from /opt/VirtualBox/VirtualBox.so
#18 0x00007f309166da45 in UISettingsDialog::execute() ()
   from /opt/VirtualBox/VirtualBox.so
#19 0x00007f3091776d98 in VBoxSelectorWnd::fileSettings() ()
   from /opt/VirtualBox/VirtualBox.so
#20 0x00007f3091852f3a in VBoxSelectorWnd::qt_metacall(QMetaObject::Call, int, void**) () from /opt/VirtualBox/VirtualBox.so
#21 0x00007f308ff0059f in QMetaObject::activate(QObject*, int, int, void**) ()
   from /opt/VirtualBox/libQtCoreVBox.so.4
#22 0x00007f308f49b717 in QAction::triggered(bool) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
---Type <return> to continue, or q <return> to quit---
#23 0x00007f308f49ba7a in QAction::activate(QAction::ActionEvent) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#24 0x00007f308f872afc in QMenuPrivate::activateAction(QAction*, QAction::ActionEvent, bool) () from /opt/VirtualBox/libQtGuiVBox.so.4
#25 0x00007f308f4eea17 in QWidget::event(QEvent*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#26 0x00007f308f8706eb in QMenu::event(QEvent*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#27 0x00007f308f4a1740 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /opt/VirtualBox/libQtGuiVBox.so.4
#28 0x00007f308f4a1e4f in QApplication::notify(QObject*, QEvent*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#29 0x00007f308fef0207 in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /opt/VirtualBox/libQtCoreVBox.so.4
#30 0x00007f308f4a3806 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#31 0x00007f308f506e1d in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#32 0x00007f308f50605d in QApplication::x11ProcessEvent(_XEvent*) ()
   from /opt/VirtualBox/libQtGuiVBox.so.4
#33 0x00007f308f52a2a2 in ?? () from /opt/VirtualBox/libQtGuiVBox.so.4
#34 0x00007f308b7df7b2 in g_main_context_dispatch ()

---Type <return> to continue, or q <return> to quit---
   from /usr/lib64/libglib-2.0.so.0
#35 0x00007f308b7dff90 in g_main_context_iterate.clone.6 ()
   from /usr/lib64/libglib-2.0.so.0
#36 0x00007f308b7e0171 in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
#37 0x00007f308ff18900 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#38 0x00007f308f529c99 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtGuiVBox.so.4
#39 0x00007f308feef863 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#40 0x00007f308feefa12 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/VirtualBox/libQtCoreVBox.so.4
#41 0x00007f308fef3e98 in QCoreApplication::exec() ()
   from /opt/VirtualBox/libQtCoreVBox.so.4
#42 0x00007f30915ded08 in TrustedMain () from /opt/VirtualBox/VirtualBox.so
#43 0x0000000000401fb0 in ?? ()
#44 0x00007f3092b8febd in __libc_start_main () from /lib64/libc.so.6
#45 0x000000000040121a in ?? ()
#46 0x00007fff4b44bfe8 in ?? ()
#47 0x000000000000001c in ?? ()
#48 0x0000000000000001 in ?? ()
#49 0x00007fff4b44cf12 in ?? ()

Change History

comment:1 Changed 2 years ago by frank

  • Description modified (diff)

comment:2 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9851, please download the fixed 4.1.6 package.

comment:3 Changed 2 years ago by Skinkie

  • Status changed from closed to reopened
  • Resolution duplicate deleted

This IS 4.1.6...

Or are you claiming there are multiple 4.1.6 packages?

comment:4 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

PLEASE could you read the ticket I was referring to?

comment:5 Changed 2 years ago by Skinkie

I did and I just did not expect that you refered to: replacing 4.1.6. I notice that the subminor version number changed. And that Gentoo Linux is not picking this up. Will open a bug there.

comment:6 Changed 2 years ago by Skinkie

I guess they already found out:  https://bugs.gentoo.org/show_bug.cgi?id=389773

"Oh dear... why can't they just increase the version number?"

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use