VirtualBox

Ticket #9851 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Segmentation fault when installing vbox-extpack 4.1.6-74713

Reported by: reureu Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I have just updated from VBox 4.1.4 to 4.1.6. I have tried to install the corresponding extension pack (File-->Preferences-->Extensions), but VBox crashes with a segmentation fault as soon as I double click on the corresponding file (aka Oracle_VM_VirtualBox_Extension_Pack-4.1.6-74713.vbox-extpack).

Host: Ubuntu 10.04 LTS (Lucid Lynx).

It is 100% reproducible on my machine.

Is anyone having the same problem?

Change History

comment:1 Changed 2 years ago by frank

Darn, I can reproduce this crash in an Ubuntu 10.10 VM. This is a Qt but, see  here.

comment:2 follow-up: ↓ 3 Changed 2 years ago by goldie

+1, after upgrade from 4.1.4 to 4.1.6, click "File -> Preferences" then VirtualBox crashes and disappears with "Segmentation Fault" error messages left in terminal.

Core dump file with 7-Zip 9.20 compressed:  http://www.mediafire.com/?5t02n4hq2341kyb

comment:3 in reply to: ↑ 2 Changed 2 years ago by goldie

Replying to goldie:

+1, after upgrade from 4.1.4 to 4.1.6, click "File -> Preferences" then VirtualBox crashes and disappears with "Segmentation Fault" error messages left in terminal.

Core dump file with 7-Zip 9.20 compressed:  http://www.mediafire.com/?5t02n4hq2341kyb

Relative discussion thread:  https://forums.virtualbox.org/viewtopic.php?f=7&t=45868

comment:4 Changed 2 years ago by frank

I already explained the reason in my comment. Right now I'm uploading new builds as all builds which contain Qt 4.6.2 or older are affected (half of the Linux builds and Solaris).

comment:5 Changed 2 years ago by goldie

OK, thanks you. Sorry that I haven't noticed it before.

comment:6 Changed 2 years ago by frank

Affected are the following builds: Solaris, Ubuntu Hardy and Lucid, Debian Lenny, Mandriva 2010, RHEL4/5/6, SLES10/11, Linux generic.

comment:7 Changed 2 years ago by frank

Affected users please download the new builds, see the download page. Users of the repositories (Debian, Ubuntu, RHEL, OL) just need to do apt-get update;apt-get upgrade or yum update.

comment:8 Changed 2 years ago by goldie

The problem solved after apt-get update/upgrade, thanks for your quick fix.

comment:9 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Segmentation fault when installing vbox-extpack 4.1.6-74713. to Segmentation fault when installing vbox-extpack 4.1.6-74713
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use