VirtualBox

Ticket #9866 (closed defect: fixed)

Opened 2 years ago

Last modified 19 months ago

when IO-ACPI is enabled, VM's will cause system-wide (host) freeze

Reported by: samopal Owned by:
Priority: blocker Component: VMM
Version: VirtualBox 4.1.6 Keywords: io-apic host freeze
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

My host is HP ProLiant ML370 G5 E5410 Intel Xeon 2.33GHz/12M 1333, 4 GB HP SA P400/256 RAID SAS, BBWC, DVD-RW 10/100/1000 lan 6x HP HDD 72GB, SAS-I 15K, 2.5' hot plug

I use binaries for SLES 10, 64bit -  http://download.virtualbox.org/virtualbox/4.1.6/VirtualBox-4.1-4.1.6_74727_sles10.1-1.x86_64.rpm

Host OS is SLES 10, SP1 and I want to install single guest OS, preferrably windows 7 64bit, for that, I need VT-x enabled, so: 1, I've upgraded BIOS to latest version (2011.05.02, 20 Jul 2011) and enabled "No-Execute Memory Protection" and "Intel® Virtualization Technology" options in BIOS. 2, I did cold restart (plugged out power cord before) 3, I've installed Virtualbox (specific build for SLES10, 64bit) 4, When I enable IO-ACPI option in VM's settings, whole machine will freeze shortly after start, sometimes 5seconds, sometimes 2minutes. It doesn't matter if VT-x is enabled or not, nor if I've assigned 1 or 3 CPU's to the VM, nor the amount of memory, nor if the VM is 32bit or 64bit. It seems like I've tried all the combination, but it all goes down to "IO-ACPI" feature. I enable it, machine freezes (not only gdm, the whole machine, I can't even switch to command line)

I want to use 64bit guest and be able to assign more than 1 cpu core to the VM and without IO-ACPI it's not possible, so I'm stuck here.

I've attached log from my last attempt to start installation of win7, 64b, but from what I see, freeze is random and there is nothing obvious in virtualbox log. I also browsed the linux system logs, but found nothing helpful. System just hangs and needs cold restart.

Attachments

VBox.log.1.txt Download (40.5 KB) - added by samopal 2 years ago.
VBox4.1.6.log Download (43.2 KB) - added by samopal 2 years ago.

Change History

Changed 2 years ago by samopal

comment:1 Changed 2 years ago by frank

The log is from VirtualBox 4.1.4, are you sure that you really installed VirtualBox 4.1.6?

comment:2 Changed 2 years ago by samopal

oh, yes, the log is made with 4.1.4 and the issue appears in 4.1.4, my mistake. Anyhow, I don't see any relevant fix between 4.1.4 and 4.1.6, but I can try to upgrade it and try again. I can post here the result, I expect the same outcome.

comment:3 Changed 2 years ago by Technologov

+1 follower.

-Technologov

Changed 2 years ago by samopal

comment:4 Changed 2 years ago by samopal

I've attached the log file from my another attempt to run quest with IO-APIC, this one is from upgraded VBox to 4.1.6, no change, host freezes. I've tried to acquire a VBox core dump, following the instructions on this site, but apparently none was created.

comment:5 Changed 2 years ago by samopal

alright, so it's definitely not hardware fault, I've reinstalled host OS on that machine few days ago, now I run virtualbox headless with the same settings and it works perfectly ok. Though I don't think this is a headless vs. non-headless issue, I've tried to run it headless on the old host OS too and it was freezing exactly the same way as it did when ran from gui.

comment:6 Changed 2 years ago by Technologov

It means, that you probably had some conflicting software. If you stumble across this problem again, please let us know which software (and drivers) you have installed in Host.

-Technologov

comment:7 Changed 2 years ago by steveatoracle

I am experiencing something similar with Oracle Linux 5.5 host and Windows 2008 64-bit and Windows 7 64-bit guests. I need to perform one further install without IO APIC to confirm. I will log it under a separate ticket.

comment:8 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use