VirtualBox

Ticket #9603 (closed defect: fixed)

Opened 3 years ago

Last modified 15 months ago

NULL pointer dereference in vboxdrv on the host when shutting a guest OS down

Reported by: spectre Owned by:
Priority: critical Component: VMM
Version: VirtualBox 4.1.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Host OS: OpenSUSE Linux 11.3 32-bit
Guest OS: the problem was observed with different guest Linux systems including Mandriva 2010 and Fedora 12
VirtualBox 4.1.2 installed from  the recommended repository

Sometimes when I shutdown the guest system, a NULL pointer dereference occurs in vboxdrv at rtR0MemObjLinuxFreePages+0x14/0x90 (see the relevant portion of the system log attached).

The guest system itself seems to be shut down correctly.

The problem does not reproduce each time I shutdown a guest OS. Among several dozens of VM shutdowns I did this week, I saw this problem only twice.

The host system has no hardware virtualization support, so nested paging is not used among other things. PAE is not enabled for the guest systems either. Therefore, it is probably not related to bug #7930 as I thought earlier.

May be it is nothing but there is a probably interesting thing in the system log. It looks like the problem occured before the network interface finished cleaning up. Before the oops report, there is a message:

[75613.447367] device vboxnet0 entered promiscuous mode

and after the report - the following message:

[85715.717558] device vboxnet0 left promiscuous mode

Attached is the portion of the system log, the VM log (F12_VBox.log) and the VM configuration (F12.xml).

Attachments

F12_VBox.log Download (78.7 KB) - added by spectre 3 years ago.
VirtualBox log file
F12.xml Download (13.3 KB) - added by spectre 3 years ago.
Machine configuration file
system.log Download (6.2 KB) - added by spectre 3 years ago.
The log for the host system

Change History

Changed 3 years ago by spectre

VirtualBox log file

Changed 3 years ago by spectre

Machine configuration file

Changed 3 years ago by spectre

The log for the host system

comment:1 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use