VirtualBox

Ticket #7930 (closed defect: fixed)

Opened 3 years ago

Last modified 22 months ago

Host crashes with VB 4.0.0 (PAE guests with nested paging only)

Reported by: AndyMutz Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

VB 3.2.12 runs with no problems. after upgrading to VB 4.0.0 my host (vista x86) crashes, always with the same BSOD (0x000000D1, VMMR0.r0), when trying to load 7 or vista VMs. so far no problems with XP VMs. after downgrading to VB 3.2.12 again, no more host crashes. unfortunately the vbox.log file was 0 bytes after a host crash. minidump is attached.

Attachments

Mini122710-03.7z Download (20.4 KB) - added by AndyMutz 3 years ago.
minidump of last host BSOD
Mini010911-02.zip Download (15.5 KB) - added by marcox 3 years ago.
minidump of one of the BSODs
Mini012911-01.7z Download (20.8 KB) - added by AndyMutz 3 years ago.
020711-38360-01.dmp Download (268.3 KB) - added by hechacker1 3 years ago.
Win 7 x64 minidump
Maverick-2011-02-07-14-59-29.log Download (58.7 KB) - added by hechacker1 3 years ago.
minidump-windbg.txt Download (24.6 KB) - added by hechacker1 3 years ago.
HP_Pavilion_dv6-2170us.txt Download (2.5 KB) - added by changedsoul 3 years ago.
Harware info to help resolve this problem
kernel.txt Download (4.4 KB) - added by changedsoul 3 years ago.
Message generated when VirtualBox Locked Up
VBox.log.1 Download (48.2 KB) - added by changedsoul 3 years ago.
VirtualBox Log when error occured

Change History

Changed 3 years ago by AndyMutz

minidump of last host BSOD

comment:1 Changed 3 years ago by Technologov

Can you provide some more info ?

Which CPU + 3D accelerator you have ? Did you enable 3D acceleration for your VMs ? Which network cards you have on your host ? (some are known to be incompatible with VirtualBox)

-Technologov

comment:2 Changed 3 years ago by cryptr

The same happens with my linux hosts, two machines running debian squeeze kernel panics with the new 4.0 vboxdrv and completely freezes.

Downgrading to 3.2 and it works again.

Running VBoxHeadless there.

comment:3 Changed 3 years ago by Technologov

Oracle: Please up bug priority to "BLOCKER"

cryptr: Which Linux kernels on hosts ? Please do "uname -a"

-Technologov

comment:4 Changed 3 years ago by AndyMutz

CPU is an intel i7-870, gfx card is a radeon hd5870, 3d acceleration is always enabled for all VMs that support it, network is an onboard realtek RTL8168D/8111D, using bridged adapter in all VMs.

comment:5 Changed 3 years ago by cryptr

Linux box1 2.6.32-5-amd64 #1 SMP Fri Dec 10 15:35:08 UTC 2010 x86_64 GNU/Linux Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz

Linux box2 2.6.32-5-686-bigmem #1 SMP Fri Dec 10 16:59:53 UTC 2010 i686 GNU/Linux Pentium(R) Dual-Core CPU E5300 @ 2.60GHz

Both running Debian Squeeze

comment:6 Changed 3 years ago by mattb

Possibly related to #7998?

comment:7 Changed 3 years ago by fastdruid

Same happens with my Ubuntu 10.10 linux host, 3.2 works perfectly, 4.0 crashes the host, tried with (previously) working Windows XP and Linux guests and both crash it.

# uname -a Linux <nodename> 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

comment:8 Changed 3 years ago by frank

fastdruid, this is a different problem as this ticket is for Windows host crashes. You problem might be covered by #7908.

comment:9 in reply to: ↑ description Changed 3 years ago by mattb

Hi Andy, After analyzing my dumps & your's, I'm convinced my bugreport #7998 is the same thing you are seeing. Were you able to downgrade to 3.2.12 and still use the vbox you created with 4.0? I think this is my next option. thanks!

comment:10 Changed 3 years ago by AndyMutz

i didn't create any new VMs with 4.0.0 but after a downgrade to 3.2.12, the ones i tried to use with 4.0.0, still worked fine.

Changed 3 years ago by marcox

minidump of one of the BSODs

comment:11 Changed 3 years ago by marcox

I think my problem could relate to this ticket, so I have not opened a new one. Asus P7P55D-E PRO, i7 860, 4GB ram, GeForce 9800 GT, EWX24/96 audio. XP x64 host, many different Win/Linux guests. I upgraded to VBox 4 a week ago, with no apparent problems since. This morning, while attempting to start a SECOND guest (which was in saved state), I got a BSOD, the first in a very long time.

I tried again, with other VMs, getting several other BSODs (0x..D1, DRIVER_IRQL_NOT_LESS_OR_EQUAL, pointing to the audio card driver), always at about 3/4 of the startup of a VM, no matter if in saved state or not. I tried both with "old" VMs (used for a long time with no problems) and ones created with VBox 4. All VMs are configured with Win DirectSound and AC97.

For the first 5 or 6 BSODs, the already opened VMs lost their saved states but could later be normally started. Then I got also a corruption of a vdi file. No error messages whatsoever apart from the BSODs, which leave no trace in Windows' event viewer or log files.

Nothing has recently been changed from the host system. No BSODs with my previous version of VBox (324).

While testing I noticed (maybe it has no meaning) the amount of used RAM reported from Task Manager did not correspond to the sum of the RAM assigned to the various VMs running. For example, I was able to start a Win7 guest with 1280MB of assigned RAM despite only 600MB of RAM being available to the host system.

I'm attaching one of the minidumps, hoping it helps.

comment:12 Changed 3 years ago by marcox

I saw that 4.0.2's changelog does not mention this ticket at all, so I presume these crashes have not been fixed yet. Next time?

Changed 3 years ago by AndyMutz

comment:13 Changed 3 years ago by AndyMutz

just testet VB 4.0.2 and the bug remains. my host just BSOD'ed when trying to start my win7 VM. new minidump attached, vbox.log size is again 0 bytes.

comment:14 Changed 3 years ago by frank

Thanks for the additional minidumps. Could you attach a VBox.log file of such a VM session as well?

Changed 3 years ago by hechacker1

Win 7 x64 minidump

comment:15 Changed 3 years ago by hechacker1

I've added my own minidump and logs from this same crash. VMMR0 Bsod.

I can reproduce this every time:

Start Ubuntu 64Bit 4GB guest on Win 7 x64.

On Grub boot menu, start up Memtest.

Before memtest gets to load, it crashes my host machine.

Bluescreenviewer shows: VMMR0.r0 VMMR0.r0+e7cd fffff8800def8000 fffff8800df89100 0x00091100 0x4d35ba56 1/18/2011 8:05:42 AM

I am download the Windows debugging tools and symbols now to see if I can get more info.

Attached is a minidump, and a Vbox log from when it didn't crash. When it crashes I get a 0 byte log.

Changed 3 years ago by hechacker1

Changed 3 years ago by hechacker1

comment:16 Changed 3 years ago by hechacker1

My problem has been resolved.

It turns out there's a weird compatibility issue between a program called prio:

 http://www.prnwatch.com/prio.html

And Virtualbox.

Prio was also causing HostMemoryLow errors for me (as described in a forum post).

With prio uninstalled, I can successfully run a memtest in a Ubuntu guest.

Still though, I do wish there was a Virtualbox approved way of setting a priority. Another ticket mentions we should use external tools.... Well look how that went.

comment:17 Changed 3 years ago by Technologov

A possible solution for your problem is described in Wish #6057

-Technologov

comment:18 Changed 3 years ago by michaln

The BSODs can be likely avoided by turning off nested paging.

The issue is probably specific to certain Intel Core i5/i7 models, possibly in combination with certain chipsets, but so far we don't know which and we don't have one of the failing systems. It would be great if users could provide more information on which CPUs are failing and which similar CPUs are not, so that we know what to look for.

comment:19 Changed 3 years ago by hechacker1

I'm willing to post my info here if it helps. But I'm guessing my issue was due to Prio. Perhaps the chipset is also related.

Core i7 920 Revision D0. EX58-UD4P (X58) ICH10R

comment:20 Changed 3 years ago by Juan Martinez

Same BSOD on host here.

HP EliteBook 8440p 4 GB RAM
CPU Intel(R) Core(TM) i5 CPU M 520 @ 2.40GHz
NIC 1 Intel(R) Centrino(R) Advanced-N 6200 AGN
NIC 2 Intel(R) 82577LM Gigabit Network Connection
Graphics NVIDIA NVS 3100M
VBOX 4.0.4
Host Win XP Professional 32bits SP3
Guest Win 7 Enterprise 32bits SP1 (1 CPU, 1 GB RAM, VT-x enabled, Nested Paging enabled, 3D acceleration enabled, 2 NIC attached (bridged) to physical ones)

I have no minidumps nor vbox.log files at hand right now but can manage to provide some to you if needed.

Also, if it can help you, note that I have two virtual machines (Windows 2008 and 2008 R2) running fine on that host.

comment:21 Changed 3 years ago by michaln

It looks like the problem only shows up with the combination of EPT (Intel nested paging) and guests with relatively large amounts of RAM assigned (certainly more than 512MB), possibly also with guest PAE enabled. Turning off nested paging will make the guests run a little slower but likely without crashes.

comment:22 Changed 3 years ago by AndyMutz

i got new hardware and while VB 3.2.12 ran without any problems, VB 4.0.4 still BSOD's my host.
Mobo: ASRock P67 Extreme4
CPU: Intel i5-2500K
RAM: 8 GB DDR3-1333
NIC: Realtek RTL8168/8111
GPU: AMD Radeon HD 5870
host is still vista sp2 x86
turning nested paging off seems to help indeed, but the VM feels considerably slower then.

comment:23 Changed 3 years ago by Juan Martinez

I confirm that this seems related to nested paging, turning it off seems to have solved the issue on my case.

comment:24 Changed 3 years ago by mng

I am not sure if it is related but same issue here with VirtualBox 4.0.4, Debian Squeeze guest & host on a SUN X2200 M2 (2x Opteron Dualcore, 8GB), using VBoxHeadless, 512MB Squeeze guest, host OS sporadically freezes and needs hardware reset. I tried different guest configurations but until now nothing seems to help... Any idea?

comment:25 Changed 3 years ago by pablo

I've confirmed disabling paging works around bug #7893

comment:26 Changed 3 years ago by frank

  • Summary changed from Host crashes with VB 4.0.0 to Host crashes with VB 4.0.0 (PAE guests with nested paging only)

Changed 3 years ago by changedsoul

Harware info to help resolve this problem

comment:27 Changed 3 years ago by changedsoul

Hi, I just added a file with my specs to possibly help resolve this issue. I am also having this problem and I have a core i5 laptop.

Changed 3 years ago by changedsoul

Message generated when VirtualBox Locked Up

Changed 3 years ago by changedsoul

VirtualBox Log when error occured

comment:28 follow-up: ↓ 29 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be finally fixed with VBox 4.1.4. Please reopen if still relevant.

comment:29 in reply to: ↑ 28 Changed 2 years ago by DenisBY

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to frank:

Should be finally fixed with VBox 4.1.4. Please reopen if still relevant.

I started to have BSOD exactly from version 4.1.4. Never had it before. My CPU is old Core2Duo 6300, Win7 X64 as host and Ubuntu 11.10 x64 as guest.

comment:30 Changed 2 years ago by frank

DenisBY, a VBox.log file from such a VM session is missing. Also, which was the VBox release you tested before which was working?

comment:31 Changed 2 years ago by changedsoul

I would like to add that any issues I had with PAE, Nested paging, and multiple CPU's, have disappeared when I switched from 32bit to 64bit openSuse Host.

comment:32 Changed 22 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

changedsoul, actually the fix for you problem is part of VBox 4.1.18. I will close this ticket as there is no response from DenisBY.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use