VirtualBox

Ticket #42 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Problem with all Audio Adpaters

Reported by: gilir Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.4 Keywords: audio adpater
Cc: Guest type: other
Host type: other

Description

System : Ubuntu 6.10
The 3 audio adapters have problems

  • Null Audio Driver doesn't have any sound in the guest
  • ALSA Audio Driver crash the host (reboot all the system !) when try to launch any guest
  • OSS Audio Driver : can't have sound in the guest and in the host (probably normal). But, when I have sound in the guest, any audio program (totem, amarok, vlc ...) launching after the guest in the host become completly crazy (no sound, playing video 2x faster ...).

Attachments

log.txt Download (8.8 KB) - added by gilir 7 years ago.
log file
VBox.log Download (25.1 KB) - added by gilir 7 years ago.
a complete logfile

Change History

comment:1 Changed 7 years ago by achimha

The ALSA problem is caused by kernels older than 2.6.18. We are currently looking into it. If you update your kernel, it should work.

comment:2 Changed 7 years ago by frank

The Null audio driver is expected to generate any sound output. The ALSA problem was fixed in svn and the next release will contain the fix as well. Regarding OSS: Are there any messages regarding OSS in the logfile?

Changed 7 years ago by gilir

log file

comment:3 Changed 7 years ago by gilir

Thanks for this informations. I attach a piece of logfile for the OSS. Starting 2 times Amarok in the host during the log.

comment:4 Changed 7 years ago by frank

Thanks for the logfile. However, please would you post the whole file since there is an interesting piece missing.

comment:5 Changed 7 years ago by gilir

I post a other logfile more complete.

Changed 7 years ago by gilir

a complete logfile

comment:6 Changed 7 years ago by frank

I don't see any problematic log entries in your logfile. I get more and more the feeling that your OSS problems are not a bug of VBox. OSS does not mix audio streams, that is only one application can access the sound device /dev/dsp at one time. If VBox occupied the device then other applications trying the same might behave strange but that is nothing we can influence.

Just try the ALSA backend with a guest kernel >= 2.6.18 or wait for the next VBox release which is expected very soon.

comment:7 Changed 7 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed

ALSA crash is fixed in 1.3.6

comment:8 Changed 7 years ago by vbgunz

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have 1.3.6, running on Kubuntu 6.10 (Kernel 2.6.17-10-generic) and believe I see this bug. If I enable ALSA and startup an XP guest, all is fine *but* none of my media applications will start up. Amarok, Kaffeine both act like they're going to startup but they never do. The only way I've noticed I can run a guest and these media applications at the same is if I disable the sound in the guest settings.

comment:9 Changed 7 years ago by vbgunz

this appears fixed for me with the latest version 1.3.8 released 2007-03-14, awesome!

comment:10 Changed 7 years ago by vbgunz

Sorry, I reported on this too soon. the graphics resolution in ticket 95 is definitely fixed but using ALSA for audio and booting up a VM still results in my multimedia applications either crashing or never starting up :(

Sorry...

Ubuntu 6.10 vbox 1.3.8

comment:11 Changed 7 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

We believe that these problems are fixed now. Please reopen if you still encounter problems with the next release.

comment:12 Changed 7 years ago by vbgunz

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am sorry but this is not fixed for me. From Kubuntu Edgy 6.10 to Kubuntu Feisty 7.04, enabling either OSS or ALSA in VirtualBox 1.3.8 and respective debs, results in several applications to crash or not work at all.

If I have OSS or ALSA enabled, Amarok and Kaffeine will not launch at all. If I visit a webpage with Firefox that has Flash embedded into it, Firefox will freeze until killed. OSS and ALSA work and sound will play in the guest but at the expense of instability of multimedia applications on the host.

Sorry I couldn't get to this earlier.

comment:13 Changed 7 years ago by frank

With next release I meant 1.4.0. It should be fixed there.

comment:14 Changed 7 years ago by frank

Any experiences with 1.4.0?

comment:15 Changed 7 years ago by vbgunz

the problems with vbox since 1.3.6 regarding audio seemed to have disappeared with 1.4.0. I can run an XP guest with ALSA enabled on a Kubuntu 7.04 host and everything seems to run just fine. Firefox no longer freezes up with flash embedded and Amarok and Kaffeine startup and work with no problem. Thank you very much for your time on fixing this!

comment:16 Changed 7 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Glad to hear this :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use