VirtualBox

Ticket #7893 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Fail to boot VM with 2048 MB of memory allocated

Reported by: pablo Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords: Windows 2003
Cc: Guest type: Windows
Host type: Linux

Description

Hi,

I have 12 GB of RAM on my Host O/S. For some of my VM's, I give them 2 GiB of RAM. I noticed that with 4.0.0, these VM's fail to boot unless I decrease their memory to 1 GiB. I haven't attempted to find the right amount of RAM where the VM will boot but will do so if it's necessary.

I'm attaching to .log files: one where the VM fails to boot (2 GiB) and one where it succeeds (1 GiB)

I also observe when the VM fails to boot, the `Oracle VM VirtualBox Manager' fails to repaint. Other concurrently running VM's (with less RAM) continue to run.

Please let me know if there's additional data to collect.

Cheers, -pablo

Attachments

VBox-1024MB-of-RAM.log Download (78.6 KB) - added by pablo 3 years ago.
Successful boot
VBox-2048MB-of-RAM.log Download (52.1 KB) - added by pablo 3 years ago.
Hang
cpu_pegged.vbox.strace.bz2 Download (36.8 KB) - added by pablo 3 years ago.
strace with 4.0.3 tests - CPU pegged on System (not User)
VBox.log Download (46.3 KB) - added by pablo 3 years ago.
VBox.log with 4.0.3 tests - CPU pegged on System (not User)

Change History

Changed 3 years ago by pablo

Successful boot

Changed 3 years ago by pablo

Hang

comment:1 Changed 3 years ago by frank

So fails to boot means the VM crashes? In that case you should be able to create a  core dump. If so, please contact me at frank _dot_ mehnert _at_ oracle _dot_ com and I will tell you a server where you can upload the core dump.

comment:2 Changed 3 years ago by pablo

Hi Frank,

I'm sorry I wasn't clear. No, the VM doesn't crash, it hangs at the point listed above.

Can I send a signal to the process to core it? Not sure if that'd be useful.

Please advise.

comment:3 Changed 3 years ago by frank

Yes, please send a signal as described at the web page.

comment:4 Changed 3 years ago by pablo

Core'd and I've sent you an e-mail for the server credentials.

Thank you! -pablo

comment:5 Changed 3 years ago by pablo

FYI: Same issue with 4.0.2

comment:6 Changed 3 years ago by frank

We found something. Could you check if  this test build fixes your issue (boot with 2048MB)?

comment:7 Changed 3 years ago by pablo

Will do! Thank you.

Cheers, -pablo

Changed 3 years ago by pablo

strace with 4.0.3 tests - CPU pegged on System (not User)

Changed 3 years ago by pablo

VBox.log with 4.0.3 tests - CPU pegged on System (not User)

comment:8 Changed 3 years ago by pablo

Howdy, unfortunately the latest build didn't address the issue. When I set the VM's memory to 2048, the VM pegged one of my CPU's. I've attached both strace' and VBox.log' Please let me know if you'd like me to collect additional data and/or try something different.

Cheers, -pablo

comment:9 Changed 3 years ago by pablo

I forgot to mention with the latest build, when I revert the memory to, say 1024, the VM can boot.

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually this is a duplicate of #7930. Disabling nested paging would work around this bug. Or use a non-PAE guest.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use