VirtualBox

Ticket #96 (closed defect: wontfix)

Opened 7 years ago

Last modified 7 years ago

Centos 4.4 guest makes host CPU goes 100 even the guest is idle

Reported by: gbuonfiglio Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.6 Keywords: centos performance
Cc: Guest type: other
Host type: other

Description

Running a Centos 4.4 guest under VirtualBox 1.3.6 makes the host CPU goes 100% even after boot.

I also have Windows XP and Ubuntu 7.04 guests and they both worked well with host CPU dropping just after the boot.

When running Centos 4.4 guests, "top" on host shows 100% busy and "top" on guest shows 99% idle.

My host is a Ubuntu 6.10, default Ubuntu kernel, and it has a dual-core CPU.

I already tried other Centos kernels, disable ACPI, and reinstalling Guest Addictions but with the same results.

The last test was install the Fedora3 kernel (2.6.9-1.667) that is only a bit older but at least install without dependency problems and IT DID GREAT! Host and Guest CPU were minimal after boot just like the other OS's I tested.

So it look like a Centos kernel specific problem when running under VirtualBox.

The kernels I tested:

  • Centos 4.4 kernel-2.6.9-42.0.8.EL (100% host cpu usage after boot)


  • Centos 4.4 kernel-2.6.9-42.0.8.plus.c4 (100% host cpu usage after boot)


  • Fedora FC3 kernel-2.6.9-1.667 (0% host cpu usage after boot - good)

Thanks! Guilherme

Change History

comment:1 Changed 7 years ago by gbuonfiglio

I've just compiled kernel 2.6.20.1 based on Centos 4.4 default config and the problem is gone. I followed these steps:

  • copied the 2.4.6.42.0.8.EL kernel config for the 2.6.20.1 kernel sources directory


  • make silentconfig and accepted all the defaults


  • make && make modules_install && make install


  • rebooted into new kernel and installed VBoxLinuxAdditions


  • rebooted again and the problem is gone.


Ok, I will not take conclusions but I think this deserves some work with the CentOS team and maybe VirtualBox has nothing to do with this problem.

comment:2 Changed 7 years ago by gbuonfiglio

I've just tested CentOS 4.4 under VMWare Player and it does not have this weird behaviour, at least when idle. I've seen many reports of CentOS performance problems under vmware but I cannot say if I google for SLES performance problems under vmware I will get different results. ;-)

Anyway, it's really something CentOS x VirtualBox problem. And I think it's causing other kinds of problems, for example, IBM JVM does not work at all in a CentOS guest. Openning a new ticket for that...

comment:3 follow-up: ↓ 4 Changed 7 years ago by markba

comment:4 in reply to: ↑ 3 Changed 7 years ago by markba

I can confirm this, though not with Centos but with Ubuntu. This always happens (9 out of 10) when I hibernate the session and then trying to resume: processor is going to 100%, nothing is responding. A hard reboot solves the problem.

In my case, this only happens with Linux guests, be it Ubuntu Edgy, Feisty, server or desktop. Windows XP as a guest pauses and resumes as expected. Linux guests seems to be the problem.

Running Ubuntu Edgy as host.

comment:5 Changed 7 years ago by michael

Are any of you (who are still experiencing this problem) using a dual core CPU? If so, this may be related to timing problems which VirtualBox has with these processors (including at least one related to suspending and resuming). The next version will contain number of fixes in this area.

comment:6 Changed 7 years ago by markba

I'am using a single core (Intel P4 on a Dell and AMD 2800+).

comment:7 Changed 7 years ago by quayd

I have a MacBook running OS X 10.4.9. I downloaded the most recent OS X version of VirtualBox 1.3.99-Beta-1 reported by the GUI. My guest OS's I have tried are DSL, Dynebolic, and Ubuntu all from their iso image LiveCD's. Selected in the CDROM setting for each virtual machine, I refer to the respective iso image on my harddrive.

Each virtual machine runs with variances in idle CPU usage, but all of them are much higher than one would expect. DSL is at 28%, Dynebolic is 98%, and Ubuntu is 48%. If I disable audio and network for each of the virtual machines, the idle CPU usage drops by just over 20%. I ran Dynebolic and DSL with the options noapic specified at boot without effect. I also tried disabling both APIC and ACPI for the virtual machines without effect.

comment:8 Changed 7 years ago by mark901

I have a 3.0G Intel P4 hyperthreading enabled, host Windows XP. Guest Fedora 6 (2.6.20-1.2944) causes 100% cpu usage on host when idle. Guest Fedora 7 test-4 cpu usage on host is nearly 0%.

After disabling hyperthreading in host bios, there were no changes.

comment:9 Changed 7 years ago by ripi

The same problem appears when running Centos 5 (including RHEL 5, Fedora 6 kernels) guest under VirtualBox 1.4.0 (windows xp pro).

I think its still the noted problem - VirtualBox with the "dual core CPU". I experience the CPU problem even before to start the kernel (in the grub menu).

Compiling newer kernels (tested with 2.6.21) can surround the problem - after loading the kernel the load goes down to Zero.

comment:10 Changed 7 years ago by ripi

Playing around, preparing kernels for RHEL5 VMWARE ESX, I suddenly got to this link:  http://www.vmware.com/community/thread.jspa?messageID=699089

the kernels on  http://vmware.xaox.net/centos/ looks similar to these we have at work ;) and guess what - they make your centos 5 virtualbox guest work Credits to XAOX for this repository.

Kind Regards, Ivan Kolemanov

comment:11 Changed 7 years ago by ripi

just to finish the topic, and go to sleep ;)

if you are running development/test machine or non critical server your best bet is kernel 2.6.22 with:
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y

comment:12 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix

The usual problem with kernels compiled with 1000 hz timers. Solution mentioned above. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use