VirtualBox

Ticket #97 (closed enhancement: duplicate)

Opened 7 years ago

Last modified 4 years ago

Network Setup

Reported by: FixAte Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.3.6 Keywords: network setup
Cc: Guest type: other
Host type: other

Description

When it comes to virtualising, VirtualBox is the smallest, fastest, best performing software available I have encountered. There is just one problem, the network setup needs work. Whenever I run a virtual machine, I need to access the guest and/or other virtual machines and/or other computers on the local network or internet. I also need to access the virtual machine from the guest or other computers on the network. This can be done by just updating the IP settings on the virtual machine using static IP settings or dynamic (DHCP). My suggestion is to enable one using the VirtualBox interface, to select the guest network card (like Microsoft Virtual PC/Server). You then boot up the virtual machine and set the IP settings static or dynamic. This is the basic setup that I always use and I am sure others also. Currently this is not possible through the interface, and without network connectivity, this excellent software product is useless, because one needs network connectivity 99% of the time when testing. Currently I cannot use it, but I would like to. Thanks.

Change History

comment:1 Changed 7 years ago by achimha

  • Status changed from new to closed
  • Resolution set to invalid

This is all possible using Host Interface Networking. Please study the manual.

comment:2 Changed 7 years ago by FixAte

  • Status changed from closed to reopened
  • Resolution invalid deleted

I did go through the manual. The Internal Networking option looks like the option that will work for me, but couldn't get it to work. How about adding some examples in the manual? This will be a problem for lots of people that only has limited knowledge about routing and switching, like developers and other non-network specialists. Would be great if this can be done through the GUI. What's confusing is that there is no option in the network section of the GUI for Internal Networking, so which option do I pick? With good examples in the manual, even the VBoxManage modifyvm option will work for now. Host Interface is not an option, because I cannot use static IP. This ticket is similar to ticket #18.

comment:3 Changed 7 years ago by FixAte

The Host Interface option seems to work with TCP/IP routing on my work pc. Attempted this and bridging yesterday on my home pc, but couldn't get it going. Will try again when I get home, maybe I missed something.

comment:4 Changed 7 years ago by Technologov

Host interface *is* an option, and allows you to use static IPs.

I have built (emulated) virtual large-scale networks, running dozens virtual Routers and virtual PCs, virtual switches and emulating hundreds of NICs.

Your bug really needs to be closed as duplicate to bug #18. Please add your comments there.

I would like, however, to raise priority for bug #18. (to critical)

-Alexey Eremenko, CCNA (Cisco Certified Network Associate)

comment:5 Changed 7 years ago by klaus

  • Status changed from reopened to closed
  • Resolution set to duplicate

Remaining issues are a duplicate of bug #18, as already mentioned.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use