VirtualBox

Ticket #948 (closed defect: duplicate)

Opened 6 years ago

Last modified 3 years ago

Blue screen when accessing Aladdin HASP USB dongle

Reported by: BrunoAbe Owned by:
Priority: major Component: USB
Version: VirtualBox 1.6.2 Keywords: Alladin Hasp USB Dongle
Cc: Guest type: Windows
Host type: other

Description

Windev usus a Aladdin Hasp Dongle. When opening Windev the first time, everything is fine. But then, after working a bit, or when closing Windev and reopening, I get a blue screen(win 2000). I suspect that the 2nd time the USB dongle gets queried, VB crashes.

Note: VMWare does work with this dongle When sharing the USB dongle over the network(with "USB Over Network"), so NOT using the VB USB controller, VB behaves normal.

Attachments

VB Blue screen.gif Download (13.2 KB) - added by BrunoAbe 6 years ago.
VirtualBox-HASP-Blue-Screen.png Download (25.9 KB) - added by jonnieboy 6 years ago.
VirtualBox XP guest blue screen after installing HASP driver.

Change History

Changed 6 years ago by BrunoAbe

comment:1 Changed 6 years ago by sandervl73

  • Cc bruno_abe@… removed

comment:2 Changed 6 years ago by sandervl73

Could you try again with 1.5.4?

comment:3 Changed 6 years ago by BrunoAbe

Sorry, but 1.5.4 still has the same issue, consistently reproducable.

If you need more information to troubleshoot further, just let me know what you need from me.

I also noticed that when EHCI controller is enabled, the USB key is not even recognized (unknown device) ...

comment:4 Changed 6 years ago by ruben03mx

I have the same problem, I also tried 1.5.4 and got the same error. Also, ff any more information is needed, let me know.

comment:5 Changed 6 years ago by frank

  • Component changed from other to USB

comment:6 Changed 6 years ago by jonnieboy

I'm seeing something similar using XP guest, HASP dongle and VirtualBox 1.6.2 under Ubuntu 8.04. When I install the HASP run time ( http://www.aladdin.com/support/hasp/enduser.aspx) my XP VM crashes and restarts - I briefly see a Windows blue screen before it reboots. This is all without plugging the USB dongle while the VM is running. I have however plugged the dongle in to set up a filter then unplugged it before starting the VM.

If I revert to an earlier snapshot and just plug in the dongle it is recognised and Windows goes through the normal driver install procedure - when I told it to go off and search online for drivers sometime later I returned to find the VM had restarted and XP moaned that something bad had happened when it finally booted. Sorry, I don't have more details on this.

Related to  http://www.virtualbox.org/ticket/869 ?

Let me know if you would like logs and how to go about getting them.

comment:7 Changed 6 years ago by jonnieboy

Further information. I rolled back to a snapshot before all of these shenanigans and installed some s/w that includes a driver for the HASP dongle. It installed OK then when I rebooted XP VM I got a blue screen - png attached.

aksfridge.sys is from Aladdin Knowledge Systems Ltd - the HASP crowd.

VM then continually cycled, chucking this blue screen during boot - it got as far as starting to sort out network connections but not as far as login dialog.

Changed 6 years ago by jonnieboy

VirtualBox XP guest blue screen after installing HASP driver.

comment:8 Changed 6 years ago by iceman

Same as #2141. Problem is related to the instruction decoder of VirtualBox. It does not handle obfuscated code (in kernel mode driver) correctly.

comment:9 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.5.2 to VirtualBox 1.6.2
  • Guest type changed from other to Windows

I don't believe that. We have seen several blue screens of Windows because a virtual device does not behave like a real device. If you are right then the chances that your device will not make Windows BSOD are good with VirtualBox 2.0.2.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

#2141 is more recent, so I'll close this one as a duplicate.

comment:11 Changed 5 years ago by crixtiano

  • Status changed from closed to reopened
  • Resolution duplicate deleted

this error is not fixed

I have a software inside windows using a HASP Aladin and an sometimes I get a typical blue screen message error.

My configuration:

Host : Ubuntu Gutsy Guest: Windows XP VBox Version: 2.0.6

comment:12 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

crixtiano, can you actually read the last comment of this defect? Do not open defects which were closed as duplicates!

comment:13 Changed 3 years ago by Falcon_Sapsan

  • Status changed from closed to reopened
  • Resolution duplicate deleted

In version 3.2.12 the problem remained. At installation of driver HASP HL 3.25 - blue screen

comment:14 Changed 3 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate

Look up the word 'duplicate' before pressing any buttons next time.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use