VirtualBox

Ticket #9412 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Deterministic out of memory errors during boot while having a lot of free memory in host

Reported by: scam Owned by:
Priority: major Component: other
Version: VirtualBox 4.1.0 Keywords: guest memory
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

I have Win7 x64 host OS and WinXp 32bit guests with 1Gb memory allocated. Whenever I try to increase the amount of guest memory, the VM crashes during boot with out of memory error. Additionally, whenever I tried to run more than 1 guests at a time, I got the same error on all VMs booting up. To to start another VM, I have to close the single VM actually running and start another one, then everything works just fine. Tried continuously with recent releases, bug is present since at least 4.0. I have a Toshiba A500 with an Intel i5430M and 6GB RAM. May be related to similar tickets #7780 and #8409.

Attachments

VBox.log Download (186.5 KB) - added by scam 3 years ago.
The log for my latest boot crash. I haven't attached a screenshot since it is blank during the boot.
ubuntu.log Download (82.6 KB) - added by scam 3 years ago.
host log for ubuntu guest with out-of-memory right after login
winxp.log Download (75.4 KB) - added by scam 3 years ago.
windows xp guest with out of memory error that seems to be the same as before

Change History

Changed 3 years ago by scam

The log for my latest boot crash. I haven't attached a screenshot since it is blank during the boot.

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9373.

comment:2 Changed 3 years ago by scam

  • Status changed from closed to reopened
  • Resolution duplicate deleted

With recent release 4.1.4, the out of memory error still exists, but may occur later in the booting process, it's quite hard to tell. The original error may be fixed, but there's still issues causing the same effect. See log files for two different VMs attached right after posting this entry.

Changed 3 years ago by scam

host log for ubuntu guest with out-of-memory right after login

Changed 3 years ago by scam

windows xp guest with out of memory error that seems to be the same as before

comment:3 Changed 2 years ago by scam

Is there any chance that this bug will be fixed? I am willing to provide any information to track it down, if a developer cares.

comment:4 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #10219, please continue the discussion there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use