VirtualBox

Ticket #9411 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

"Snipping Tool" use causes repeatable crash on VBoxDisp.dll

Reported by: akulbe Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.1.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Any time you use the "Snipping Tool" to highlight a part of the screen, Windows (in my cause, 7x64 Pro) will blue screen with a fault on VBoxDisp.dll

Attachments

VBox.log Download (65.3 KB) - added by akulbe 3 years ago.
VBox log file for crashed session

Change History

comment:1 Changed 3 years ago by akulbe

I tried to change some info on the ticket, but I don't see how I can do that after the fact.

I'm running VBox 4.1.0 on an Ubuntu Server 11.04 64-bit. My guest is Windows 7 x64 Professional.

comment:2 Changed 3 years ago by frank

Please attach a VBox.log file of such a VM session. The log file will also show the configuration of your VM.

Changed 3 years ago by akulbe

VBox log file for crashed session

comment:3 Changed 3 years ago by Thest

I encountered the same problem under VirtualBox 4.1.2 with the Guest Additions installed - Windows 7 x64 host with Windows 7 x64 guest. When the Snipping Tool is used to capture an area it crashes/freezes VirtualBox. I then uninstalled the Guest Additions and the Snipping Tool worked correctly. I tested the behavior on another Windows 7 x64 guest by installing and uninstalling the Guest Additions and it was repeatable. As a solution I rolled back VirtualBox and the Guest Additions to 4.0.8 and the Snipping Tool works correctly.

comment:4 Changed 3 years ago by mrkang

Hi, just to help troubleshooting.. I have exactly the same problem with the snipping tool but also with the software yEd Graph Editor(also W7 x64). after I start it I create a new document and click around "wildly" at any of the forms in the right panel. => bluescreen

comment:5 Changed 3 years ago by vanto

I can confirm too that there is issues with VboxDisp driver on x64 guests. I am running Win 2003 SP2 64bit guest and everytime i try to control or connect to another Vbox remote guest and the resolution changes or just the remote machine refreshes then my machine crashes. I have performed Memory Dump debugging on my machine and the Vbox disply driver was the problem.

  • I have uninstalled the display driver and loaded the Default Standard VGA driver and everything is working fine since then.
  • The problemappears to be happining on 64bit machines. (I have tested 2 Win2k3 64 guests)
  • I am running vbox 4.1.2
  • Please fix it

thank you vanto

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #9508. Well, this ticket was earlier but #9508 contains a helpful minidump.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use