VirtualBox

Ticket #9188 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VBoxManage Minor Issues => Fixed in SVN

Reported by: TheShiv Owned by:
Priority: trivial Component: other
Version: VirtualBox 4.0.10 Keywords: VBoxManage
Cc: Guest type: Linux
Host type: Linux

Description

These are two small issues that I think would help users who rely solely on the VBoxManage utility.

1: When you create a VM through the GUI vs VBoxManage, the default settings are not 100% the same. I first noticed this when creating a RedHat guest through the GUI, then another through VBoxManage and saw that the GUI created VM had PAE and UTC enabled by default whereas the VBoxManage one did not. It's trivial but I would think the default settings should be the same regardless how the VM is created.

2: When using storagectl/storageattach in VBoxManage it requires you to use --port and --device for SATA controllers; I understand this for IDE controllers where you would have, for instance, port 0 device 1, however, shouldn't the SATA controller only require port since device should always be 0?

Thanks!

Change History

comment:1 Changed 3 years ago by klaus

Your issue 1 is expected behavior - the GUI sets up a relatively fancy VM config as part of the wizard. VBoxManage creates a VM, nothing else. No storage controllers, no VM settings changed relative to the "everything disabled" default.

Issue 2 is valid, and should make it into the next release.

comment:2 Changed 3 years ago by TheShiv

Thanks for the info, much appreciated.

comment:3 Changed 3 years ago by frank

  • Summary changed from VBoxManage Minor Issues to VBoxManage Minor Issues => Fixed in SVN

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use