VirtualBox

Ticket #8823 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Displays warning when not in vboxusers group

Reported by: debfx Owned by:
Priority: major Component: USB
Version: VirtualBox 4.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

VirtualBox 4.0.6 pops up a warning when opening VM settings and the user is not in the vboxusers group.
This is a regression from 4.0.4.

The warning is:

Failed to access the USB subsystem.

Result Code: NS_ERROR_FAILURE (0x00004005)
Component: Host
Interface: IHost {35b004f4-7806-4009-bfa8-d1308adba7e5}
Callee: IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Actually this is not a bug but a feature. If you don't need USB devices then you can ignore and disable this warning. If you need USB devices then the current user has to be member of the vboxusers group. This is documented in the user manual for a long time. In older releases it might have worked without being member of the vboxusers group in some cases but there was no guarantee. As of version 4.0.6, VBox depends on device links in the /dev/vboxusb directory.

comment:2 Changed 3 years ago by debfx

  • Status changed from closed to reopened
  • Resolution invalid deleted

It is a bug because

  • USB is enabled for new VMs even when the user is not a member of the vboxusers group
  • the warning is displayed even when the USB controller is deactivated

It would be really nice if the warning mentioned the reason for the failure and pointed the user to the documentation.

comment:3 Changed 3 years ago by frank

Hmm, that indeed makes a bit sense. But it is always hard to find the exact case why we cannot access USB devices as there are a couple of possible reasons. Well, we should probably check that vboxusers group issue and provide an additional hint in that case. OTOH, users are supposed to read the documentation ...

I agree that the warning should not appear if the USB controller is disabled, this is indeed a bug.

Regarding activating USB for new VMs: This is a different issue because enabling the USB controller is a good default and there are even virtual USB devices which don't need access to physical USB devices.

comment:4 Changed 3 years ago by debfx

enabling the USB controller is a good default

Ok, but then the warning should only be shown if there are active USB device filters.

I just want to make sure that people who don't actually use USB get a pop-up dialog warning.
Maybe the warning could be embedded into the USB settings tab.

comment:5 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

I think we fixed the warning in VBox 4.0.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use