VirtualBox

Ticket #8824 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

64 bit guests fail during boot on hosts using AMD E-350 mainboards => fixed in SVN/4.1.2

Reported by: level323 Owned by:
Priority: blocker Component: VMM/HWACCM
Version: VirtualBox 4.1.0 Keywords: 64bit guest AMD E-350 E350 amdfusion zacate
Cc: Guest type: Linux
Host type: Linux

Description

Hi there,

I have recently taken delivery of a system based on the ASUS E35M1-I Deluxe motherboard. This board uses the new AMD E-350 fusion APU's ("Zacate" cores). These E-350 APU's (the new name for CPU+GPU combined cores) are 64 bit and support AMD-V and RVI.

Attempts to boot 64bit linux distro (in my case, Linux Mint 10, which is derived from Ubuntu Maverick) fails almost immediately.

The host system is brand new and running an absolutely stock standard install of Linux Mint 10 64 bit OS.

Naturally, the initial step in building a Linux guest from scratch is to make the guest virtual CDROM use the Linux distro live/install ISO (in my case the Linux Mint 10 64 bit live/install ISO).

The guest begins booting off the virtual CDROM ISO and dies indelicately almost immediately after Grub hands off to the Linux Mint boot process. The guest dies due to a kernel panic (screenshot attached).

To try and isolate the cause of the problem, I installed VMWare 7.1 on the host and can report that it booted the Mint 64bit guest with no problems at all. So whatever the problem is, VMWare 7.1 doesn't suffer from it.

It seemed worthwhile to try fiddling with the guest settings to see if I could get around the problem. The only change that seemed relevant was to turn off RVI (virtualbox calls it "nested paging"). Alas, the guest still failed to boot but this time with a segfault instead of a kernel panic. Screenshot attached.

The virtualbox host is not adversely affected in any way by the failure of the guest. The paniced/segfaulted guest can be powered off as per normal. Attached is a log file anyway.

All BIOS updates for the host system have been applied.

Other vbox users are reporting similar problems - see the forums here (I was one of the posters):  http://forums.virtualbox.org/viewtopic.php?f=6&t=39361

Searching the interwebs revealed a few other people reporting the same problem with E-350 based hosts, and acknowledgement that VMWare will run 64 bit guests on E-350 hosts without issue.

I much prefer vbox so am looking forward to a resolution of this problem.

I suspect it's a nuance of the E-350 spec that's causing the problem. Not overly surprising as these cores are quite new. But they are getting more and more popular so I expect more and more vbox users are going to be experiencing this issue over the coming weeks/months.

At a stretch, I'm willing to provide a vbox developer with access to this system if absolutely necessary to root out the bug - this system isn't running in a production environment currently (mostly because of this bug).

Looking forward to a solution.

John

Attachments

chubby-client-edn02-2011-04-27-12-01-15.log Download (63.9 KB) - added by level323 3 years ago.
Virtualbox log
Screenshot-chubby-client-edn02-nested-paging-enabled.png Download (31.5 KB) - added by level323 3 years ago.
Screenshot of guest (nested paging enabled)
Screenshot-chubby-client-edn02-nested-paging-disabled.png Download (13.4 KB) - added by level323 3 years ago.
Screenshot of guest (nested paging disabled)
chubby-client-edn02-2011-05-03-10-37-55-nested-paging-enabled.log Download (63.9 KB) - added by level323 3 years ago.
log file (guest config set to enable nested paging)
VBox.log.3 Download (68.2 KB) - added by davidgood 3 years ago.
Win7 x64

Change History

Changed 3 years ago by level323

Virtualbox log

Changed 3 years ago by level323

Screenshot of guest (nested paging enabled)

Changed 3 years ago by level323

Screenshot of guest (nested paging disabled)

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

Thanks for this report. Could you attach an additional VBox.log file for nested paging enabled?

Changed 3 years ago by level323

log file (guest config set to enable nested paging)

comment:2 in reply to: ↑ 1 Changed 3 years ago by level323

Replying to frank:

Thanks for this report. Could you attach an additional VBox.log file for nested paging enabled?

Just attached, as per your request. Thanks!

comment:3 in reply to: ↑ description Changed 3 years ago by level323

I can also report that I just installed Ubuntu 11.04 (Natty) 64 bit on this host, along with VirtualBox 4.0.6 64bit and any attempt to boot a Natty 64bit guest fails in the same way.

comment:4 Changed 3 years ago by davidgood

I have an HP dm1-3025dx with AMD E-350 running Win7 x64 host. I enabled SMV in the BIOS but trying to install Ubuntu 11.04 (Natty) fails with the message the the Ubuntu x64 kernel doesn't support i686. For some reason the guest is seeing the machine as i686.

comment:5 Changed 3 years ago by frank

davidgood, please attach a VBox.log file of such a VM session.

Changed 3 years ago by davidgood

Win7 x64

comment:6 Changed 3 years ago by frank

  • Component changed from other to VMM/HWACCM

comment:7 Changed 3 years ago by level323

I've got AMD Fusion boxes here that I can't deploy because of this bug.

Would one of the developers like root access to an AMD fusion box in order to fix this blocker?

comment:8 Changed 3 years ago by msg7086

mark. same crash for 64-on-64 on my ASUS E-350 laptop. i tried debian64 on win7-64, VBox 4.0.10.

comment:9 Changed 3 years ago by Lykos

Same here on opensuse 11.4 64 with any 64 bit guest (sabayon, opensuse, kubuntu) VBox 4.0.10 I can test anything that is needed.

comment:10 Changed 3 years ago by frank

Do I understand it correct that only 64-bit guests are affected, that is, do 32-bit guests run well on this hardware?

davidgood, in your case the log clearly says VERR_SVM_DISABLED meaning that AMD-V is disabled. Are you sure that you enabled the correct item in the BIOS?

comment:11 Changed 3 years ago by Lykos

only 64 bit guests are affected, 32 bit guests run well (performed opensuse 11.4 32 bit installation)

comment:12 Changed 3 years ago by level323

Frank: Yes, 32-bit guests run just fine. 64bit guests will not. I've had 32-bit guests running on my E-350 boxes continually since I opened this ticket - because of this bug I have no other option if I wish to use virtualbox.

Reiterating for information purposes that VMWare Workstation does not have this bug - 64 and 32bit guests work fine on my E350 under vmware workstation.

comment:13 Changed 3 years ago by hodgeb

I've had this exact same problem as stated here in this thread, multiple different ways. I've encountered every single problem as described here on two different boards (Asus and Asrock), running both Debian and Ubuntu with Virtualbox up through 4.0.10 from 4.0.6 (IIRC). Booting Windows or Linux 32 bit, everything is OK. Booting 64 bit Linux, I get a RIP error (IIRC) and booting 64 bit Windows installer results in the installer failing consistently at roughly the same part (early, as it's loading shit) with a fairly random "hardware" related error (which is seemingly different each time - bad memory, etc.).

Interestingly, XenServer's dom0 has the same problem, I think, though its manifesting differently. VMWare does not.

comment:14 Changed 3 years ago by stuartmd

I'm experiencing similar issues - Windows 64-bit guest running on various host OSs on an AMD E-350 laptop. As with hodgeb's comments, it tends to manifest as hardware/memory related issues resulting in various blue screen conditions during the Windows 7 boot process. I suspect there's already sufficient log files available, but am happy to help if I can.

comment:15 Changed 3 years ago by at141am

Hello - I have the same issue when trying to run 64bit guests on the ideapad s205 which is a Zacate e350 based system. Please let me know if I can contribute any log files or other information.

comment:16 Changed 3 years ago by level323

Because VB 4.1.0 is out and it contains a large number of bug-fixes, I thought I'd try running it on my AMD E-350 machine to see if it fixed this particular bug as a side-effect. No dice. This bug still exists with VB 4.1.0

comment:17 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.0.6 to VirtualBox 4.1.0

Thanks so far for all these reports. We confirm that we know that there are problems with 64-bit guests on this hardware and we are currently investigating the problem. We will announce the fix when appropriate.

comment:18 Changed 3 years ago by aeichner

  • Summary changed from 64 bit guests fail during boot on hosts using AMD E-350 mainboards to 64 bit guests fail during boot on hosts using AMD E-350 mainboards => fixed in SVN/4.1.2

Thanks for reports again. The bug will be fixed in the next maintenance release. If someone wants to test the fix just drop a note here with the host system you need a build for and we will provide a test build.

comment:19 Changed 3 years ago by Lykos

I want to test, I am on opensuse 11.3(/12.1) x86-64

comment:20 Changed 3 years ago by level323

I would like to test it. I'm on Linux Mint Debian Edition (essentially Debian Testing) x86-64 and Linux Mint 11 x86-64

comment:21 Changed 3 years ago by stuartmd

I would like to test. I'm running Windows 7 (64-bit)

comment:22 Changed 3 years ago by aeichner

Windows:  http://www.virtualbox.org/download/testcase/VirtualBox-2011-08-01-14-30-09-win-rel-4.1.1-r73247-MultiArch.exe

Linux x86-64:  http://www.virtualbox.org/download/testcase/VirtualBox-2011-08-01-14-18-23-lin64-rel-4.1.1-r73247.run

I uploaded the generic .run installation file for Linux only because the distribution packages are not built automatically.

comment:23 Changed 3 years ago by msg7086

just wanna say i'm using the windows build and it works just fine with debian64 guest.

(only except the bridge networking not work, seems not related to this issue)

Thank you for the fix

comment:24 Changed 3 years ago by stuartmd

Windows build runs fine with a Windows7-64 guest. Many thanks!

comment:25 Changed 3 years ago by frank

The fix can be found in r38243.

comment:26 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix contained in VBox 4.1.2.

comment:27 Changed 3 years ago by Minus

could you tell me how install the fix please??

Thank you

comment:28 Changed 3 years ago by frank

  1. Your '?' key is probably defect, it bounces.
  2. Just install VirtualBox 4.1.2 which was released this week, it contains the fix.

comment:29 Changed 3 years ago by builtofire

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello All,

i seem to experience this issue with 4.1.2 amd64 on the following hardware :

ASUS E35M1 deluxe, SVM enabled, on ubuntu 10.04 amd64 Linux 2.6.32-33-generic #72-Ubuntu SMP Fri Jul 29 21:07:13 UTC 2011 x86_64 GNU/Linux

the error message is : VT-x/AMD-V hardware acceleration has been enabled, but is not operational. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

Please ensure that you have enabled VT-x/AMD-V properly in the BIOS of your host computer.

thank you, have a nice day.

comment:30 follow-up: ↓ 31 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

builtofire, your problem is different. As the message says, go to the BIOS and check if "virtualization" is enabled there. If yes and you still have problems, open a separate ticket.

comment:31 in reply to: ↑ 30 Changed 3 years ago by builtofire

Replying to frank:

builtofire, your problem is different. As the message says, go to the BIOS and check if "virtualization" is enabled there. If yes and you still have problems, open a separate ticket.

Hi, thanks for the reply, you are right

i removed the kvm_amd, kvm modules and virtualbox is not complaining anymore.

(yes virtualization was enabled in bios)

thank you, have a nice day

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use