VirtualBox

Ticket #72 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Fails to resize X display in Linux guest

Reported by: Val Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Slackware Linux 11 guest VirtualBox 1.3.4 (Windows XP host) fails to resize X display using standard X mechanisms (i.e. Ctrl+Alt+{+,-}). X server used there is X.Org 6.9.0. I haven't tested other distros/X servers.

Steps to reproduce:

  1. Start X server
  2. Press Ctrl-Alt-Gray- to reduce screen size

Expected results:

  • Screen resoultion and thus VirtualBox window is reduced

Actual results:

  • The resolution is changed, but the screen becomes black and

sometimes shows garbage. X hung and needs to be killed.

The problem occurs with or without Guest Additions installed.

If you need any further information, it will be provided upon request.

Attachments

screen.PNG Download (292.4 KB) - added by Blazeix 6 years ago.

Change History

comment:1 Changed 7 years ago by sandervl73

Try again with 1.4.0 please.

comment:2 Changed 7 years ago by Val

Good news are it does not hang anymore in 1.4.0 Bad news are it still doesn't resize properly - you get only randomly placed pieces of what was previously on the screen.

comment:3 Changed 7 years ago by mikerobi

I can confirm this behavior with Xubuntu 7.04 (same x server as ubuntu/kubuntu.) running with 1.4.0 on an XP host, and 1.3.99-beta1 OS/X host.

comment:4 Changed 7 years ago by frank

To make it clear: You are changing the resolution of the host and expect that the VirtualBox guest window changes the resolution as well? Because pressing <CTRL>+<ALT>+<->/<+> is not passed to the guest.

Changed 6 years ago by Blazeix

comment:5 follow-up: ↓ 6 Changed 6 years ago by Blazeix

I have this same issue as well. VBox 1.5.2, Windows XP Pro SP2 host, Xubuntu 7.10 guest. @frank, not quite. The host screen resolution is not being changed at all. The guest OS resolution is being changed, and the guest display becomes garbled. Note that in the description of the ticket they are on a Windows XP host. So every reference to X is referencing the Linux guest.

I have found that if I edit the "screen" section in xorg.conf to contain the desired resolution, it works fine. If xorg.conf does not have an entry for the resolution, and you try to switch to using that resolution, then it fritzes out.

I've attached a screenshot of the issue.

comment:6 in reply to: ↑ 5 Changed 6 years ago by michael

Replying to Blazeix: I'm afraid that I didn't quite follow you there - how did you set the resolution in the guest without setting it in xorg.conf?

comment:7 Changed 6 years ago by hramrach

Normally you do not set up any particular resolution or set up multiple resolutions in xorg.conf

Then it is possible to switch between the resolutions you set up (or 320x200 .. your maximum supported resolution) with Ctrl+Alt+Num+, Ctrl+Alt+Num-, or xrandr (a command line application)

comment:8 Changed 4 years ago by Technologov

Is this still relevant for VBox v3.x ?

-Technologov

comment:9 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use