VirtualBox

Ticket #8647 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Restore snapshot produces inconsistent uuids across VirtualBox.xml / MyMachine.xml

Reported by: tikitu Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

After restoring a snapshot from the GUI (where Current State is not identical to the snapshot), MyMachine.xml contains an <Image uuid="{}"> tag but the uuid it references does not occur in VirtualBox.xml. (A vmdk file with the corresponding name is created in the Snapshots directory.)

This produces the error reported in ticket  8595, when VirtualBox next starts up.

(In fact the VirtualBox.xml file is not changed at all; I don't know whether the correct behaviour would be to write the new uuid through to the media registry or to not change it in the machine's own config file, but they certainly shouldn't be getting out of synch.)

Attached files: .shutdown.xml are the files after I've shut the machine down and exited the GUI; .shutdown-restore.xml are from starting the GUI again, restoring the previous snapshot, and exiting the GUI. (Also a logfile is attached, perhaps you'll make more of it than I did.)

My details: Host Ubuntu 10.04.2 64-bit, Debian package virtualbox-4.0 (4.0.4-70112~Ubuntu~lucid); guest Ubuntu server. (Not setting properties because I doubt it's relevant -- I've seen forum posts from windows users with apparently the same issue.)

Change History

comment:1 Changed 3 years ago by Technologov

Duplicate of Bug #8648

-Technologov

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by tikitu

Aw bugger, chrome crashed submitting the form and I didn't think to check if it nonetheless arrived. Egg on my face.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use