VirtualBox

Ticket #8648 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Restore snapshot produces inconsistent uuids across VirtualBox.xml / MyMachine.xml

Reported by: tikitu Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

After restoring a snapshot from the GUI (where Current State is not identical to the snapshot), MyMachine.xml contains an <Image uuid="{}"> tag but the uuid it references does not occur in VirtualBox.xml. (A vmdk file with the corresponding name is created in the Snapshots directory.)

This produces the error reported in ticket  8595, when VirtualBox next starts up.

(In fact the VirtualBox.xml file is not changed at all; I don't know whether the correct behaviour would be to write the new uuid through to the media registry or to not change it in the machine's own config file, but they certainly shouldn't be getting out of synch.)

Attached files: {VirtualBox,BasicUbuntuInstall}.shutdown.xml are the files after I've shut the machine down and exited VirtualBox; .shutdown-restore.xml are from starting the GUI again, restoring the previous snapshot, and exiting the GUI. (Also a logfile is attached, perhaps you'll make more of it than I did.)

My details: Host Ubuntu 10.04.2 64-bit, Debian package virtualbox-4.0 (4.0.4-70112~Ubuntu~lucid); guest Ubuntu server. (Not setting properties because I doubt it's relevant -- I've seen forum posts from windows users with apparently the same issue.)

Attachments

BasicUbuntuInstall.shutdown.xml Download (34.2 KB) - added by tikitu 3 years ago.
Machine's config file after shutting down (current state changed)
VirtualBox.shutdown.xml Download (3.3 KB) - added by tikitu 3 years ago.
VirtualBox config after shutting down machine (current state changed)
BasicUbuntuInstall.shutdown-restore.xml Download (34.2 KB) - added by tikitu 3 years ago.
Machine's config file after restoring snapshot
VirtualBox.shutdown-restore.xml Download (3.3 KB) - added by tikitu 3 years ago.
VirtualBox config after restoring snapshot
VBox.log Download (72.7 KB) - added by tikitu 3 years ago.

Change History

Changed 3 years ago by tikitu

Machine's config file after shutting down (current state changed)

Changed 3 years ago by tikitu

VirtualBox config after shutting down machine (current state changed)

Changed 3 years ago by tikitu

Machine's config file after restoring snapshot

Changed 3 years ago by tikitu

VirtualBox config after restoring snapshot

Changed 3 years ago by tikitu

comment:1 Changed 3 years ago by tikitu

NB: If you restore a snapshot when the current state hasn't changed, nothing goes wrong: a new uuid appears in both config files and everything stays in synch.

comment:2 Changed 3 years ago by poulbak

I can confirm this bug, in fact I came here just to report it.

VirtualBox version: 4.0.4 My host is Windows 7 64-bit, guests are XP and Kubuntu, happens for both.

This has started in version 4.0, I think, never saw it in 3.x. What I see is: After restoring the snapshot, everything looks normal, going into device manager shows the correct disks, no phantoms. Only after shutting down and restarting will the old (now deleted) disk show up, which VBox obviously can't find.

This happens, whether I kill the WM from the VM shutdown menu (with 'revert' checked) or I manually revert after the VM has been shut down.

I read somewhere, that the VBox service is shutting down a few seconds after the GUI, is it that service creating the ghost entries?

Anyway, this is of course mainly annoying, since I can manually remove the entries from the device manager, but would nice to have it fixed.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #8363.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use