VirtualBox

Ticket #8566 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VERR_NOT_SUPPORTED error when trying to add RAW vmdk disk on VBox 4.0.4 running on Windows

Reported by: audrunas Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.4 Keywords: vmdk raw VERR_NOT_SUPPORTED
Cc: Guest type: other
Host type: Windows

Description

Hello,

I know that this bug has been reported before and has a status of being fixed (tickets #7811 and #7251), but it is definitely present in version 4.0.4 , so this is not a duplicate.

I have the following problem running VBox on Windows 7 Host:

  1. I created a raw vmdk disk using the following command:
    VBoxManage internalcommands createrawvmdk -filename D:\VirtualPC\Physical_Ubuntu\disk.vmdk -rawdisk \.\PhysicalDrive0 -partitions 5,6
    RAW host disk access VMDK file D:\VirtualPC\Physical_Ubuntu\disk.vmdk created successfully.
    
  1. Then I tried to add it to a virtual machine and I got the following error message:
    Failed to open the hadr disk D:\VirtualPC\Physical_Ubuntu\disk-pt.cmdk .
    Result Code: 
    VBOX_E_IPRT_ERROR (0x80BB0005)
    Component: 
    Medium
    Interface: 
    IMedium {9edda847-1279-4b0a-9af7-9d66251ccc18}
    Callee: 
    IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}
    

I hope this helps you. Thank you for such a great product! I am enjoying using VirtualBox.

Attachments

disk.vmdk Download (863 bytes) - added by audrunas 3 years ago.
disk-pt.vmdk Download (95.5 KB) - added by audrunas 3 years ago.

Change History

Changed 3 years ago by audrunas

Changed 3 years ago by audrunas

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #8567.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use