VirtualBox

Ticket #7251 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

createrawvmdk seems broken in 3.2.6 => fixed in SVN

Reported by: dubuscyr Owned by:
Priority: minor Component: VMM/RAW
Version: VirtualBox 3.2.6 Keywords: verr_not_supported createrawvmdk
Cc: Guest type: Linux
Host type: Mac OS X

Description

Hi all,

I'm reporting this because I think this is a bug. At least, I can reproduce it.

I'm trying to use a USB Key (physical) as a virtual disk for a VM. For this, I looked at the documentation, and I found something at 9.7.1.1 :

VBoxManage internalcommands createrawvmdk -filename /path/to/file.vmdk -rawdisk /dev/sda

I apply this to my case, the command runs well. But when I start my VM with this vmdk disk, I got exactly the same error as Beren in this topic :

 http://forum.virtualbox.org/viewtopic.php?f=8&p=147197

The screenshot is available here :  http://www.joelandmeg.com/webpics/win7shot.png

I tried to downgrade Vbox to the 3.0.8 version, and everything is working well.

That's why I think that the createrawvmdk command is broken in the last version.

I'm running MacOs X SL 10.6.4

Cyril

Change History

comment:1 Changed 3 years ago by klaus

  • Summary changed from createrawvmdk seems broken in 3.2.6 to createrawvmdk seems broken in 3.2.6 => fixed in SVN

The workaround is disabling the use of the new async I/O code... done by ticking "Use host I/O cache" for the SATA (and SCSI) controllers.

The fix will show up in 4.0.0_BETA4 and the next 3.2 maintenance release.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use