VirtualBox

Opened 14 years ago

Closed 14 years ago

#7811 closed defect (duplicate)

VERR_NOT_SUPPORTED when using raw vmdk on OSX

Reported by: Tinco Owned by:
Component: other Version: VirtualBox 3.2.12
Keywords: Cc:
Guest type: other Host type: other

Description

When you create a raw disk vmdk image like so:

VBoxManage internalcommands createrawvmdk -filename arch_disk1.vmdk

-rawdisk /dev/disk2

You get a vmdk file like the one attached.

When you select it as a hard disk for a virtual machine, it will throw the following error before booting:

VD: error VERR_NOT_SUPPORTED opening image file '/Users/tinco/smurfer2.vmdk' (VERR_NOT_SUPPORTED). VD: error VERR_NOT_SUPPORTED opening image file '/Users/tinco/smurfer2.vmdk' (VERR_NOT_SUPPORTED). Failed to open image '/Users/tinco/smurfer2.vmdk' in read-write mode rc=VERR_NOT_SUPPORTED (VERR_NOT_SUPPORTED). Failed to attach driver below us! Not supported. (VERR_NOT_SUPPORTED). AHCI: Failed to attach drive to Port0 (VERR_NOT_SUPPORTED). Unknown error creating VM (VERR_NOT_SUPPORTED).

## Details

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

A work around that works suggested by klaus-vb is to enable "use host I/O cache" on the SATA controller"

Attachments (1)

arch_disk1.vmdk (633 bytes ) - added by Tinco 14 years ago.
erronous vmdk file

Download all attachments as: .zip

Change History (2)

by Tinco, 14 years ago

Attachment: arch_disk1.vmdk added

erronous vmdk file

comment:1 by Klaus Espenlaub, 14 years ago

Resolution: duplicate
Status: newclosed

Turned out to be a duplicate of #7251

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use