VirtualBox

Ticket #8414 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Cannot restore snapshot with USB pack uninstalled

Reported by: romkyns Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

If the Extras pack is not installed, it is perfectly possible to START a VM that has USB configured. It warns that USB will actually be disabled, and gets on with it. Everything works fine.

If you then make a snapshot and try to restore it, it will say that USB is enabled but not installed, and hence the snapshot cannot be restored. I haven't found a way to convince VirtualBox to disregard USB, so for now it's a snapshot-loss bug, which is quite serious.

"Implementation of the USB 2.0 controller not found!"

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

That's a duplicate of #8182. Actually we should never have allowed the user to start a VM with USB enabled but without the Extension Pack installed. This will be fixed in the next maintenance release. For fixing your VM have a look at #8182.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use