VirtualBox

Ticket #8340 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

Keyboard/mouse non-responsive in Ubuntu 10.04 guest -> USB filter setup issue

Reported by: dorsey Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Ubuntu Lucid 10.04

Guest: Ubuntu Lucid 10.04

During install the keyboard and mouse worked. On first boot of the guest operating system the keyboard worked, then updates were installed. During boot of the guest, the keyboard appears to work, but once guest gets to GNOME desktop, the keyboard and mouse are both nonresponsive. Host key will not disengage the keyboard from the guest either, forcing a hard reboot. This is not the issue with the host screensaver previously reported; screen saver never activates on host and keyboard/mouse never works in guest.

Attachments

VBox.log Download (50.0 KB) - added by dorsey 3 years ago.
Log from after issue started occurring
VBox.log.3 Download (75.9 KB) - added by dorsey 3 years ago.
Log from before issue started occurring

Change History

Changed 3 years ago by dorsey

Log from after issue started occurring

Changed 3 years ago by dorsey

Log from before issue started occurring

comment:1 Changed 3 years ago by dorsey

More info: We tried killing the VirtualBox instance via SSH after we lost keyboard and mouse. Upon doing so, keyboard and mouse were still non-responsive in the guest, but unplugging and replugging both got them responding again.

comment:2 Changed 3 years ago by dorsey

So after the last comment we took the results to the logical conclusion: we booted the VM, the mouse and keyboard were unresponsive, then we unplugged and replugged the mouse and keyboard. That workaround made the mouse and keyboard start working again in both the host and the guest.

comment:3 Changed 3 years ago by dorsey

And that only worked for a short period of time before the virtual machine completely froze and caused the keyboard and mouse to stop responding again.

comment:4 Changed 3 years ago by dorsey

OK, we resolved the issue. The filters for the USB keyboard and mouse were checked under the USB tab of the Settings. Upon unchecking them, the keyboard and mouse worked as expected.

comment:5 Changed 3 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from Keyboard/mouse non-responsive in Ubuntu 10.04 guest to Keyboard/mouse non-responsive in Ubuntu 10.04 guest -> USB filter setup issue

Thanks for letting us know.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use