VirtualBox

Ticket #8341 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

4.0.2 Guest Additions breaks Windows Media Player in Windows 7

Reported by: allencp Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

After installing the guest additions for 4.0.2, Windows 7 is unable to play video in Media Player. The following error appears:

Windows Media Player cannot play the video because there is a problem with your video card.

Typically occurs while trying to play an MPEG1 or MPEG2 video clip. Uninstall the guest additions and it works fine.

Attachments

VBox.log Download (84.3 KB) - added by allencp 3 years ago.

Change History

Changed 3 years ago by allencp

comment:1 Changed 3 years ago by ramshankar

  • Guest type changed from other to Windows

comment:2 Changed 3 years ago by eblaine

Update: Conducted further troubleshooting on this issue with 4.0.6. Workstation is running Solaris 10 update 9, Windows 7 32-bit as a guest.

When the guest additions are not installed, videos work fine.

When the guest additions are installed but D3D support is disabled, videos work fine.

When the guest additions are installed and D3D support is enabled, the videos do not work.

Additionally, HD video playback is extremely choppy with quite a few artifacts the first time it is accessed. If the video is restarted it plays back perfectly.

comment:3 Changed 3 years ago by ramshankar

Could you please try with the latest additions (4.1.0) which has a WDDM based driver for Windows guests.

comment:4 Changed 3 years ago by allencp

I tried with the latest additions and it still exhibits the problem. It should be noted that this is occurring in Windows 7 64-bit.

comment:5 follow-up: ↓ 7 Changed 3 years ago by allencp

Several things to add. First, this problem is exhibited with 32-bit version of Windows 7. However, we attempted installing Wine3D and it fixed the problem for 32-bit, but not 64-bit.

comment:6 Changed 2 years ago by misha

Assuming you have

  1. The VBox XPDM video driver is installed (aka "Basic D3D support", NO Aero support) and
  2. The 3D support is installed in safe mode ..

Could you check whether %windir%\SysWOW64\MSD3D9.dll & %windir%\SysWOW64\MSD3D8.dll and windir%\System32\MSD3D9.dll & %windir%\System32\MSD3D8.dll files are present on your guest system.
This should hopefully give us a clue as to why video does not work with 3D settings disabled.

As for the case with 3D enabled, could you please specify:

  1. Whether you have any codecs installed on the guest system
  2. Post here [a link to] some sample video file(s) which is known to cause the playback issues.

comment:7 in reply to: ↑ 5 Changed 2 years ago by misha

Replying to allencp: Also, what Wine3D package did you install on guest and how did you install it, that solved the problem for 32-bit guest, and did not solve it for 64-bit one?

comment:8 Changed 2 years ago by eblaine

The VirtualBox 3D drivers were installed in safe mode and "Basic D3D support" was selected. Attempts to replicate this issue should be done with 3D acceleration enabled with VBoxManage --modifyvm as that is how our production workstation will be configured.

No third-party instances of WineD3D are being used anymore, just what comes with the VirtualBox guest additions drivers. We performed a clean install of Windows 7 Enterprise 64-bit and have only used the VBox guest additions to replicate the issue recently.

A sample video file can be found in any Windows 7 install at C:\Users\Public\Videos\Sample Videos\Wildlife.wmv

I did further testing today with AVI and MPG files and they return an error in Windows Media Player stating there was a problem with the video card and simply refuses to play the file. With the Wildlife.wmv listed above it attempts to play but the video windows becomes corrupted.

comment:9 Changed 2 years ago by misha

We've made a set of fixes that should hopefully solve the video playback problem you're seeing.

To summarize the problem, there were two different issues actually, although the symptoms could be pretty much the same.

  1. The playback problem seen with the "3D" DISABLED in a VM settings - is

caused by Microsoft d3d system files (d3d9.dll & d3d8.dll) removal caused by a bug in Guest Additions installer. We've fixed the installer, but unfortunately there is no way we can restore the system files since they are physically absent on the guest system. So Guest Addition installer now checks if d3d system files are missing and if so, displays a warning dialog pointing to VBox manual, where we added a step-by-step guide on restoring the missing d3d files.

  1. The playback problem seen with the "3D" ENABLED in a VM settings - is

caused by wined3d bugs that we've fixed also.

I've uploaded a test build to:  http://www.virtualbox.org/download/testcase/VirtualBox-2011-12-15-14-17-04-sol-rel-4.1-4.1.7-SunOS-r75422.tar.gz which includes Solaris Host VBox installation containing the updated manual as well as updated guest additions with all necessary fixes included. The link is valid for 14 days.

Please give it a try and let let me know if all the issues are fixed now.

comment:10 Changed 2 years ago by frank

Please test VBox 4.1.8.

comment:11 Changed 2 years ago by eblaine

VirtualBox 4.1.7 and 4.1.8 fixed the problem, thanks!

comment:12 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use