VirtualBox

Ticket #8275 (reopened defect)

Opened 5 years ago

Last modified 7 months ago

3D accelerated OpenGL 1.5 occlusion query support missing

Reported by: net147 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by misha) (diff)

Host: Windows 7 Ultimate 64-bit Guest: Windows XP Professional SP3 32-bit 3D acceleration: Enabled

The Windows XP guest reports the OpenGL version as "2.1 Chromium 1.9". However not all OpenGL features up until OpenGL 2.1 are supported. The following OpenGL 1.5 functions are missing: glBeginQuery, glDeleteQueries, glEndQuery, glGenQueries, glGetQueryObjectiv, glGetQueryObjectuiv, glGetQueryiv, glIsQuery. This means that OpenGL programs that expect full OpenGL 2.1 support may crash if it uses the OpenGL version string to determine whether or not it can use OpenGL 1.5 occlusion queries.

Attached is output from glewinfo which lists extensions that are present/missing.

Attachments

glewinfo.txt Download (184.1 KB) - added by net147 5 years ago.
GLEW Extension Info
glxinfo-v4.3.22-linux-guest.txt Download (21.7 KB) - added by sam123 7 months ago.
glewinfo-v4.3.22-linux-guest.txt Download (198.9 KB) - added by sam123 7 months ago.

Change History

Changed 5 years ago by net147

GLEW Extension Info

comment:1 Changed 4 years ago by magnesj

Same happens for Win7 x64 host with Win7 x64 guest

comment:2 Changed 4 years ago by net147

Still occurs in VirtualBox 4.0.4.

comment:3 follow-up: ↓ 4 Changed 4 years ago by net147

Still occurs in VirtualBox 4.0.6.

comment:4 in reply to: ↑ 3 Changed 4 years ago by audiofanatic

Any chance this ticket will get some attention soon? It is still not addressed in 4.1.2. I'm working on a project that does indeed fail because it expects full OpenGL 2.1 support and it verifies that what should be there is indeed available as part of its initialization. There's enough special case handling for Mesa bugs on linux without having to start adding things in for VirtualBox too (that starts getting too complicated and harder to maintain).

comment:5 Changed 4 years ago by audiofanatic

It's also worth pointing out that according to the glew output in the original report, the equivalent ARB functions for the missing query functions are actually present, so this should really be a relatively simple deficiency to fix.

comment:6 Changed 4 years ago by net147

Still occurs in VirtualBox 4.1.4.

comment:7 Changed 3 years ago by Giniu

I can confirm it still occurs in VirtualBox 4.1.12, Linux host, Linux guest.

comment:8 Changed 22 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

This issue should be fixed with VBox 4.3 & 4.3 Additions.
I'm seeing glewinfo reports occlusion query as supported.
Could you give it a try and re-open if needed?

Changed 7 months ago by sam123

Changed 7 months ago by sam123

comment:9 Changed 7 months ago by sam123

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am seeing the very same missing OpenGL 1.5 features in VirtualBox 4.3.22 with the matching Guest Additions, in a Windows 7 host and Fedora 20 linux guest. I am attaching sample output from glxinfo (glxinfo-v4.3.22-linux-guest.txt) and glewinfo (glewinfo-v4.3.22-linux-guest.txt). Furthermore, those utilities themselves print the following messages to stderr:

pci id for fd 4: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo

I wasn't sure whether to reopen or file a new issue. Please let me know if I should file a new issue instead.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use