VirtualBox

Ticket #8274 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VBox 4.0.2 delete snapshot error with running VM

Reported by: cdp-ava Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.0.2 Keywords: snapshot
Cc: Guest type: Windows
Host type: Windows

Description

Host: Win7 x64 Guest: Win7 x32

Snapshots can be created via vboxmanage for the running image, but cannot be deleted while the virtual guest is running. For example:

Microsoft Windows [Version 6.1.7600] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\dbear>cd "\Program Files\Oracle\VirtualBox"

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe snapshot Win7 take backup1 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe snapshot Win7 delete backup1 0%... Progress state: RPC_E_SERVERFAULT VBoxManage.exe: error: Snapshot operation failed. No error message available! -=-=-=-=-=-=-= Once the guest is shut-down, the snapshot is then able to be deleted: C:\Program Files\Oracle\VirtualBox>VBoxManage.exe snapshot Win7 delete backup1 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

Attachments

VBox.log Download (69.5 KB) - added by cdp-ava 3 years ago.
Guest log file

Change History

Changed 3 years ago by cdp-ava

Guest log file

comment:1 Changed 3 years ago by frank

Confirmed. Windows 64-bit host problem. Actually related to #8005 -- same problem even if it sounds different. But I will keep this ticket open.

comment:2 Changed 3 years ago by klaus

Just out of curiosity - does the same (deleting a snapshot while the VM is running, 64bit windows host) work with VirtualBox 3.2? It uses pretty much the same code, and thus should also crash.

I wonder why no one reported this before, could be that 64bit windows is simply gaining lots of users lately.

comment:3 Changed 3 years ago by diagiman

I had reported just 355 tickets ago :)

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Will mark this as a duplicate of #8349 (yes, your ticket is older but anyway...)

comment:5 Changed 3 years ago by frank

To be more verbose: This sounds different but both tickets have the same cause (Windows 64-bit hosts only).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use